summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Andres2021-02-21 21:42:13 +0100
committerThomas Andres2021-02-21 21:42:13 +0100
commita3e68c61b35c3ff3ee553d25db70287953de97bd (patch)
treec7d2e1323e9e0d5c541f07e9601737fb9c0fdec9
downloadaur-a3e68c61b35c3ff3ee553d25db70287953de97bd.tar.gz
new package for the stable release of OpenHantek6022
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD41
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..371a65e1ff4b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = openhantek6022
+ pkgdesc = A DSO software for Hantek USB digital signal oscilloscopes 6022BE/BL.
+ pkgver = 3.1.5
+ pkgrel = 1
+ url = https://github.com/OpenHantek/OpenHantek6022
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cmake>=3.5
+ makedepends = make
+ makedepends = sed
+ makedepends = gcc>=4.3
+ makedepends = qt5-tools>=5.4
+ depends = fftw>=3
+ depends = qt5-base>=5.4
+ depends = qt5-svg>=5.4
+ depends = libusb>=1.0.16
+ provides = openhantek6022
+ conflicts = openhantek6022-git
+ conflicts = openhantek
+ conflicts = openhantek-git
+ source = OpenHantek6022::git+https://github.com/OpenHantek/OpenHantek6022.git
+ md5sums = SKIP
+
+pkgname = openhantek6022
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..20f88aa9a51d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Thomas Andres <thomas at andres dot in>
+pkgname=openhantek6022
+_gitname=OpenHantek6022
+pkgver=3.1.5
+pkgrel=1
+pkgdesc="A DSO software for Hantek USB digital signal oscilloscopes 6022BE/BL."
+arch=('i686' 'x86_64')
+url="https://github.com/OpenHantek/OpenHantek6022"
+license=('GPL3')
+depends=('fftw>=3' 'qt5-base>=5.4' 'qt5-svg>=5.4' 'libusb>=1.0.16')
+makedepends=('git' 'cmake>=3.5' 'make' 'sed' 'gcc>=4.3' 'qt5-tools>=5.4')
+conflicts=(openhantek6022-git openhantek openhantek-git)
+provides=(openhantek6022)
+source=("$_gitname::git+https://github.com/OpenHantek/OpenHantek6022.git")
+md5sums=('SKIP')
+
+prepare() {
+ cd $_gitname
+ # change the udev directory to match arch defaults
+ sed -i 's/\/lib\/udev\/rules.d\//\/usr\/lib\/udev\/rules.d\//g' CMakeLists.txt
+}
+
+pkgver() {
+ curl --silent https://api.github.com/repos/OpenHantek/OpenHantek6022/releases/latest | grep -Po '"tag_name": "\K.*?(?=")'
+}
+
+build() {
+ cd $_gitname
+ git checkout $pkgver -q
+ [[ ! -d build ]] && mkdir -p build
+ cd build
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ ../
+ make
+}
+
+package() {
+ cd $_gitname/build
+ make DESTDIR=$pkgdir install
+}