summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRihards Skuja2024-03-02 14:08:19 +0200
committerRihards Skuja2024-03-02 14:08:19 +0200
commitfa6bd485472f0d44fce36d232781bb592bdd528c (patch)
tree5a0bd90efc4bf4cde55f38765070b9607afb69b1
parent62c20ee3df284ef2dc783d708cb7dce809f4482d (diff)
downloadaur-fa6bd485472f0d44fce36d232781bb592bdd528c.tar.gz
fix failing wifibroadcast patch
-rw-r--r--.SRCINFO8
-rw-r--r--0001-fix-compile-on-gcc-13.patch28
-rw-r--r--0002-fix-compile-on-gcc-13.patch24
-rw-r--r--PKGBUILD12
4 files changed, 50 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 631e515719e2..8dfb931ccfd3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openhd-git
pkgdesc = Open-source digital FPV system
- pkgver = 2.5.0.beta3.r381.gf559237
- pkgrel = 2
+ pkgver = 2.5.3.r23.gb9ed014
+ pkgrel = 1
url = https://openhdfpv.org
arch = any
license = GPL3
@@ -22,7 +22,9 @@ pkgbase = openhd-git
conflicts = openhd
source = git+https://github.com/OpenHD/OpenHD.git
source = 0001-fix-compile-on-gcc-13.patch
+ source = 0002-fix-compile-on-gcc-13.patch
sha256sums = SKIP
- sha256sums = f5353f5411a41833a050cee54d9b461261c8a68eb9051547830960d06c0c0733
+ sha256sums = 7637ec59e85b4616d05d1f0c81a10fca921473b4b124c04e6506213718bb205a
+ sha256sums = 118befc82ae46153b407ea66fdf7ee4bc0043cb0d36308e124703da1d01f8a79
pkgname = openhd-git
diff --git a/0001-fix-compile-on-gcc-13.patch b/0001-fix-compile-on-gcc-13.patch
index cd2cff13b4e5..71926ef8e15c 100644
--- a/0001-fix-compile-on-gcc-13.patch
+++ b/0001-fix-compile-on-gcc-13.patch
@@ -1,26 +1,26 @@
-From f15c889cf40d7c96a01af1e12f443b14c27872ba Mon Sep 17 00:00:00 2001
+From f1111ce46894d3b51434e33a6f3461318dade5fd Mon Sep 17 00:00:00 2001
From: Rihards Skuja <rihards@skuja.eu>
-Date: Fri, 3 Nov 2023 15:41:01 +0200
+Date: Thu, 29 Feb 2024 11:40:31 +0200
Subject: [PATCH] fix compile on gcc 13
Without the header compilation fails with a bunch of
"'uint8_t' does not name a type" errors.
---
- src/HelperSources/StringHelper.hpp | 1 +
+ wifibroadcast/src/HelperSources/StringHelper.hpp | 1 +
1 file changed, 1 insertion(+)
-diff --git a/src/HelperSources/StringHelper.hpp b/src/HelperSources/StringHelper.hpp
-index f00bf9c..1e8e774 100644
---- a/src/HelperSources/StringHelper.hpp
-+++ b/src/HelperSources/StringHelper.hpp
-@@ -9,6 +9,7 @@
- #include <sstream>
+diff --git a/wifibroadcast/src/HelperSources/StringHelper.hpp b/wifibroadcast/src/HelperSources/StringHelper.hpp
+index 056b12d..9d16c94 100644
+--- a/wifibroadcast/src/HelperSources/StringHelper.hpp
++++ b/wifibroadcast/src/HelperSources/StringHelper.hpp
+@@ -6,6 +6,7 @@
+ #define OSDTESTER_STRINGHELPER_H
+
#include <array>
- #include <vector>
+#include <cstdint>
-
- class StringHelper {
- public:
+ #include <sstream>
+ #include <string>
+ #include <vector>
--
-2.42.1
+2.44.0
diff --git a/0002-fix-compile-on-gcc-13.patch b/0002-fix-compile-on-gcc-13.patch
new file mode 100644
index 000000000000..e704428454ce
--- /dev/null
+++ b/0002-fix-compile-on-gcc-13.patch
@@ -0,0 +1,24 @@
+From 79b881d9007d44023ab1c6c4d91c0933a1bc934f Mon Sep 17 00:00:00 2001
+From: Rihards Skuja <rihards@skuja.eu>
+Date: Thu, 29 Feb 2024 11:52:22 +0200
+Subject: [PATCH] fix compile on gcc 13
+
+---
+ OpenHD/ohd_common/inc/openhd_util.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/OpenHD/ohd_common/inc/openhd_util.h b/OpenHD/ohd_common/inc/openhd_util.h
+index 9890eaa3..6c4b1ba5 100644
+--- a/OpenHD/ohd_common/inc/openhd_util.h
++++ b/OpenHD/ohd_common/inc/openhd_util.h
+@@ -1,6 +1,7 @@
+ #ifndef OPENHD_UTIL_H
+ #define OPENHD_UTIL_H
+
++#include <cstdint>
+ #include <optional>
+ #include <string>
+ #include <vector>
+--
+2.44.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 246e2a5f0931..0713e5da1f11 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=openhd-git
_reponame=OpenHD
-pkgver=2.5.0.beta3.r381.gf559237
-pkgrel=2
+pkgver=2.5.3.r23.gb9ed014
+pkgrel=1
pkgdesc='Open-source digital FPV system'
arch=(any)
url='https://openhdfpv.org'
@@ -16,9 +16,10 @@ optdepends=(
)
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=("git+https://github.com/OpenHD/$_reponame.git" "0001-fix-compile-on-gcc-13.patch")
+source=("git+https://github.com/OpenHD/$_reponame.git" "0001-fix-compile-on-gcc-13.patch" "0002-fix-compile-on-gcc-13.patch")
sha256sums=('SKIP'
- 'f5353f5411a41833a050cee54d9b461261c8a68eb9051547830960d06c0c0733')
+ '7637ec59e85b4616d05d1f0c81a10fca921473b4b124c04e6506213718bb205a'
+ '118befc82ae46153b407ea66fdf7ee4bc0043cb0d36308e124703da1d01f8a79')
pkgver() {
cd "$_reponame"
@@ -28,7 +29,8 @@ pkgver() {
prepare() {
cd "$_reponame"
git submodule update --init --recursive
- patch -d 'OpenHD/lib/wifibroadcast' -p1 -i "$srcdir/0001-fix-compile-on-gcc-13.patch"
+ patch -d 'OpenHD/ohd_interface/lib/wifibroadcast' -p1 -i "$srcdir/0001-fix-compile-on-gcc-13.patch"
+ patch -p1 -i "$srcdir/0002-fix-compile-on-gcc-13.patch"
}
build() {