summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrenton Horne2024-03-31 20:04:28 +1000
committerBrenton Horne2024-03-31 20:04:28 +1000
commitee034bc490123bd5e732f41a8e849697464069cf (patch)
tree6d3ce982b4434b8bb94a1329a7f4dfcfaad12406
downloadaur-ee034bc490123bd5e732f41a8e849697464069cf.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore12
-rw-r--r--PKGBUILD35
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9b9593f34488
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = openhv-git
+ pkgdesc = An open-source SciFi RTS game based on OpenRA game engine.
+ pkgver = 2501.git.61fabc8
+ pkgrel = 1
+ url = https://www.openhv.net
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = unzip
+ depends = mono
+ depends = openal
+ depends = libgl
+ depends = freetype2
+ depends = sdl2
+ depends = lua51
+ depends = hicolor-icon-theme
+ depends = gtk-update-icon-cache
+ depends = desktop-file-utils
+ depends = xdg-utils
+ depends = zenity
+ options = !debug
+ source = git+https://github.com/OpenHV/OpenHV.git
+ sha512sums = SKIP
+
+pkgname = openhv-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5e76f0e8fa44
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,12 @@
+pkg
+src
+OpenHV
+*.xz
+*.gz
+Changelog.md
+.*.swp
+octave-workspace
+*.zst
+.RData
+.Rhistory
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bffad83c29e9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Brenton Horne <brentonhorne77 at gmail dot com>
+pkgname=openhv-git
+pkgver=2501.git.61fabc8
+pkgrel=1
+pkgdesc="An open-source SciFi RTS game based on OpenRA game engine."
+arch=('any')
+url="https://www.openhv.net"
+license=('GPL3')
+depends=('mono' 'openal' 'libgl' 'freetype2' 'sdl2' 'lua51' 'hicolor-icon-theme'
+ 'gtk-update-icon-cache' 'desktop-file-utils' 'xdg-utils' 'zenity')
+makedepends=('git' 'unzip')
+options=(!debug)
+source=("git+https://github.com/OpenHV/OpenHV.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $srcdir/OpenHV
+ no=$(git rev-list --count HEAD)
+ hash=$(git log | head -n 1 | cut -d ' ' -f 2 | head -c 7)
+ version="${no}.git.${hash}"
+ printf "$version"
+}
+
+build() {
+ cd OpenHV
+
+ make RUNTIME=mono TARGETPLATFORM=unix-generic
+}
+
+package() {
+ cd OpenHV
+
+ make prefix=/usr TARGETPLATFORM=unix-generic DESTDIR="$pkgdir" install
+ sed -i -e "s|./OpenRA|mono --debug /usr/lib/openhv/OpenRA.dll|g" $pkgdir/usr/bin/openhv
+}