summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2020-09-21 15:30:45 +0200
committerbartus2020-09-21 15:30:45 +0200
commitdfd12a9cddfc004c0fd1469a1fb75e2fef10ebec (patch)
treeef58d8d77a09801d659de65a6af812874d9d1ca5
parent1d40668ea8d56a96132242f831a22d02a7e9c4bd (diff)
downloadaur-dfd12a9cddfc004c0fd1469a1fb75e2fef10ebec.tar.gz
Extract git-lfs protocol to it's own package
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD16
2 files changed, 2 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5d66f0422ec2..70bfb652e14c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,7 +6,7 @@ pkgbase = openimagedenoise-develop
arch = x86_64
license = Apache
makedepends = git
- makedepends = git-lfs
+ makedepends = makepkg-git-lfs-proto
makedepends = cmake
makedepends = ispc>=1.14
makedepends = ninja
diff --git a/PKGBUILD b/PKGBUILD
index 28fec2c59e1f..46e8132cae7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,5 @@
# Maintainer : bartus <arch-user-repoᘓbartus.33mail.com>
-function download_git-lfs {
- local url dir
- url=${1#git-lfs+}
- download_git "$url"
- dir="$SRCDEST/$(get_filename "$url")"
- git -C "$dir" lfs install
- git -C "$dir" lfs fetch
-}
-
-function extract_git-lfs {
- url=${1/git-lfs/https}
- extract_git "$url"
-}
-
pkgname=openimagedenoise-develop
pkgver=1.2.3
_fragment="#tag=v${pkgver}"
@@ -24,7 +10,7 @@ url="https://www.openimagedenoise.org/"
license=('Apache')
depends=(intel-tbb python)
provides=("openimagedenoise=${pkgver%.r*}")
-makedepends=(git git-lfs cmake 'ispc>=1.14' ninja)
+makedepends=(git makepkg-git-lfs-proto cmake 'ispc>=1.14' ninja)
source=("${pkgname}::git+https://github.com/OpenImageDenoise/oidn.git${_fragment}"
"git+https://github.com/OpenImageDenoise/mkl-dnn.git"
"git-lfs+https://github.com/OpenImageDenoise/oidn-weights.git"