summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2024-03-07 17:22:19 +0100
committerbartus2024-03-07 17:22:19 +0100
commit1e5d7d848270e8ceb5642f98656c7986e987db92 (patch)
tree12234e3b5aa9544fa315a9735f871119cda15d90
parent657629b8623d31a6c47d3947a0908ed2a3256442 (diff)
downloadaur-1e5d7d848270e8ceb5642f98656c7986e987db92.tar.gz
Configure submodules with gh/gist: 41a3bfb707f1b258de061f75b109042b
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD27
2 files changed, 24 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 92751e4b847a..f0e0391449dc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,9 +14,11 @@ pkgbase = openimagedenoise-git
provides = openimagedenoise=2.2.0
conflicts = openimagedenoise
source = openimagedenoise::git+https://github.com/OpenImageDenoise/oidn.git
- source = git+https://github.com/OpenImageDenoise/mkl-dnn.git
- source = git+https://github.com/NVIDIA/cutlass
- source = git+https://github.com/ROCmSoftwarePlatform/composable_kernel
+ source = mkl-dnn::git+https://github.com/OpenImageDenoise/mkl-dnn.git
+ source = oidn-weights::git+https://github.com/OpenImageDenoise/oidn-weights.git
+ source = cutlass::git+https://github.com/NVIDIA/cutlass
+ source = composable_kernel::git+https://github.com/ROCmSoftwarePlatform/composable_kernel
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index f44fe18462b7..14bd6e93a050 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,21 +15,15 @@ provides=("openimagedenoise=${pkgver%.r*}")
conflicts=(openimagedenoise)
makedepends=(git cmake 'ispc>=1.14' ninja)
source=("${pkgname%-git}::git+https://github.com/OpenImageDenoise/oidn.git${_fragment}"
- "git+https://github.com/OpenImageDenoise/mkl-dnn.git"
- "git+https://github.com/NVIDIA/cutlass"
- "git+https://github.com/ROCmSoftwarePlatform/composable_kernel"
)
sha256sums=('SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
prepare() {
- git -C "${srcdir}"/${pkgname%-git} config submodule.mkl-dnn.url "${srcdir}"/mkl-dnn
- git -C "${srcdir}"/${pkgname%-git} config submodule.cutlass.url "${srcdir}"/cutlass
- git -C "${srcdir}"/${pkgname%-git} config submodule.external/composable_kernel.url "${srcdir}"/composable_kernel
- sed 's|../oidn-weights.git|https://github.com/OpenImageDenoise/oidn-weights.git|' -i "${srcdir}"/${pkgname%-git}/.gitmodules
- git -C "${srcdir}"/${pkgname%-git} -c protocol.file.allow=always submodule update --init --recursive # --remote
+ prepare_submodule
}
pkgver() {
@@ -47,4 +41,21 @@ package() {
DESTDIR=${pkgdir} ninja -C "build" install
}
+# Generated with git_submodule_PKGBUILD_conf.sh ( https://gist.github.com/bartoszek/41a3bfb707f1b258de061f75b109042b )
+# Call prepare_submodule in prepare() function
+
+prepare_submodule() {
+ git -C "$srcdir/openimagedenoise" config submodule.mkl-dnn.url "$srcdir/mkl-dnn"
+ git -C "$srcdir/openimagedenoise" config submodule.weights.url "$srcdir/oidn-weights"
+ git -C "$srcdir/openimagedenoise" config submodule.cutlass.url "$srcdir/cutlass"
+ git -C "$srcdir/openimagedenoise" config submodule.external/composable_kernel.url "$srcdir/composable_kernel"
+ git -C "$srcdir/openimagedenoise" -c protocol.file.allow=always submodule update --init --recursive
+}
+source+=(
+ "mkl-dnn::git+https://github.com/OpenImageDenoise/mkl-dnn.git"
+ "oidn-weights::git+https://github.com/OpenImageDenoise/oidn-weights.git"
+ "cutlass::git+https://github.com/NVIDIA/cutlass"
+ "composable_kernel::git+https://github.com/ROCmSoftwarePlatform/composable_kernel"
+)
+
# vim:set ts=2 sw=2 et: