summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2024-02-27 16:25:29 +0100
committerbartus2024-02-27 16:25:29 +0100
commit657629b8623d31a6c47d3947a0908ed2a3256442 (patch)
treea454b91d86c05c4b2f3b85800ae44dd67c4e02f8
parent2c477a41ae080604febe875f186aec27e4b57089 (diff)
downloadaur-657629b8623d31a6c47d3947a0908ed2a3256442.tar.gz
Drop lfs oidn-weights submodule (git-lfs makepkg proto needs fragment)
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 2 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c67c0406e478..92751e4b847a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,7 +6,6 @@ pkgbase = openimagedenoise-git
arch = x86_64
license = Apache
makedepends = git
- makedepends = makepkg-git-lfs-proto
makedepends = cmake
makedepends = ispc>=1.14
makedepends = ninja
@@ -16,13 +15,11 @@ pkgbase = openimagedenoise-git
conflicts = openimagedenoise
source = openimagedenoise::git+https://github.com/OpenImageDenoise/oidn.git
source = git+https://github.com/OpenImageDenoise/mkl-dnn.git
- source = git-lfs+https://github.com/OpenImageDenoise/oidn-weights.git
source = git+https://github.com/NVIDIA/cutlass
source = git+https://github.com/ROCmSoftwarePlatform/composable_kernel
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = SKIP
pkgname = openimagedenoise-git
diff --git a/PKGBUILD b/PKGBUILD
index 38d2f1bb420e..f44fe18462b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,24 +13,22 @@ license=('Apache')
depends=(intel-tbb python)
provides=("openimagedenoise=${pkgver%.r*}")
conflicts=(openimagedenoise)
-makedepends=(git makepkg-git-lfs-proto cmake 'ispc>=1.14' ninja)
+makedepends=(git cmake 'ispc>=1.14' ninja)
source=("${pkgname%-git}::git+https://github.com/OpenImageDenoise/oidn.git${_fragment}"
"git+https://github.com/OpenImageDenoise/mkl-dnn.git"
- "git-lfs+https://github.com/OpenImageDenoise/oidn-weights.git"
"git+https://github.com/NVIDIA/cutlass"
"git+https://github.com/ROCmSoftwarePlatform/composable_kernel"
)
sha256sums=('SKIP'
'SKIP'
'SKIP'
- 'SKIP'
'SKIP')
prepare() {
git -C "${srcdir}"/${pkgname%-git} config submodule.mkl-dnn.url "${srcdir}"/mkl-dnn
- git -C "${srcdir}"/${pkgname%-git} config submodule.weights.url "${srcdir}"/oidn-weights
git -C "${srcdir}"/${pkgname%-git} config submodule.cutlass.url "${srcdir}"/cutlass
git -C "${srcdir}"/${pkgname%-git} config submodule.external/composable_kernel.url "${srcdir}"/composable_kernel
+ sed 's|../oidn-weights.git|https://github.com/OpenImageDenoise/oidn-weights.git|' -i "${srcdir}"/${pkgname%-git}/.gitmodules
git -C "${srcdir}"/${pkgname%-git} -c protocol.file.allow=always submodule update --init --recursive # --remote
}