summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Bero2023-11-04 11:54:19 -0500
committerChristopher Bero2023-11-04 11:54:19 -0500
commit90663032e3c6c1fd49ab5b617f7c4ebb187604d7 (patch)
tree47c6aa44c01a4038e56ab0ba162e9830af76c033
parentb4f8248160c60e28c4afbce7e191b1af3bea21ac (diff)
downloadaur-90663032e3c6c1fd49ab5b617f7c4ebb187604d7.tar.gz
Updated to 1.1.8 and resolved some issues with submodules not building.
-rw-r--r--.SRCINFO6
-rw-r--r--0001-Added-cstdint-to-fix-error-when-compiling-on-Linux.patch24
-rw-r--r--PKGBUILD20
3 files changed, 44 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7766641d8aac..a5e5e6fad63f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = openixcard
pkgdesc = Open Source Version of Allwinner PhoenixCard on Linux
- pkgver = 1.1.0
+ pkgver = 1.1.8
pkgrel = 1
url = https://github.com/YuzukiTsuru/OpenixCard
arch = x86_64
@@ -8,17 +8,19 @@ pkgbase = openixcard
makedepends = cmake
depends = glibc
depends = confuse
- source = openixcard-1.1.0::git+https://github.com/YuzukiTsuru/OpenixCard.git#tag=1.1.0
+ source = openixcard-1.1.8::git+https://github.com/YuzukiTsuru/OpenixCard.git#tag=1.1.8
source = git+https://github.com/YuzukiTsuru/ColorCout.git
source = git+https://github.com/p-ranav/argparse.git
source = git+https://github.com/arun11299/cpp-subprocess.git
source = git+https://github.com/ArthurSonzogni/FTXUI.git
source = git+https://github.com/SemaiCZE/inicpp.git
+ source = 0001-Added-cstdint-to-fix-error-when-compiling-on-Linux.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = 5ef6d78c5e98bf7ca87911ef7609b9192a9a88411741a971d565401b8fd85523
pkgname = openixcard
diff --git a/0001-Added-cstdint-to-fix-error-when-compiling-on-Linux.patch b/0001-Added-cstdint-to-fix-error-when-compiling-on-Linux.patch
new file mode 100644
index 000000000000..8187f56d9594
--- /dev/null
+++ b/0001-Added-cstdint-to-fix-error-when-compiling-on-Linux.patch
@@ -0,0 +1,24 @@
+From af102f6f4137ae4cb814a8c0a423b4bbde21b89e Mon Sep 17 00:00:00 2001
+From: Christopher Bero <bigbero@gmail.com>
+Date: Sat, 4 Nov 2023 10:53:14 -0500
+Subject: [PATCH] Added cstdint to fix error when compiling on Linux
+
+---
+ includes/ColorCout.hpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/includes/ColorCout.hpp b/includes/ColorCout.hpp
+index b73d928..0064999 100644
+--- a/includes/ColorCout.hpp
++++ b/includes/ColorCout.hpp
+@@ -21,6 +21,7 @@ Copyright (C) 2020 GloomyGhost <GloomyGhost@foxmail.com>
+ #define COLORBOX_COLORCOUT_H
+
+ #include <iostream>
++#include <cstdint>
+
+ #ifdef WIN32
+ #ifndef WIN32_LEAN_AND_MEAN
+--
+2.42.0
+
diff --git a/PKGBUILD b/PKGBUILD
index aa67ff5930df..fe0772e8063a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Camber Huang <camber@poi.science>
pkgname=openixcard
-pkgver=1.1.0
+pkgver=1.1.8
pkgrel=1
pkgdesc="Open Source Version of Allwinner PhoenixCard on Linux"
arch=("x86_64")
@@ -17,12 +17,14 @@ backup=()
options=()
install=
changelog=
-source=("${pkgname}-${pkgver}::git+https://github.com/YuzukiTsuru/OpenixCard.git#tag=1.1.0"
+source=("${pkgname}-${pkgver}::git+https://github.com/YuzukiTsuru/OpenixCard.git#tag=${pkgver}"
"git+https://github.com/YuzukiTsuru/ColorCout.git"
+ #"https://github.com/ctag/ColorCout"
"git+https://github.com/p-ranav/argparse.git"
"git+https://github.com/arun11299/cpp-subprocess.git"
"git+https://github.com/ArthurSonzogni/FTXUI.git"
"git+https://github.com/SemaiCZE/inicpp.git"
+ "0001-Added-cstdint-to-fix-error-when-compiling-on-Linux.patch"
)
noextract=()
sha256sums=('SKIP'
@@ -30,7 +32,8 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP')
+ 'SKIP'
+ '5ef6d78c5e98bf7ca87911ef7609b9192a9a88411741a971d565401b8fd85523')
prepare() {
pushd $pkgname-$pkgver
@@ -40,10 +43,19 @@ prepare() {
git config submodule.lib/cpp-subprocess.url "$srcdir/cpp-subprocess"
git config submodule.lib/ftxui.url "$srcdir/FTXUI"
git config submodule.lib/inicpp.url "$srcdir/inicpp"
- git submodule update
+ git -c protocol.file.allow=always submodule update
pushd lib/argparse
#git checkout 95d4850 include/argparse/argparse.hpp
popd
+ pushd lib/inicpp
+ git fetch
+ git checkout 0f7bd53
+ popd
+ # Temporary workaround until ColorCout and OpenixCard/submodule are both updated.
+ pushd lib/ColorCout
+ git apply --verbose $srcdir/0001-Added-cstdint-to-fix-error-when-compiling-on-Linux.patch
+ popd
+
popd
}