summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJameson Pugh2015-06-08 09:27:31 -0400
committerJameson Pugh2015-06-08 09:27:31 -0400
commit4c96044b85730ca7a38c97480ff419baa3ab81be (patch)
tree1fef172066dd4819e68fe6379e4854afddff7995
downloadaur-4c96044b85730ca7a38c97480ff419baa3ab81be.tar.gz
Initial import
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD66
-rw-r--r--openjk.install15
-rw-r--r--openjkmp.desktop10
-rw-r--r--openjkmp.pngbin0 -> 76195 bytes
-rw-r--r--openjksp.desktop10
-rw-r--r--openjksp.pngbin0 -> 92123 bytes
7 files changed, 135 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..38a1611f7698
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = openjk-git
+ pkgdesc = Open Source Jedi Knight II + III Engine
+ pkgver = 1299.9fcc435
+ pkgrel = 1
+ url = https://github.com/Razish/OpenJK
+ install = openjk.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = yasm
+ depends = lib32-libgl
+ depends = lib32-openal
+ depends = lib32-zlib
+ depends = lib32-sdl2
+ optdepends = lib32-libpng
+ optdepends = lib32-libjpeg
+ provides = openjk
+ conflicts = openjk
+ source = openjk::git://github.com/Razish/OpenJK.git
+ source = openjk.install
+ source = openjkmp.png
+ source = openjksp.png
+ source = openjkmp.desktop
+ source = openjksp.desktop
+ sha256sums = SKIP
+ sha256sums = 8873237a7c6f12a0347b3e44cb237110ba526603e2b64aa4914bf4845be477c2
+ sha256sums = 0e82e720777eeb2043c2c25cdbce702c6d4ca077543aedfe51e5c4e96cf03969
+ sha256sums = afb2c1a757720c70798e7f7218f823297a43bc61e0cb192e9443df67c2963903
+ sha256sums = d3ad7dd270e57d36a22caef21bff17f2eb4acb0ad9087f6a17ca4a0bf9c566fc
+ sha256sums = d03554bd926954218c243a1a97d39ea9700d064a2374f671249a533ebd970375
+
+pkgname = openjk-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3905fdf57ebc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# Maintainer: Jameson Pugh <imntreal@gmail.com>
+# Contributor: Rene Schoebel (wesley) <schoebel.r at gmail dot com>
+
+pkgname=openjk-git
+pkgver=1299.9fcc435
+pkgrel=1
+pkgdesc="Open Source Jedi Knight II + III Engine"
+arch=('i686' 'x86_64')
+url="https://github.com/Razish/OpenJK"
+license=('GPL')
+depends=('lib32-libgl' 'lib32-openal' 'lib32-zlib' 'lib32-sdl2')
+optdepends=('lib32-libpng' 'lib32-libjpeg')
+makedepends=('cmake' 'yasm')
+provides=(openjk)
+conflicts=(openjk)
+source=("openjk::git://github.com/Razish/OpenJK.git"
+ 'openjk.install'
+ 'openjkmp.png'
+ 'openjksp.png'
+ 'openjkmp.desktop'
+ 'openjksp.desktop')
+install=openjk.install
+sha256sums=('SKIP'
+ '8873237a7c6f12a0347b3e44cb237110ba526603e2b64aa4914bf4845be477c2'
+ '0e82e720777eeb2043c2c25cdbce702c6d4ca077543aedfe51e5c4e96cf03969'
+ 'afb2c1a757720c70798e7f7218f823297a43bc61e0cb192e9443df67c2963903'
+ 'd3ad7dd270e57d36a22caef21bff17f2eb4acb0ad9087f6a17ca4a0bf9c566fc'
+ 'd03554bd926954218c243a1a97d39ea9700d064a2374f671249a533ebd970375')
+
+pkgver() {
+ cd openjk
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "${srcdir}/openjk"
+
+ mkdir build
+ cd build
+ cmake ../ \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/opt/${pkgname} \
+ -DCMAKE_CXX_FLAGS=-m32 \
+ -DCMAKE_C_FLAGS=-m32 \
+ -DCMAKE_SHARED_LINKER_FLAGS=-m32 \
+ -DCMAKE_SIZEOF_VOID_P=4
+ make
+}
+
+package() {
+ cd "${srcdir}/openjk/build"
+
+ make DESTDIR="${pkgdir}" install
+
+ mkdir -p "${pkgdir}/usr/bin"
+ ln -s "/opt/${pkgname}/openjk.i386" "${pkgdir}/usr/bin/openjk"
+ ln -s "/opt/${pkgname}/openjk_sp.i386" "${pkgdir}/usr/bin/openjk_sp"
+ ln -s "/opt/${pkgname}/openjkded.i386" "${pkgdir}/usr/bin/openjkded"
+
+ install -Dm755 "${srcdir}/openjkmp.png" "${pkgdir}/usr/share/pixmaps/openjkmp.png"
+ install -Dm755 "${srcdir}/openjksp.png" "${pkgdir}/usr/share/pixmaps/openjksp.png"
+ install -Dm755 "${srcdir}/openjkmp.desktop" "${pkgdir}/usr/share/applications/openjkmp.desktop"
+ install -Dm755 "${srcdir}/openjksp.desktop" "${pkgdir}/usr/share/applications/openjksp.desktop"
+}
+
+# vim: set ts=2 sw=2 ft=sh noet:
diff --git a/openjk.install b/openjk.install
new file mode 100644
index 000000000000..ab8bd1e3f2a7
--- /dev/null
+++ b/openjk.install
@@ -0,0 +1,15 @@
+post_install() {
+ update-desktop-database -q
+ xdg-icon-resource forceupdate --theme hicolor
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ update-desktop-database -q
+ xdg-icon-resource forceupdate --theme hicolor
+}
+
+
diff --git a/openjkmp.desktop b/openjkmp.desktop
new file mode 100644
index 000000000000..0c6eec115556
--- /dev/null
+++ b/openjkmp.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Type=Application
+Name=OpenJK Multi Player
+Comment="Open Source Jedi Knight II + III Engine - Multi Player"
+Exec=openjk
+Icon=openjkmp
+Terminal=false
+StartupNotify=false
+Categories=Game
diff --git a/openjkmp.png b/openjkmp.png
new file mode 100644
index 000000000000..b3fef102cf1d
--- /dev/null
+++ b/openjkmp.png
Binary files differ
diff --git a/openjksp.desktop b/openjksp.desktop
new file mode 100644
index 000000000000..e6adad93b3ae
--- /dev/null
+++ b/openjksp.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Type=Application
+Name=OpenJK Single Player
+Comment="Open Source Jedi Knight II + III Engine - Single Player"
+Exec=openjk_sp
+Icon=openjksp
+Terminal=false
+StartupNotify=false
+Categories=Game
diff --git a/openjksp.png b/openjksp.png
new file mode 100644
index 000000000000..862244e852c7
--- /dev/null
+++ b/openjksp.png
Binary files differ