summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2017-11-25 15:26:29 +0330
committerMohammadreza Abdollahzadeh2017-11-25 15:26:29 +0330
commit2ec4993637d45b964ae12f8e7025f03f7ae01e9a (patch)
treee8decd47fe3b5721005b84d281409425987292dd
parenta48159f6564cda47371d3209eeae6fc1450423e1 (diff)
downloadaur-2ec4993637d45b964ae12f8e7025f03f7ae01e9a.tar.gz
update to v4.5.0
-rw-r--r--.SRCINFO10
-rw-r--r--LICENSE.txt26
-rw-r--r--PKGBUILD10
3 files changed, 7 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8555129d85a8..83035bdc28fd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
# Generated by mksrcinfo v8
-# Fri Nov 10 09:30:28 UTC 2017
+# Sat Nov 25 11:55:59 UTC 2017
pkgbase = openlayers
pkgdesc = A high-performance, feature-packed JavaScript library for displaying map data.
- pkgver = 4.4.2
+ pkgver = 4.5.0
pkgrel = 1
url = http://openlayers.org/
arch = any
license = BSD
- source = https://github.com/openlayers/ol3/releases/download/v4.4.2/v4.4.2-dist.zip
- source = LICENSE.txt
- sha256sums = 5c3b10e0fd81bec8486c39e8610a024e2d21899cda20f5f2ebd2cfcc94a505ef
- sha256sums = d00addee76cd5bb68fa012b880d8be2c0fb1677a9cbd53bf7256adb644668247
+ source = https://github.com/openlayers/openlayers/releases/download/v4.5.0/v4.5.0-dist.zip
+ sha256sums = 791cb4ec5ce691ad0b34ff6c69a1dea5a8e331d1d59ccd6679766d7ce6747424
pkgname = openlayers
diff --git a/LICENSE.txt b/LICENSE.txt
deleted file mode 100644
index 672812a08cb1..000000000000
--- a/LICENSE.txt
+++ /dev/null
@@ -1,26 +0,0 @@
-Copyright (c) 2016, OpenLayers
-All rights reserved.
-
-Redistribution and use in source and binary forms, with or without
-modification, are permitted provided that the following conditions are met:
-
-1. Redistributions of source code must retain the above copyright notice, this
- list of conditions and the following disclaimer.
-2. Redistributions in binary form must reproduce the above copyright notice,
- this list of conditions and the following disclaimer in the documentation
- and/or other materials provided with the distribution.
-
-THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
-ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
-WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
-DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR
-ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
-(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
-LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
-ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
-(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
-SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-The views and conclusions contained in the software and documentation are those
-of the authors and should not be interpreted as representing official policies,
-either expressed or implied, of the FreeBSD Project.
diff --git a/PKGBUILD b/PKGBUILD
index ed1ad02a3a95..2dac654914b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,15 @@
#Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
pkgname=openlayers
-pkgver=4.4.2
+pkgver=4.5.0
pkgrel=1
pkgdesc='A high-performance, feature-packed JavaScript library for displaying map data.'
arch=('any')
url='http://openlayers.org/'
license=('BSD')
-source=("https://github.com/openlayers/ol3/releases/download/v${pkgver}/v${pkgver}-dist.zip"
- "LICENSE.txt")
-sha256sums=('5c3b10e0fd81bec8486c39e8610a024e2d21899cda20f5f2ebd2cfcc94a505ef'
- 'd00addee76cd5bb68fa012b880d8be2c0fb1677a9cbd53bf7256adb644668247')
+source=("https://github.com/openlayers/openlayers/releases/download/v${pkgver}/v${pkgver}-dist.zip")
+sha256sums=('791cb4ec5ce691ad0b34ff6c69a1dea5a8e331d1d59ccd6679766d7ce6747424')
package() {
install -d ${pkgdir}/usr/share/javascript/${pkgname}
- install -d ${pkgdir}/usr/share/licenses/${pkgname}
cp -a ${srcdir}/v${pkgver}-dist/* ${pkgdir}/usr/share/javascript/${pkgname}
- cp -L ./LICENSE.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
}