summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2016-01-03 19:09:35 +0330
committerMohammadreza Abdollahzadeh2016-01-03 19:09:35 +0330
commit8ba9f3de0251d7f2d3211d285d39b286dcdec3d8 (patch)
tree8a9b198e78daf6341ab67295f904fba15d72fb5e
downloadaur-8ba9f3de0251d7f2d3211d285d39b286dcdec3d8.tar.gz
Initial package
-rw-r--r--.SRCINFO16
-rw-r--r--LICENSE.txt26
-rw-r--r--PKGBUILD20
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..971221c3dea9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sun Jan 3 15:39:23 UTC 2016
+pkgbase = openlayers
+ pkgdesc = A high-performance, feature-packed JavaScript library for displaying map data.
+ pkgver = 3.12.1
+ pkgrel = 1
+ url = http://openlayers.org/
+ arch = any
+ license = BSD
+ source = https://github.com/openlayers/ol3/releases/download/v3.12.1/v3.12.1-dist.zip
+ source = LICENSE.txt
+ md5sums = 90120116661e7c06758e813cb861291e
+ md5sums = ad650727154af9d966f3ac1be150eff3
+
+pkgname = openlayers
+
diff --git a/LICENSE.txt b/LICENSE.txt
new file mode 100644
index 000000000000..672812a08cb1
--- /dev/null
+++ b/LICENSE.txt
@@ -0,0 +1,26 @@
+Copyright (c) 2016, OpenLayers
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+
+1. Redistributions of source code must retain the above copyright notice, this
+ list of conditions and the following disclaimer.
+2. Redistributions in binary form must reproduce the above copyright notice,
+ this list of conditions and the following disclaimer in the documentation
+ and/or other materials provided with the distribution.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
+ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR
+ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
+ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+The views and conclusions contained in the software and documentation are those
+of the authors and should not be interpreted as representing official policies,
+either expressed or implied, of the FreeBSD Project.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6e230275f8d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+#Maintainer: Mohammadreza Abdollahzadeh <morealaz@gmail.com>
+
+pkgname=openlayers
+pkgver=3.12.1
+pkgrel=1
+pkgdesc='A high-performance, feature-packed JavaScript library for displaying map data.'
+arch=any
+url='http://openlayers.org/'
+license='BSD'
+source=("https://github.com/openlayers/ol3/releases/download/v${pkgver}/v${pkgver}-dist.zip"
+ "LICENSE.txt")
+md5sums=('90120116661e7c06758e813cb861291e'
+ 'ad650727154af9d966f3ac1be150eff3')
+
+package() {
+ install -d ${pkgdir}/usr/share/javascript/${pkgname}
+ install -d ${pkgdir}/usr/share/licenses/${pkgname}
+ cp -a ${srcdir}/v${pkgver}-dist/* ${pkgdir}/usr/share/javascript/${pkgname}
+ cp -L ./LICENSE.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}