summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarks2021-05-11 23:48:37 +0200
committerDarks2021-05-12 19:16:09 +0200
commita201979f9cbc4dce411b183a0477313aba2e4bbc (patch)
treedc4e376180ce8a1d871e63fbab19f4daceb8bc53
downloadaur-a201979f9cbc4dce411b183a0477313aba2e4bbc.tar.gz
Created package from 0.7.2
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD32
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8e2bf5879a80
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = openlibm-casio
+ pkgdesc = Fork of the OpenLibm math library with support for fx-9860G and fx-CG 50
+ pkgver = 0.7.2
+ pkgrel = 1
+ url = https://gitea.planet-casio.com/Lephenixnoir/OpenLibm
+ arch = i686
+ arch = x86_64
+ makedepends = sh-elf-gcc-casio
+ options = !buildflags
+ options = !strip
+ source = openlibm-casio-0.7.2.tar.gz::https://gitea.planet-casio.com/Lephenixnoir/OpenLibm/archive/v0.7.2.tar.gz
+ sha256sums = d919ceda62ee32b7397ee521b8ad5f96e7f8c46645c6e554d51ce50fd9bf3f6f
+
+pkgname = openlibm-casio
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c6dbc3531878
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Eldeberen <eldeberen.aur@middleearth.fr>
+pkgname=openlibm-casio
+pkgver=0.7.2
+pkgrel=1
+pkgdesc='Fork of the OpenLibm math library with support for fx-9860G and fx-CG 50'
+arch=('i686' 'x86_64')
+url="https://gitea.planet-casio.com/Lephenixnoir/OpenLibm"
+licence=('custom')
+makedepends=('sh-elf-gcc-casio')
+options=('!buildflags' '!strip')
+source=("$pkgname-$pkgver.tar.gz::https://gitea.planet-casio.com/Lephenixnoir/OpenLibm/archive/v${pkgver}.tar.gz")
+sha256sums=('d919ceda62ee32b7397ee521b8ad5f96e7f8c46645c6e554d51ce50fd9bf3f6f')
+
+prepare() {
+ cd "${srcdir}/openlibm"
+ make clean
+}
+
+build() {
+ cd "$srcdir/openlibm"
+ _prefix=$(sh-elf-gcc --print-search-dirs | grep install | sed 's/install: //')
+ make USEGCC=1 TOOLPREFIX=sh-elf- ARCH=sh3eb libdir="${_prefix}" includedir="${_prefix}/include" libopenlibm.a
+}
+
+package() {
+ cd "$srcdir/openlibm"
+ _prefix=$(sh-elf-gcc --print-search-dirs | grep install | sed 's/install: //')
+ make USEGCC=1 TOOLPREFIX=sh-elf- ARCH=sh3eb libdir="${_prefix}" includedir="${_prefix}/include" DESTDIR="$pkgdir" install-static install-headers
+
+ # Install licence
+ install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}