summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjose17112019-01-26 23:19:42 +0100
committerjose17112019-01-26 23:19:42 +0100
commitc882cbf6d4b35c537a8cdf68a921166d4f6d8d48 (patch)
tree2e9bcb3a80de03ede968d7c19c341e56fa121ab9
downloadaur-c882cbf6d4b35c537a8cdf68a921166d4f6d8d48.tar.gz
Initial commit
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD39
-rw-r--r--cbytestream.patch11
-rw-r--r--compilesh.patch11
4 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b2fbf8fd899b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by mksrcinfo v8
+# Sat Jan 26 22:19:27 UTC 2019
+pkgbase = openlierox
+ pkgdesc = An extremely addictive realtime worms shoot-em-up backed by an active gamers community
+ pkgver = 0.57_beta2
+ pkgrel = 1
+ url = http://openlierox.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = gendesk
+ depends = sdl
+ depends = sdl_mixer
+ depends = sdl_image
+ depends = hawknl
+ depends = gd
+ depends = zlib
+ depends = libxml2
+ source = http://downloads.sourceforge.net/sourceforge/openlierox/OpenLieroX_0.57_beta2.src.tar.bz2
+ source = compilesh.patch
+ source = cbytestream.patch
+ md5sums = 6985e35d7d1cd7520ccba387c459f333
+ md5sums = 414db95d3acac00dca935deba6cc7488
+ md5sums = 485670d8cdfeef69199ed481acbbe1b3
+
+pkgname = openlierox
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2194ddd99f19
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Jose Riha <jose 1711 gmail com>
+# Contributor: Dominika Solarz <dominikasolarz@gmail.com>
+pkgname=openlierox
+pkgver=0.57_beta2
+pkgrel=1
+pkgdesc="An extremely addictive realtime worms shoot-em-up backed by an active gamers community"
+arch=(i686 x86_64)
+license=("GPL")
+url="http://openlierox.sourceforge.net/"
+depends=("sdl" "sdl_mixer" "sdl_image" "hawknl" "gd" "zlib" "libxml2")
+makedepends=("gendesk")
+source=("http://downloads.sourceforge.net/sourceforge/openlierox/OpenLieroX_${pkgver}.src.tar.bz2"
+ "compilesh.patch"
+ "cbytestream.patch")
+md5sums=('6985e35d7d1cd7520ccba387c459f333'
+ '414db95d3acac00dca935deba6cc7488'
+ '485670d8cdfeef69199ed481acbbe1b3')
+
+prepare() {
+cd $srcdir/OpenLieroX
+patch -p0 -i $srcdir/compilesh.patch
+patch -p0 --binary -i $srcdir/cbytestream.patch
+gendesk -f -n --pkgname OpenLieroX --pkgdesc "${pkgdesc}" --exec "openlierox" --categories "Games"
+}
+
+build() {
+cd $srcdir/OpenLieroX
+./compile.sh
+}
+
+package() {
+cd $srcdir/OpenLieroX
+install -Dm755 bin/openlierox $pkgdir/usr/bin/openlierox
+chmod -R 644 share/gamedir
+install -dm755 $pkgdir/usr/share/OpenLieroX
+cp -r share/gamedir/* $pkgdir/usr/share/OpenLieroX/
+install -Dm644 OpenLieroX.desktop "$pkgdir/usr/share/applications/OpenLieroX.desktop"
+install -Dm644 share/OpenLieroX.png "$pkgdir/usr/share/pixmaps/OpenLieroX.png"
+}
diff --git a/cbytestream.patch b/cbytestream.patch
new file mode 100644
index 000000000000..a3a376e0505e
--- /dev/null
+++ b/cbytestream.patch
@@ -0,0 +1,11 @@
+--- src/common/CBytestream.cpp.orig 2019-01-26 20:45:40.086373395 +0100
++++ src/common/CBytestream.cpp 2019-01-26 20:45:59.482914532 +0100
+@@ -314,7 +314,7 @@
+ char *CBytestream::readString(char *str, size_t maxlen)
+ {
+ if (!str)
+- return false;
++ return "false";
+
+ // Validate that there is some terminating character
+ bool valid = false;
diff --git a/compilesh.patch b/compilesh.patch
new file mode 100644
index 000000000000..3733a1d09d01
--- /dev/null
+++ b/compilesh.patch
@@ -0,0 +1,11 @@
+--- compile.sh.orig 2019-01-26 20:39:36.455394693 +0100
++++ compile.sh 2019-01-26 20:39:55.385269142 +0100
+@@ -105,7 +105,7 @@
+ if $COMPILER src/*.cpp src/client/*.cpp src/common/*.cpp src/server/*.cpp \
+ $HAWKNL_GCC_PARAM \
+ -I include -I /usr/include/libxml2 -I /usr/include/hawknl \
+- -I /usr/local/include/libxml2 -I /usr/local/include/hawknl \
++ -I /usr/local/include/libxml2 -I /usr/local/include/hawknl -I /usr/include/SDL \
+ -lSDL -lSDL_image -lSDL_gfx -lSDL_mixer -lz -lgd -lxml2 \
+ -DSYSTEM_DATA_DIR="\"$SYSTEM_DATA_DIR\"" \
+ -DDEBUG="$DEBUG" \