summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRon Bickers2022-05-25 04:25:31 -0400
committerRon Bickers2022-05-25 04:25:31 -0400
commitcfe7480dc997d14fa5c7d8f63a89753b25b8975e (patch)
tree77f92f02009ccb16d14cf7b514bf74337e11d698
parenta6be081ea4fc3ea440f12c918876995c74a64b84 (diff)
downloadaur-cfe7480dc997d14fa5c7d8f63a89753b25b8975e.tar.gz
user/group fix
-rw-r--r--PKGBUILD2
-rw-r--r--archlinux.patch38
2 files changed, 28 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d4fabc00339d..111c81971121 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,7 +23,7 @@ source=(https://openlitespeed.org/packages/$pkgname-$pkgver.src.tgz
$pkgname.sysusers
$pkgname.tmpfiles)
sha256sums=('918c1f54b92b87462ff7013568768c85cb08568f184eb83223c48f3c0a792719'
- 'e96831b0bc823974e7351e9fe5f99561609fa395c77a400d71997f9df23978d3'
+ '92d1c6e4c93f2f0ee363b20add793a47b1cf7783ca430591a9de95b3496d7ef3'
'77b8b0870da1bbf43e77b976cb118b97ac09f74744845877e56023c5772616f1'
'0d2a2d55882e76e1bbdea12e9d97886366c0ad58c43b24fe655fff099c11e141'
'93de5ef937ec4fdf0c33e3932fd81f9890b96b99efb2fbe3d601fb91945bde7f')
diff --git a/archlinux.patch b/archlinux.patch
index fd478744c2bd..4a151a7067c8 100644
--- a/archlinux.patch
+++ b/archlinux.patch
@@ -12,7 +12,7 @@ diff '--color=auto' -ur --no-dereference openlitespeed-1.7.16-dist/addon/example
LSM_ERR((&MNAME), session, "get file stat failed\n");
diff '--color=auto' -ur --no-dereference openlitespeed-1.7.16-dist/build.sh openlitespeed-1.7.16/build.sh
--- openlitespeed-1.7.16-dist/build.sh 2022-05-13 14:30:06.000000000 -0400
-+++ openlitespeed-1.7.16/build.sh 2022-05-25 03:42:52.229772638 -0400
++++ openlitespeed-1.7.16/build.sh 2022-05-25 04:13:29.388403740 -0400
@@ -29,7 +29,7 @@
if [ "${OS}" = "FreeBSD" ] ; then
APP_MGRS="pkg"
@@ -56,16 +56,19 @@ diff '--color=auto' -ur --no-dereference openlitespeed-1.7.16-dist/build.sh open
./build_ols.sh
fi
-@@ -599,7 +603,7 @@
+@@ -599,16 +603,16 @@
#If you want to change the default values, please update this file.
#
-SERVERROOT=/usr/local/lsws
+-OPENLSWS_USER=nobody
+-OPENLSWS_GROUP=nobody
+-OPENLSWS_ADMIN=admin
+SERVERROOT=/opt/lsws
- OPENLSWS_USER=nobody
- OPENLSWS_GROUP=nobody
- OPENLSWS_ADMIN=admin
-@@ -607,8 +611,8 @@
++OPENLSWS_USER=lshttpd
++OPENLSWS_GROUP=lshttpd
++OPENLSWS_ADMIN=lsadm
+ OPENLSWS_EMAIL=root@localhost
OPENLSWS_ADMINSSL=yes
OPENLSWS_ADMINPORT=7080
USE_LSPHP7=yes
@@ -76,16 +79,20 @@ diff '--color=auto' -ur --no-dereference openlitespeed-1.7.16-dist/build.sh open
OPENLSWS_EXAMPLEPORT=8088
#You can set password here
-@@ -623,7 +627,7 @@
+@@ -623,17 +627,17 @@
cat > ./install.sh <<END
#!/bin/sh
-SERVERROOT=/usr/local/lsws
+-OPENLSWS_USER=nobody
+-OPENLSWS_GROUP=nobody
+-OPENLSWS_ADMIN=admin
+SERVERROOT=/opt/lsws
- OPENLSWS_USER=nobody
- OPENLSWS_GROUP=nobody
- OPENLSWS_ADMIN=admin
-@@ -632,8 +636,8 @@
++OPENLSWS_USER=lshttpd
++OPENLSWS_GROUP=lshttpd
++OPENLSWS_ADMIN=lsadm
+ OPENLSWS_PASSWORD=
+ OPENLSWS_EMAIL=root@localhost
OPENLSWS_ADMINSSL=yes
OPENLSWS_ADMINPORT=7080
USE_LSPHP7=yes
@@ -96,6 +103,15 @@ diff '--color=auto' -ur --no-dereference openlitespeed-1.7.16-dist/build.sh open
OPENLSWS_EXAMPLEPORT=8088
CONFFILE=./ols.conf
+@@ -669,7 +673,7 @@
+ echo OPENLSWS_PASSWORD=\${OPENLSWS_PASSWORD} >> ./ols.conf
+ fi
+
+- echo "WebAdmin user/password is admin/\${OPENLSWS_PASSWORD}" > \$SERVERROOT/adminpasswd
++ echo "WebAdmin user/password is lsadm/\${OPENLSWS_PASSWORD}" > \$SERVERROOT/adminpasswd
+ chmod 600 \$SERVERROOT/adminpasswd
+ fi
+
diff '--color=auto' -ur --no-dereference openlitespeed-1.7.16-dist/configure openlitespeed-1.7.16/configure
--- openlitespeed-1.7.16-dist/configure 2022-05-13 15:00:48.000000000 -0400
+++ openlitespeed-1.7.16/configure 2022-05-25 03:16:37.445919246 -0400