summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMr.Smith19742023-06-07 11:34:45 +0300
committerMr.Smith19742023-06-07 11:34:45 +0300
commitdb66c0f22d8fe84f30f53e7fe808158cfbce2842 (patch)
treee009ca22fc2026587af5ae2e0375e3debe4b39c0
downloadaur-db66c0f22d8fe84f30f53e7fe808158cfbce2842.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ea7d3fda8063
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = openloco
+ pkgdesc = An open source re-implementation of Chris Sawyer's Locomotion
+ pkgver = 23.05
+ pkgrel = 1
+ url = https://github.com/OpenLoco/OpenLoco
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ makedepends = gtest
+ makedepends = lib32-glibc
+ makedepends = yaml-cpp
+ source = https://github.com/OpenLoco/OpenLoco/archive/refs/tags/v23.05.tar.gz
+ sha256sums = 19c867f311dde3f934d4d075d0931117f8480563a0dd576ca35182648ae38b71
+
+pkgname = openloco
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f43d168dcdc1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+pkgname=openloco
+_pkgname=OpenLoco
+pkgver=23.05
+pkgrel=1
+pkgdesc="An open source re-implementation of Chris Sawyer's Locomotion"
+arch=('x86_64')
+url="https://github.com/OpenLoco/OpenLoco"
+license=('MIT')
+depends=()
+makedepends=('cmake' 'gtest' 'lib32-glibc' 'yaml-cpp')
+source=("https://github.com/${_pkgname}/${_pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('19c867f311dde3f934d4d075d0931117f8480563a0dd576ca35182648ae38b71')
+
+
+build() {
+ cd ${_pkgname}-${pkgver}
+ sed -i 's/option(OPENLOCO_BUILD_TESTS "Build tests" YES)/option(OPENLOCO_BUILD_TESTS "Build tests" NO)/' CMakeLists.txt
+
+ rm -rf "build"
+ mkdir -p "build"
+ cd build
+
+ cmake -G "Unix Makefiles" -DCMAKE_BUILD_TYPE=Release ../
+ make
+}
+
+package() {
+ cd ${_pkgname}-${pkgver}
+ DESTDIR="$pkgdir" cmake -P cmake_install.cmake --install build
+}
+