summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Hanna2022-01-27 19:39:09 +0100
committerSimon Hanna2022-01-27 19:41:21 +0100
commit9fb7725dd103ac9a67dac60be9d6947830c01c01 (patch)
treeb274dfdbeffed1d2b7e8d13b29bfd999ab971986
parentb7634824c48ba4ffbacc20025024eac52aada45a (diff)
downloadaur-9fb7725dd103ac9a67dac60be9d6947830c01c01.tar.gz
Update for python3.10 compatibility
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
-rw-r--r--dbus.patch11
3 files changed, 15 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 20e189e939d7..5508783e909a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Wed Dec 30 15:49:37 UTC 2020
pkgbase = openlp-git
pkgdesc = Church presentation software.
- pkgver = r16942.303b3ded1
+ pkgver = r17137.ff0605cb2
pkgrel = 1
url = http://openlp.org/
install = openlp.install
@@ -10,10 +8,14 @@ pkgbase = openlp-git
license = GPLv2
makedepends = qt5-tools
makedepends = git
- depends = python>=3.9
- depends = python<3.10
+ depends = python>=3.10
+ depends = python<3.11
depends = python-pyqt5
depends = phonon-qt5
+ depends = python-pyqt5-webengine
+ depends = python-flask
+ depends = python-flask-cors
+ depends = python-pymediainfo
depends = python-chardet
depends = python-lxml
depends = python-six
@@ -41,10 +43,7 @@ pkgbase = openlp-git
conflicts = openlp
source = git+https://gitlab.com/openlp/openlp.git
source = openlp.sh
- source = dbus.patch
sha256sums = SKIP
sha256sums = 19c2f3c622585bf308efc259013fb5518feaf8cf14b51613e1e71778fcc2e8cf
- sha256sums = e8aabadd8037179b15cb0093bb0dbd0ad1aa069e2990e13cec677b07eee1b1b6
pkgname = openlp-git
-
diff --git a/PKGBUILD b/PKGBUILD
index a1fc6c0250d3..3626d3f667a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=openlp-git
_pkgbase=openlp
-pkgver=r16942.303b3ded1
+pkgver=r17137.ff0605cb2
pkgrel=1
pkgdesc="Church presentation software."
arch=('any')
@@ -12,7 +12,9 @@ license=('GPLv2')
provides=('openlp')
conflicts=('openlp')
makedepends=('qt5-tools' 'git')
-depends=('python>=3.9' 'python<3.10' 'python-pyqt5' 'phonon-qt5'
+depends=('python>=3.10' 'python<3.11' 'python-pyqt5' 'phonon-qt5'
+ 'python-pyqt5-webengine' 'python-flask' 'python-flask-cors'
+ 'python-pymediainfo'
'python-chardet' 'python-lxml' 'python-six'
'python-beautifulsoup4' 'python-pyenchant' 'python-dbus'
'python-alembic' 'mediainfo' 'qt5-multimedia' 'python-zeroconf'
@@ -24,34 +26,23 @@ optdepends=('libreoffice-fresh: display impress presentations'
'python-mysql-connector: Use a mysql/mariadb database'
'python-psycopg2: Use a postgresql database')
install=openlp.install
-source=('git+https://gitlab.com/openlp/openlp.git' 'openlp.sh' 'dbus.patch')
+source=('git+https://gitlab.com/openlp/openlp.git' 'openlp.sh')
sha256sums=('SKIP'
- '19c2f3c622585bf308efc259013fb5518feaf8cf14b51613e1e71778fcc2e8cf'
- 'e8aabadd8037179b15cb0093bb0dbd0ad1aa069e2990e13cec677b07eee1b1b6')
-
-prepare() {
- cd "$_pkgbase"
- patch --forward --strip=1 --input="${srcdir}/dbus.patch"
-}
+ '19c2f3c622585bf308efc259013fb5518feaf8cf14b51613e1e71778fcc2e8cf')
pkgver() {
cd "$_pkgbase"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-#check() {
-# cd "$srcdir/trunk"
-# nosetests -v tests
-#}
-
package() {
cd "${srcdir}/${_pkgbase}"
python setup.py install --root="$pkgdir/" --optimize=1
-
+ PYTHON_VERSION=$(python -c 'import sys; print(".".join(map(str, sys.version_info[:2])))')
TAG=$(git describe --tags --abbrev=0)
VERSION="${TAG}.$(git rev-list $TAG.. --count)-$(git rev-parse --short HEAD)"
- echo "$VERSION" > "$pkgdir/usr/lib/python3.9/site-packages/openlp/.version"
+ echo "$VERSION" > "$pkgdir/usr/lib/python${PYTHON_VERSION}/site-packages/openlp/.version"
install -Dm0755 "$srcdir/openlp.sh" "$pkgdir/etc/profile.d/openlp.sh"
install -Dm0644 "resources/openlp.desktop" "$pkgdir/usr/share/applications/openlp.desktop"
diff --git a/dbus.patch b/dbus.patch
deleted file mode 100644
index 4dd0d1c09934..000000000000
--- a/dbus.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff --unified --text openlp/setup.py openlp.new/setup.py
---- openlp/setup.py 2019-11-27 22:22:05.477556034 +0100
-+++ openlp.new/setup.py 2019-11-27 22:23:13.180384336 +0100
-@@ -100,7 +100,6 @@
- 'appdirs',
- 'beautifulsoup4',
- 'chardet',
-- 'dbus-python; platform_system=="Linux"',
- 'lxml',
- 'Mako',
- 'pymediainfo >= 2.2',