summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlukelabrie2023-10-18 17:35:15 +0200
committerlukelabrie2023-10-18 17:35:15 +0200
commit92042f6da9f3debd221f190b3438eb617bb57109 (patch)
treee1ed5b7bf2e439abfeb0499774e6804f5e473ef5
parentf0dba164ee6f80f45042c65eb0ca752598614ce3 (diff)
downloadaur-92042f6da9f3debd221f190b3438eb617bb57109.tar.gz
refactor of path handling
-rw-r--r--.SRCINFO3
-rwxr-xr-xPKGBUILD1
-rw-r--r--post.install4
3 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 38fef8d384c6..ff9d240b2597 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = openmc-git
pkgdesc = The OpenMC project aims to provide a fully-featured Monte Carlo particle transport code based on modern methods.
- pkgver = v0.13.2.r497.g6218becb1
+ pkgver = v0.13.3.r314.g7fe80e149
pkgrel = 1
url = https://github.com/openmc-dev/openmc
+ install = post.install
arch = x86_64
license = MIT
makedepends = cmake
diff --git a/PKGBUILD b/PKGBUILD
index 296dd24ea4de..669e3b6cc1b0 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -69,4 +69,5 @@ package() {
make DESTDIR="$pkgdir/" install
cp -r $srcdir/${pkgname} $pkgdir/opt/openmc
cp $srcdir/set_paths.sh $pkgdir/opt/openmc
+ cp $srcdir/openmc.sh $pkgdir/opt/openmc
} \ No newline at end of file
diff --git a/post.install b/post.install
index 5f73383be311..35ed2dee427d 100644
--- a/post.install
+++ b/post.install
@@ -1,7 +1,7 @@
post_install() {
# installed to opt, inform user how to set paths
-_path_msg="$'\n'INFO: OpenMC and its dependencies were installed to the non-standard location /opt. Run sudo bash \
- /opt/openmc/set_paths.sh before attempting to use openmc$'\n'."
+_path_msg="\nINFO: OpenMC and its dependencies were installed to the non-standard location /opt. Run sudo bash \
+ /opt/openmc/set_paths.sh before attempting to use openmc\n."
echo -e $_path_msg
} \ No newline at end of file