summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGavin Ridley2020-05-18 21:40:20 -0400
committerGavin Ridley2020-05-18 21:40:20 -0400
commitcec11d2cd856e364c40cbb886f7d8300ca39ae16 (patch)
treeab56aad5a0cbd33a3ff2968aeb1fef6c55f5bee7
downloadaur-cec11d2cd856e364c40cbb886f7d8300ca39ae16.tar.gz
add the stuff and also the thing
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD38
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..da2af60421d7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = openmc-git
+ pkgdesc = Community-developed Monte Carlo neutron and photon transport simulation code
+ pkgver = r11186.8bd8af53d
+ pkgrel = 1
+ url = https://github.com/openmc-dev/openmc
+ arch = any
+ license = MIT
+ makedepends = cmake
+ makedepends = git
+ makedepends = python-setuptools
+ depends = hdf5-cpp-fortran
+ depends = python-numpy
+ depends = python-matplotlib
+ depends = python-scipy
+ depends = python-pandas
+ depends = python-h5py
+ depends = python-uncertainties
+ depends = python-lxml
+ provides = openmc
+ provides = libopenmc.so
+ conflicts = openmc
+ source = openmc-git::git+https://github.com/openmc-dev/openmc.git
+ sha1sums = SKIP
+
+pkgname = openmc-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b66cfd646877
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Gavin Ridley <gavin.keith.ridley@gmail.com>
+pkgname=openmc-git
+pkgver=r11186.8bd8af53d
+pkgrel=1
+pkgdesc="Community-developed Monte Carlo neutron and photon transport simulation code"
+arch=('any')
+url="https://github.com/openmc-dev/openmc"
+license=('MIT')
+makedepends=('cmake' 'git' 'python-setuptools')
+depends=('hdf5-cpp-fortran' 'python-numpy' 'python-matplotlib' 'python-scipy'
+ 'python-pandas' 'python-h5py' 'python-uncertainties' 'python-lxml')
+provides=("${pkgname%-git}" "libopenmc.so")
+conflicts=("${pkgname%-git}")
+source=("${pkgname}::git+${url}.git")
+noextract=()
+sha1sums=('SKIP')
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+build() {
+ printf "build"
+ printf "%s" "${pkgname}"
+ printf "%s" "${pkgname%-git}"
+ cd "${srcdir}/${pkgname}"
+ git submodule update --init --recursive
+ python setup.py build
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+package() {
+ cd "${srcdir}/${pkgname}/build"
+ make DESTDIR="${pkgdir}" install
+ cd ..
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}