summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp Mildenberger2018-04-23 15:28:47 +0200
committerPhilipp Mildenberger2018-04-23 15:28:47 +0200
commit3f1612993490f5abf8111f9608dc7ccb54baade3 (patch)
tree07da45afa58ead8530d9190550e19feb37699967
parent608b5206bc5f78dc93d452601c6e0bcf7583b310 (diff)
downloadaur-3f1612993490f5abf8111f9608dc7ccb54baade3.tar.gz
updated to OpenMesh-7.0 and fixed a small bug with a missing python lib
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
-rw-r--r--doc-install.patch4
3 files changed, 13 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5642cf2ae2e1..481698321631 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,22 @@
-# Generated by makepkg 5.0.1
-# Mon Dec 5 22:10:44 UTC 2016
pkgbase = openmesh
pkgdesc = A generic and efficient data structure for representing and manipulating polygonal meshes
- pkgver = 6.3
+ pkgver = 7.0
pkgrel = 1
url = http://www.openmesh.org
install = openmesh.install
arch = i686
arch = x86_64
- license = custom
+ license = BSD-3
makedepends = cmake
makedepends = qt4
makedepends = graphviz
makedepends = doxygen
depends = mesa
optdepends = qt4: for using included applications
- source = openmesh-6.3.tar.bz2::http://www.openmesh.org/media/Releases/6.3/OpenMesh-6.3.tar.bz2
+ source = openmesh-7.0.tar.bz2::http://www.openmesh.org/media/Releases/7.0/OpenMesh-7.0.tar.bz2
source = doc-install.patch
- md5sums = 07a301c8a5f5649de6f19cbe83762cb3
- md5sums = 25554594b88aada3219f3c233e80eb9b
+ md5sums = 88addd1d2530bf2c957cbba95e69fe4e
+ md5sums = d6088c06f07398b44fb6660a0f04809a
pkgname = openmesh
diff --git a/PKGBUILD b/PKGBUILD
index de1ffdbb868b..bd2e5c06cfd6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,19 +4,19 @@
_build_doc=ON
_build_apps=ON
pkgname=openmesh
-pkgver=6.3
+pkgver=7.0
pkgrel=1
pkgdesc="A generic and efficient data structure for representing and manipulating polygonal meshes"
arch=('i686' 'x86_64')
url="http://www.openmesh.org"
-license=('custom')
+license=('BSD-3')
depends=('mesa')
optdepends=('qt4: for using included applications' )
install=openmesh.install
source=("${pkgname}-${pkgver}.tar.bz2::http://www.openmesh.org/media/Releases/${pkgver}/OpenMesh-${pkgver}.tar.bz2"
doc-install.patch)
-md5sums=('07a301c8a5f5649de6f19cbe83762cb3'
- '25554594b88aada3219f3c233e80eb9b')
+md5sums=('88addd1d2530bf2c957cbba95e69fe4e'
+ 'd6088c06f07398b44fb6660a0f04809a')
if [[ "${_build_doc}" == "ON" && "${_build_apps}" == "ON" ]]; then
makedepends=('cmake' 'qt4' 'graphviz' 'doxygen')
@@ -35,6 +35,7 @@ prepare() {
}
build() {
+ rm -r build
mkdir -p build
cd build
#cd "${srcdir}/OpenMesh-${pkgver}"
@@ -42,7 +43,7 @@ build() {
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DBUILD_APPS=${_build_apps} \
- -DOPENMESH_PYTHON_VERSION=3.5
+ -DOPENMESH_PYTHON_VERSION=3.6
make
if [[ "${_build_doc}" == "ON" ]]; then
@@ -58,5 +59,4 @@ package() {
mkdir -p "${pkgdir}"/usr/share/licenses/openmesh/
install -D -m644 ../OpenMesh-${pkgver}/LICENSE \
"${pkgdir}"/usr/share/licenses/openmesh/
- mv ${pkgdir}/usr/lib/python ${pkgdir}/usr/lib/python3.5
}
diff --git a/doc-install.patch b/doc-install.patch
index 9d3a184676f7..f20f2f0d1c56 100644
--- a/doc-install.patch
+++ b/doc-install.patch
@@ -1,5 +1,5 @@
---- OpenMesh-6.3/Doc/CMakeLists.txt.orig 2016-10-23 20:32:21.999279134 +0200
-+++ OpenMesh-6.3/Doc/CMakeLists.txt 2016-10-23 20:34:36.777897182 +0200
+--- OpenMesh-7.0/Doc/CMakeLists.txt.orig 2018-04-23 14:32:21.999279134 +0200
++++ OpenMesh-7.0/Doc/CMakeLists.txt 2018-04-23 14:34:36.777897182 +0200
@@ -2,14 +2,12 @@
IF (DOXYGEN_FOUND)