summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkyak2021-07-15 20:12:21 +0300
committerkyak2021-07-15 20:12:21 +0300
commit1e5dce6b9d5390d2b800e238c4287a1003d15ef1 (patch)
tree7a147b366a9bef10ac1d51c7a3d04c797228990d
parentfba16cfdb298f3da0776d5f420ecd88da1eadf85 (diff)
downloadaur-1e5dce6b9d5390d2b800e238c4287a1003d15ef1.tar.gz
Fix build issues
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e884b5d00a88..5d4f15d4de02 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openmodelica
pkgdesc = Open-source Modelica-based modeling and simulation environment
pkgver = 1.17.0
- pkgrel = 2
+ pkgrel = 3
url = https://www.openmodelica.org
arch = x86_64
license = OSMC-PL
@@ -20,8 +20,8 @@ pkgbase = openmodelica
depends = qt5-svg
depends = qt5-tools
depends = expat
+ depends = antlr4-runtime
source = openmodelica::git+https://github.com/OpenModelica/OpenModelica.git#tag=v1.17.0
sha256sums = SKIP
pkgname = openmodelica
-
diff --git a/PKGBUILD b/PKGBUILD
index e0ef6c720c69..bc6451399459 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=openmodelica
pkgver=1.17.0
-pkgrel=2
+pkgrel=3
pkgdesc="Open-source Modelica-based modeling and simulation environment"
url="https://www.openmodelica.org"
_giturl="https://github.com/OpenModelica/OpenModelica.git"
@@ -8,7 +8,7 @@ license=('OSMC-PL')
arch=('x86_64')
depends=('java-environment' 'lapack' 'openscenegraph' 'omniorb' 'libcurl-gnutls'
'lpsolve' 'boost-libs' 'qt5-webkit' 'qt5-xmlpatterns' 'qt5-svg' 'qt5-tools'
- 'expat')
+ 'expat' 'antlr4-runtime')
makedepends=('gcc-fortran' 'cmake' 'git')
source=("${pkgname}::git+${_giturl}#tag=v${pkgver}")
sha256sums=('SKIP')
@@ -18,13 +18,15 @@ prepare() {
git remote set-url origin ${_giturl}
git submodule update --force --init --recursive
# OMCompiler: Dont try to install translations
- git cherry-pick 2a39a402d9604a1ce353b0a12574fed5d320be0e
+ git cherry-pick -n 2a39a402d9604a1ce353b0a12574fed5d320be0e
# Fix build with cmake >= 3.20
- git cherry-pick 4f3a50974f0f916efd716809699f18d47f1dbe34
+ git cherry-pick -n 4f3a50974f0f916efd716809699f18d47f1dbe34
}
build() {
cd "${pkgname}"
+ # See https://github.com/OpenModelica/OpenModelica/issues/7619
+ export CXXFLAGS=-std=c++14
autoreconf -fi
./configure --prefix=/usr
make