summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2024-05-16 18:59:04 +0200
committerMichel Zou2024-05-16 18:59:04 +0200
commit4cbee0c73b0563fdde4112ada5ed5d0772c1c69d (patch)
tree97cdff8e17fe76d41190a82ab91b6697d18f93e5
parent41be1522945057876a3634438ec935388e055ce6 (diff)
downloadaur-4cbee0c73b0563fdde4112ada5ed5d0772c1c69d.tar.gz
1.22.4
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD23
2 files changed, 15 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d92ea34f3103..183d69e05b51 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = openmodelica
pkgdesc = Open-source Modelica-based modeling and simulation environment
- pkgver = 1.22.3
+ pkgver = 1.22.4
pkgrel = 1
url = https://www.openmodelica.org
arch = x86_64
@@ -17,7 +17,7 @@ pkgbase = openmodelica
depends = qt5-xmlpatterns
depends = qt5-svg
depends = qt5-tools
- source = openmodelica::git+https://github.com/OpenModelica/OpenModelica.git#tag=v1.22.3
+ source = openmodelica::git+https://github.com/OpenModelica/OpenModelica.git#tag=v1.22.4
sha256sums = SKIP
pkgname = openmodelica
diff --git a/PKGBUILD b/PKGBUILD
index 864063081801..a7d8bd7fd8f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=openmodelica
-pkgver=1.22.3
+pkgver=1.22.4
pkgrel=1
pkgdesc="Open-source Modelica-based modeling and simulation environment"
url="https://www.openmodelica.org"
@@ -12,19 +12,22 @@ source=("${pkgname}::git+${_giturl}#tag=v${pkgver}")
sha256sums=('SKIP')
prepare() {
- cd "${pkgname}"
- git remote set-url origin ${_giturl}
- git submodule update --force --init --recursive
+ cd "${pkgname}"
+ git remote set-url origin ${_giturl}
+ git submodule update --force --init --recursive
+ curl -L https://github.com/OpenModelica/OMCompiler-3rdParty/pull/158.patch | patch -p1 -d OMCompiler/3rdParty
+ curl -L https://github.com/OpenModelica/OMSimulator/pull/1295.patch | patch -p1 -d OMSimulator
+ sed -i "/Werror/d" OMSimulator/src/OMSimulatorLib/CMakeLists.txt
}
build() {
- cd "${pkgname}"
- cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DOM_USE_CCACHE=OFF -DOM_OMEDIT_ENABLE_QTWEBENGINE=ON -B build .
- make -C build
+ cd "${pkgname}"
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DOM_USE_CCACHE=OFF -DOM_OMEDIT_ENABLE_QTWEBENGINE=ON -B build .
+ make -C build
}
package() {
- cd "${pkgname}"
- make install -C build DESTDIR=${pkgdir}
- rm -r "${pkgdir}"/usr/share/zmq
+ cd "${pkgname}"
+ make install -C build DESTDIR="${pkgdir}"
+ rm -r "${pkgdir}"/usr/share/zmq
}