summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorElMastro2022-10-02 22:56:10 +0000
committerElMastro2022-10-02 22:56:10 +0000
commit5785e6d9d88843240b46dd40c7aa05ec1d89ead9 (patch)
treef39cfdf51ea0b0b2316732860b8a7914646e433d
parentb057d638e51c0954854c15996c2bcd83fd8039be (diff)
downloadaur-openmodelica-git.tar.gz
New version. OMSens not working yet
-rwxr-xr-x.SRCINFO4
-rwxr-xr-xPKGBUILD39
2 files changed, 27 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d127d2bb143b..0b156a7c4003 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = openmodelica-git
pkgdesc = The Open Source Modelica Suite
- pkgver = 1.19.0.dev.r669.gc94e2ebbd9
+ pkgver = 1.20.0.dev.r320.g9cbaf6232e
pkgrel = 1
url = https://openmodelica.org
arch = i686
@@ -37,7 +37,7 @@ pkgbase = openmodelica-git
source = git+https://github.com/OpenModelica/OMFMISimulator-3rdParty.git
source = git+https://github.com/OpenModelica/OMTLMSimulator.git
source = git+https://github.com/OpenModelica/OMCompiler-3rdParty
- source = git+https://github.com/OpenModelica/OMSens.git
+ source = git+https://github.com/OpenModelica/OMSens
source = git+https://github.com/OpenModelica/OMSens_Qt.git
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index bf2f7059e325..f16a8990e2c0 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Xwang <xwaang1976@gmail.com>
pkgname=openmodelica-git
-pkgver=1.19.0.dev.r669.gc94e2ebbd9
+pkgver=1.20.0.dev.r320.g9cbaf6232e
pkgrel=1
pkgdesc="The Open Source Modelica Suite"
arch=('i686' 'x86_64')
@@ -16,7 +16,7 @@ source=("$pkgname::git+https://github.com/OpenModelica/OpenModelica"
git+https://github.com/OpenModelica/OMFMISimulator-3rdParty.git
git+https://github.com/OpenModelica/OMTLMSimulator.git
git+https://github.com/OpenModelica/OMCompiler-3rdParty
- git+https://github.com/OpenModelica/OMSens.git
+ git+https://github.com/OpenModelica/OMSens
git+https://github.com/OpenModelica/OMSens_Qt.git)
md5sums=('SKIP'
'SKIP'
@@ -38,18 +38,22 @@ provides=('openmodelica')
conflicts=('openmodelica' 'openmodelica-svn' 'openmodelica-dev')
prepare() {
- mkdir bin
- ln -s /usr/bin/gfortran-9 bin/gfortran
+
+ #mkdir bin
+ #ln -s /usr/bin/gfortran-9 bin/gfortran
export PATH="$PWD/bin:$PATH"
cd $pkgname
+
git submodule init
+
git config submodule.OMOptim.url "$srcdir"/OMOptim
git config submodule.libraries.url "$srcdir"/OMLibraries
git config submodule.OMSimulator.url "$srcdir"/OMSimulator
git config submodule.OMCompiler-3rdParty.url "$srcdir"/OMCompiler-3rdParty
git config submodule.OMSens.url "$srcdir"/OMSens
git config submodule.OMSens_Qt.url "$srcdir"/OMSens_Qt
- git submodule update
+ git submodule update --remote
+
cd OMOptim
git submodule init
git config submodule.common.url "$srcdir"/OpenModelica-common
@@ -64,13 +68,20 @@ prepare() {
git submodule init
git config submodule.common.url "$srcdir"/OpenModelica-common
git submodule update
- cd ..
- sed -i '18 i #include <qpainterpath.h>' OMPlot/qwt/src/qwt_painter_command.h
- sed -i '16 i #include <qpainterpath.h>' OMPlot/qwt/src/qwt_null_paintdevice.h
- sed -i '30 i #include <qpainterpath.h>' OMPlot/qwt/src/qwt_painter.cpp
- sed -i '14 i #include <qpainterpath.h>' OMPlot/qwt/src/qwt_widget_overlay.cpp
- sed -i '14 i #include <qpainterpath.h>' OMPlot/qwt/src/qwt_compass_rose.cpp
- sed -i '16 i #include <qpainterpath.h>' OMPlot/qwt/src/qwt_dial_needle.cpp
+ cd ..
+
+ #cd OMSens
+ #python setup.py install
+ #cd ..
+
+
+
+ #sed -i '18 i #include <qpainterpath.h>' OMPlot/qwt/src/qwt_painter_command.h
+ #sed -i '16 i #include <qpainterpath.h>' OMPlot/qwt/src/qwt_null_paintdevice.h
+ #sed -i '30 i #include <qpainterpath.h>' OMPlot/qwt/src/qwt_painter.cpp
+ #sed -i '14 i #include <qpainterpath.h>' OMPlot/qwt/src/qwt_widget_overlay.cpp
+ #sed -i '14 i #include <qpainterpath.h>' OMPlot/qwt/src/qwt_compass_rose.cpp
+ #sed -i '16 i #include <qpainterpath.h>' OMPlot/qwt/src/qwt_dial_needle.cpp
}
pkgver() {
@@ -82,8 +93,8 @@ build() {
cd $pkgname
autoreconf -fi
autoconf
- export CPPFLAGS="$CPPFLAGS -DH5_USE_18_API"
- ./configure --prefix=/usr/ CC=clang --with-UMFPACK # CXX=clang++
+ #export CPPFLAGS="$CPPFLAGS -DH5_USE_18_API"
+ ./configure --prefix=/usr/ --without-omc --with-UMFPACK CC=clang #CXX=clang++
make
}