summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2022-07-06 18:22:01 +0200
committerMichel Zou2022-07-06 18:22:01 +0200
commit08f91199502eb3bb3644078e924304d37be79330 (patch)
tree292e14898c4c54377c50a8658c78355317c41f39
parent07707597a3deb8118639c8052ad476a59b634d21 (diff)
downloadaur-08f91199502eb3bb3644078e924304d37be79330.tar.gz
lapack
-rw-r--r--PKGBUILD7
1 files changed, 7 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 76c9b4d9a6e1..f106e4d70c7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,10 +23,17 @@ build() {
autoreconf -vfi
./configure --prefix=/usr/
make
+
+ # bundle a static version of lapack required to build fmus
+ curl -fsSL https://github.com/Reference-LAPACK/lapack/archive/v3.10.1.tar.gz | tar xz
+ cd lapack-3.10.1 && mkdir -p build && cd build
+ cmake -DBUILD_TESTING=OFF -DCMAKE_BUILD_TYPE=Release -DBUILD_SHARED_LIBS=OFF ..
+ make
}
package() {
cd "$srcdir/OpenModelica/OMCompiler"
make install DESTDIR="${pkgdir}"
chmod go+rx "${pkgdir}"/usr/share/omc/runtime/c/fmi/buildproject/config.*
+ install -m644 lapack-3.10.1/build/lib/lib*.a "${pkgdir}"/usr/lib/x86_64-linux-gnu/omc
}