summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2023-07-22 12:26:38 +0200
committerMichel Zou2023-07-22 12:26:38 +0200
commit9cf8e020017ffbfe481a184b3ca02a261bf9c2ad (patch)
tree4e8838b53578b401a87676148493682998725eda
parentc92dd66c6d3b8f070d6b8b42683a3742eab63e63 (diff)
downloadaur-9cf8e020017ffbfe481a184b3ca02a261bf9c2ad.tar.gz
shared lapack
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5bab99990898..b0a27019f1bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,9 +11,6 @@ pkgbase = openmodelica-omc
makedepends = git
makedepends = boost
depends = lapack
- depends = lapack-static
- depends = expat
- depends = lpsolve
depends = java-environment
source = git+https://github.com/OpenModelica/OpenModelica.git#tag=v1.21.0
sha1sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 64531e6d15c6..cf09a9c2c083 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ url="https://openmodelica.org"
license=('OSMC-PL')
_giturl="https://github.com/OpenModelica/OpenModelica.git"
groups=(openmodelica)
-depends=('lapack' 'lapack-static' 'expat' 'lpsolve' 'java-environment')
+depends=('lapack' 'java-environment')
makedepends=('gcc-fortran' 'cmake' 'git' 'boost')
source=("git+${_giturl}#tag=v${pkgver}")
sha1sums=('SKIP')
@@ -19,6 +19,9 @@ prepare() {
# fix build with gcc 13
curl -L https://github.com/oneapi-src/oneTBB/pull/833.patch | patch -p1 -d OMCompiler/3rdParty/tbb
+
+ # link with shared blas/lapack libs: https://github.com/OpenModelica/OpenModelica/issues/10304
+ sed -i "s|-Wl,-Bstatic -lSimulationRuntimeFMI \$LDFLAGS \$LD_LAPACK -Wl,-Bdynamic|-Wl,-Bstatic -lSimulationRuntimeFMI -Wl,-Bdynamic \$LDFLAGS \$LD_LAPACK|g" OMCompiler/configure.ac
}
build() {