summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Eberhardt2019-03-13 10:52:58 +0100
committerSebastian Eberhardt2019-03-13 10:52:58 +0100
commita4bc89d2db1f92faa03a3e5895ba7210970cd31f (patch)
tree2bf72d7c76b3192d0e255260b61b9fe92e6c47b0
parent5e419791004294f17b576b3f238984f812fbcb93 (diff)
downloadaur-a4bc89d2db1f92faa03a3e5895ba7210970cd31f.tar.gz
switched maintainer, update to openmpi 4.0.0
-rw-r--r--PKGBUILD53
-rw-r--r--system_ltdl.patch66
2 files changed, 24 insertions, 95 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c3d1dc4df736..e2cce5fa3253 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,32 @@
-# Maintainer: epitron <chris@ill-logic.com>
+# Maintainer: Sebastian Eberhardt <gpgpu_blog@protonmail.com>
+# Contributor: epitron <chris@ill-logic.com>
# Contributor: Anatol Pomozov <anatol dot pomozov at gmail>
# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
-
+#
pkgname=openmpi-cuda
_pkgname=openmpi
-pkgver=1.10.6
+pkgver=4.0.0
pkgrel=1
-pkgdesc='High performance message passing library (MPI) with CUDA support'
-arch=(i686 x86_64)
-url='http://www.open-mpi.org'
-license=(custom)
-depends=(libltdl hwloc)
-provides=(openmpi)
-conflicts=(openmpi)
-makedepends=(inetutils valgrind gcc-fortran)
+pkgdesc="High Performance Message Passing Library (MPI) compiled with CUDA support enabled"
+arch=('x86_64')
+url="https://www.open-mpi.org/"
+license=('BSD')
+groups=()
+depends=('libsystemd' 'libnl' 'numactl' 'libpciaccess' 'cuda')
+makedepends=('git' 'valgrind' 'gcc-fortran')
+provides=("${pkgname%-cuda}")
+conflicts=("${pkgname%-cuda}")
optdepends=('gcc-fortran: fortran support')
options=(staticlibs)
-source=(http://www.open-mpi.org/software/ompi/v${pkgver%.*}/downloads/${_pkgname}-${pkgver}.tar.bz2)
-sha256sums=('65606184a084a0eda6102b01e5a36a8f02d3195d15e91eabbb63e898bd110354')
+source=(https://www.open-mpi.org/software/ompi/v${pkgver%.*}/downloads/${_pkgname}-${pkgver}.tar.bz2)
+sha256sums=('2f0b8a36cfeb7354b45dda3c5425ef8393c9b04115570b615213faaa3f97366b')
+
build() {
- cd $_pkgname-$pkgver
+ cd openmpi-$pkgver
- ./autogen.pl
./configure --prefix=/usr \
- --sysconfdir=/etc/${_pkgname} \
+ --sysconfdir=/etc/openmpi \
--enable-mpi-fortran=all \
--libdir=/usr/lib/${_pkgname} \
--with-threads=posix \
@@ -34,12 +36,11 @@ build() {
--enable-pretty-print-stacktrace \
--without-slurm \
--with-hwloc=/usr \
- --with-libltdl=/usr \
- --with-cuda=/opt/cuda \
- FC=/usr/bin/gfortran \
+ --with-cuda=/opt/cuda/include \
+ --with-libltdl=/usr \
LDFLAGS="$LDFLAGS -Wl,-z,noexecstack"
- make
+ make -j8
}
check() {
@@ -54,18 +55,12 @@ package() {
# FS#28583
install -d -m 755 "$pkgdir"/usr/lib/pkgconfig
- for i in ompi-c.pc ompi-cxx.pc ompi-f77.pc ompi-f90.pc ompi.pc; do
- ln -sf /usr/lib/openmpi/pkgconfig/$i "$pkgdir"/usr/lib/pkgconfig/
+ for i in ompi-c.pc ompi-cxx.pc ompi.pc; do
+ ln -sf /usr/lib/$_pkgname/pkgconfig/$i "$pkgdir"/usr/lib/pkgconfig/
done
- # Openmpi's otfinfo conflicts with the one from texlive
- mv "$pkgdir"/usr/bin/otfinfo{,mpi}
-
- # Remove dangling symlink and useless file
- rm "$pkgdir"/usr/share/vampirtrace/config.log
-
install -d -m 755 "$pkgdir"/etc/ld.so.conf.d
echo "/usr/lib/$_pkgname" > "$pkgdir"/etc/ld.so.conf.d/$_pkgname.conf
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$_pkgname/LICENSE
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
diff --git a/system_ltdl.patch b/system_ltdl.patch
deleted file mode 100644
index 300da383f47d..000000000000
--- a/system_ltdl.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-diff --git a/config/ltdl.m4 b/config/ltdl.m4
-index ea76f4d..2f1cbfe 100644
---- a/config/ltdl.m4
-+++ b/config/ltdl.m4
-@@ -162,6 +162,8 @@ m4_defun([_LTDL_INSTALLABLE],
- fi
- fi
-
-+enable_ltdl_install=no
-+
- # If configure.ac declared an installable ltdl, and the user didn't override
- # with --disable-ltdl-install, we will install the shipped libltdl.
- case $enable_ltdl_install in
-diff --git a/ompi/debuggers/Makefile.am b/ompi/debuggers/Makefile.am
-index 2adf3fd..5b22a91 100644
---- a/ompi/debuggers/Makefile.am
-+++ b/ompi/debuggers/Makefile.am
-@@ -46,8 +46,7 @@ headers = \
- # Simple checks to ensure that the DSOs are functional
-
- dlopen_test_SOURCES = dlopen_test.c
--dlopen_test_CPPFLAGS = -I$(top_srcdir)/opal/libltdl
--dlopen_test_LDADD = $(top_builddir)/opal/libltdl/libltdlc.la
-+dlopen_test_LDADD = -lltdl
-
- predefined_gap_test_SOURCES = predefined_gap_test.c
- predefined_gap_test_LDFLAGS = $(WRAPPER_EXTRA_LDFLAGS)
-diff --git a/ompi/debuggers/dlopen_test.c b/ompi/debuggers/dlopen_test.c
-index 029a4ee..023afb8 100644
---- a/ompi/debuggers/dlopen_test.c
-+++ b/ompi/debuggers/dlopen_test.c
-@@ -13,7 +13,7 @@
- #include <string.h>
- #include <stdlib.h>
-
--#include "opal/libltdl/ltdl.h"
-+#include "ltdl.h"
-
- static int do_test(void);
-
-diff --git a/test/support/components.c b/test/support/components.c
-index 41c4345..6b4b464 100644
---- a/test/support/components.c
-+++ b/test/support/components.c
-@@ -24,7 +24,7 @@
-
- #include "opal/constants.h"
- #include "opal/mca/mca.h"
--#include "opal/libltdl/ltdl.h"
-+#include "ltdl.h"
-
- #include "components.h"
-
-diff --git a/test/support/components.h b/test/support/components.h
-index 6db1f0d..fc8dfc5 100644
---- a/test/support/components.h
-+++ b/test/support/components.h
-@@ -20,7 +20,7 @@
- #ifndef OMPI_SUPPORT_COMPONENTS_H
- #define OMPI_SUPPORT_COMPONENTS_H
-
--#include "opal/libltdl/ltdl.h"
-+#include "ltdl.h"
- #include "opal/mca/mca.h"
-
- BEGIN_C_DECLS