summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrobot Viktor2019-01-29 19:23:56 +0300
committerDrobot Viktor2019-01-29 19:23:56 +0300
commit1dacf3530fa9c7eba670eaf72f3dc7176c1134e8 (patch)
tree1570fd2f68b771bee2f75ef80b7e5ca479991ae4
downloadaur-1dacf3530fa9c7eba670eaf72f3dc7176c1134e8.tar.gz
First release
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD61
2 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bcec4633fb7e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = openmpi-gcc6
+ pkgdesc = High performance message passing library (MPI) build with gcc6
+ pkgver = 3.1.3
+ pkgrel = 1
+ url = https://www.open-mpi.org
+ arch = x86_64
+ license = custom:OpenMPI
+ makedepends = inetutils
+ makedepends = valgrind
+ makedepends = gcc6-fortran
+ depends = libltdl
+ depends = hwloc
+ depends = openssh
+ depends = zlib
+ depends = libnl
+ depends = gcc6
+ optdepends = gcc6-fortran: fortran support
+ options = staticlibs
+ source = https://www.open-mpi.org/software/ompi/v3.1/downloads/openmpi-3.1.3.tar.bz2
+ sha256sums = 8be04307c00f51401d3fb9d837321781ea7c79f2a5a4a2e5d4eaedc874087ab6
+ sha512sums = 700821df676de5f85ce2793298242dcaea73f585f89540e30999792a568f193545a9f9b2bcb3ea22effa3bf14744531c4eb5fc4c84a8d7bbe5e5fdd76ab3a04a
+
+pkgname = openmpi-gcc6
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..13280f479ab3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+
+pkgname=openmpi-gcc6
+pkgver=3.1.3
+pkgrel=1
+pkgdesc='High performance message passing library (MPI) build with gcc6'
+url='https://www.open-mpi.org'
+arch=('x86_64')
+license=('custom:OpenMPI')
+depends=('libltdl' 'hwloc' 'openssh' 'zlib' 'libnl' 'gcc6')
+makedepends=('inetutils' 'valgrind' 'gcc6-fortran')
+optdepends=('gcc6-fortran: fortran support')
+options=('staticlibs')
+source=(https://www.open-mpi.org/software/ompi/v${pkgver%.*}/downloads/${pkgname%-gcc6}-${pkgver}.tar.bz2)
+sha256sums=('8be04307c00f51401d3fb9d837321781ea7c79f2a5a4a2e5d4eaedc874087ab6')
+sha512sums=('700821df676de5f85ce2793298242dcaea73f585f89540e30999792a568f193545a9f9b2bcb3ea22effa3bf14744531c4eb5fc4c84a8d7bbe5e5fdd76ab3a04a')
+
+build() {
+ cd ${pkgname%-gcc6}-${pkgver}
+ export LD_LIBRARY_PATH="/usr/lib/gcc/x86_64-pc-linux-gnu/6.5.0:$LD_LIBRARY_PATH"
+ ./configure --prefix=/opt/${pkgname} \
+ --sysconfdir=/etc/${pkgname} \
+ --enable-mpi-fortran=all \
+ --libdir=/usr/lib/${pkgname} \
+ --with-threads=posix \
+ --enable-mpi-thread-multiple \
+ --enable-smp-locks \
+ --enable-builtin-atomics \
+ --enable-mpi-cxx \
+ --with-valgrind \
+ --enable-memchecker \
+ --enable-pretty-print-stacktrace \
+ --without-slurm \
+ --with-hwloc=/usr \
+ --with-libltdl=/usr \
+ CC=/usr/bin/gcc-6 CXX=/usr/bin/g++-6 FC=/usr/bin/gfortran-6 \
+ LDFLAGS="${LDFLAGS} -Wl,-z,noexecstack"
+ make
+}
+
+check() {
+ cd ${pkgname%-gcc6}-${pkgver}
+ make check
+}
+
+package() {
+ cd ${pkgname%-gcc6}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+
+ # FS#28583
+# install -dm 755 "${pkgdir}/usr/lib/pkgconfig"
+# for i in ompi-c.pc ompi-cxx.pc ompi-f77.pc ompi-f90.pc ompi.pc; do
+# ln -sf "/usr/lib/${pkgname}/pkgconfig/${i}" "${pkgdir}/usr/lib/pkgconfig/"
+# done
+
+ install -dm 755 "${pkgdir}/etc/ld.so.conf.d"
+ echo "/usr/lib/${pkgname}" > "${pkgdir}"/etc/ld.so.conf.d/${pkgname}.conf
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+
+# vim: ts=2 sw=2 et: