summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrobot Viktor2019-08-20 18:01:57 +0300
committerDrobot Viktor2019-08-20 18:01:57 +0300
commit9f1ca779ca36103087df5570084f98381c823788 (patch)
treeb53479485c306da13a7d65347190103d86ba2a3f
downloadaur-9f1ca779ca36103087df5570084f98381c823788.tar.gz
First release
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD67
2 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1ab0d255419f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = openmpi3-gcc7
+ pkgdesc = High performance message passing library (MPI)
+ pkgver = 3.1.4
+ pkgrel = 1
+ url = https://www.open-mpi.org
+ arch = x86_64
+ license = custom:OpenMPI
+ makedepends = inetutils
+ makedepends = valgrind
+ makedepends = gcc7-fortran
+ depends = libltdl
+ depends = hwloc
+ depends = openssh
+ depends = zlib
+ depends = libnl
+ depends = gcc7
+ optdepends = gcc7-fortran: fortran support
+ provides = openmpi
+ conflicts = openmpi
+ options = staticlibs
+ source = https://www.open-mpi.org/software/ompi/v3.1/downloads/openmpi-3.1.4.tar.bz2
+ sha256sums = 17a69e0054db530c7dc119f75bd07d079efa147cf94bf27e590905864fe379d6
+ sha512sums = 5b4aafffc79fd85cb94a11a6e2fac563b142ac532191009eb35826c432ed3c391a6616e2ca92eacbf36137468eadb7c0f7ddc787034bc95c4214232ed5128338
+
+pkgname = openmpi3-gcc7
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5453de5a0960
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+
+pkgname=openmpi3-gcc7
+_pkgname=openmpi
+pkgver=3.1.4
+_gccver=7.4.1
+pkgrel=1
+pkgdesc='High performance message passing library (MPI)'
+url='https://www.open-mpi.org'
+arch=('x86_64')
+license=('custom:OpenMPI')
+depends=('libltdl' 'hwloc' 'openssh' 'zlib' 'libnl' 'gcc7')
+makedepends=('inetutils' 'valgrind' 'gcc7-fortran')
+optdepends=('gcc7-fortran: fortran support')
+conflicts=('openmpi')
+provides=('openmpi')
+options=('staticlibs')
+source=(https://www.open-mpi.org/software/ompi/v${pkgver%.*}/downloads/${_pkgname}-${pkgver}.tar.bz2)
+sha256sums=('17a69e0054db530c7dc119f75bd07d079efa147cf94bf27e590905864fe379d6')
+sha512sums=('5b4aafffc79fd85cb94a11a6e2fac563b142ac532191009eb35826c432ed3c391a6616e2ca92eacbf36137468eadb7c0f7ddc787034bc95c4214232ed5128338')
+
+build() {
+ cd ${_pkgname}-${pkgver}
+
+ export LD_LIBRARY_PATH="/usr/lib/gcc/x86_64-pc-linux-gnu/${_gccver}:$LD_LIBRARY_PATH"
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc/${_pkgname} \
+ --enable-mpi-fortran=all \
+ --libdir=/usr/lib/${_pkgname} \
+ --with-threads=posix \
+ --enable-mpi-thread-multiple \
+ --enable-smp-locks \
+ --enable-builtin-atomics \
+ --enable-mpi-cxx \
+ --with-valgrind \
+ --enable-memchecker \
+ --enable-pretty-print-stacktrace \
+ --without-slurm \
+ --with-hwloc=/usr \
+ --with-libltdl=/usr \
+ CC=/usr/bin/gcc-7 CXX=/usr/bin/g++-7 FC=/usr/bin/gfortran-7 \
+ LDFLAGS="${LDFLAGS} -Wl,-z,noexecstack"
+ make
+}
+
+check() {
+ cd ${_pkgname}-${pkgver}
+ make check
+}
+
+package() {
+ cd ${_pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+
+ # FS#28583
+ install -dm 755 "${pkgdir}/usr/lib/pkgconfig"
+ for i in ompi-c.pc ompi-cxx.pc ompi-f77.pc ompi-f90.pc ompi.pc; do
+ ln -sf "/usr/lib/openmpi/pkgconfig/${i}" "${pkgdir}/usr/lib/pkgconfig/"
+ done
+
+ install -dm 755 "${pkgdir}/etc/ld.so.conf.d"
+ echo "/usr/lib/${_pkgname}" > "${pkgdir}"/etc/ld.so.conf.d/${_pkgname}.conf
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${_pkgname}"
+}
+
+# vim: ts=2 sw=2 et: