summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas Zimmermann2019-02-16 15:43:18 +0100
committerLukas Zimmermann2019-02-16 15:43:18 +0100
commita617ac149301a143f4f73622621b076dd013ec00 (patch)
treef6e0959e0cbec9f0d4c62e8404e9c87bd3d4d119
parent223e9b1dbe4c4b6f42727e4960899e426f066a0d (diff)
downloadaur-a617ac149301a143f4f73622621b076dd013ec00.tar.gz
Update OpenMS to 2.4 release
-rw-r--r--.SRCINFO16
-rwxr-xr-xPKGBUILD93
2 files changed, 73 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6076352d510c..ff2fd657a92e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = openms
pkgdesc = C++ library and tools for LC/MS data management and analyses
- pkgver = 2.3.0
+ pkgver = 2.4.0
pkgrel = 1
url = http://www.openms.de
arch = i686
@@ -8,25 +8,23 @@ pkgbase = openms
license = BSD
makedepends = autoconf
makedepends = automake
- makedepends = binutils
makedepends = cmake
makedepends = fakeroot
makedepends = gcc
makedepends = make
makedepends = patch
depends = boost
- depends = qt4
- depends = qtwebkit
- depends = xerces-c
- depends = bzip2
depends = eigen
depends = glpk
- depends = zlib
- source = https://download.sourceforge.net/project/open-ms/OpenMS/OpenMS-2.3/OpenMS-2.3.0-src.tar.gz
+ depends = qt5-base
+ depends = qt5-svg
+ depends = sqlite
+ depends = xerces-c
+ source = https://download.sourceforge.net/project/open-ms/OpenMS/OpenMS-2.4/OpenMS-2.4.0-src.tar.gz
source = OpenMS-TOPPView.desktop
source = OpenMS-TOPPAS.desktop
source = OpenMS.sh
- sha256sums = 6ddc56811e1bcb67f28b8c55781229bbe10cc8250b59e76ba1f2a3b52e142ba5
+ sha256sums = 86e8176b0f89cc86a10f5c3e60c34140d591e9e6c85f129ccbfa13ecb16a9af2
sha256sums = 4f93d5c22a8267e4fbde6883ecc34a00abfc2ee5eafb46f6d81256ad8a33cdac
sha256sums = 9b33c6c91d931802e88af89ade4beb6c8d05484d57d1ad804888511b7a8b00a0
sha256sums = 2cf69cb56959f101614129d2a87dc078daca904e1701ed674d399afed1ff306d
diff --git a/PKGBUILD b/PKGBUILD
index 8bd012fcc9a9..f1f9ceb8f8ff 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,42 +2,81 @@
# Contributor: saxonbeta <saxonbeta at gmail dot com>
pkgname=openms
_pkgname=OpenMS
-pkgver=2.3.0
-_pkgver=2.3
+pkgver=2.4.0
+_pkgver=2.4
pkgrel=1
pkgdesc="C++ library and tools for LC/MS data management and analyses"
arch=('i686' 'x86_64')
url="http://www.openms.de"
license=('BSD')
-depends=('boost' 'qt4' 'qtwebkit' 'xerces-c' 'bzip2' 'eigen' 'glpk' 'zlib')
-makedepends=('autoconf' 'automake' 'binutils' 'cmake' 'fakeroot' 'gcc' 'make' 'patch')
+depends=('boost' 'eigen' 'glpk' 'qt5-base' 'qt5-svg' 'sqlite' 'xerces-c')
+makedepends=('autoconf' 'automake' 'cmake' 'fakeroot' 'gcc' 'make' 'patch')
source=("https://download.sourceforge.net/project/open-ms/${_pkgname}/${_pkgname}-${_pkgver}/${_pkgname}-${pkgver}-src.tar.gz"
- OpenMS-TOPPView.desktop OpenMS-TOPPAS.desktop OpenMS.sh)
-sha256sums=('6ddc56811e1bcb67f28b8c55781229bbe10cc8250b59e76ba1f2a3b52e142ba5'
+ "OpenMS-TOPPView.desktop"
+ "OpenMS-TOPPAS.desktop"
+ "OpenMS.sh")
+sha256sums=('86e8176b0f89cc86a10f5c3e60c34140d591e9e6c85f129ccbfa13ecb16a9af2'
'4f93d5c22a8267e4fbde6883ecc34a00abfc2ee5eafb46f6d81256ad8a33cdac'
'9b33c6c91d931802e88af89ade4beb6c8d05484d57d1ad804888511b7a8b00a0'
- '2cf69cb56959f101614129d2a87dc078daca904e1701ed674d399afed1ff306d')
+ '2cf69cb56959f101614129d2a87dc078daca904e1701ed674d399afed1ff306d')
+
+# Variables
+_prefix="${_pkgname}-${pkgver}"
+_openms_build="${_prefix}-build"
+
+_physpath() {
+ realpath -P "$1"
+}
+
+_goto_empty_dir_in_src() {
+ cd "${srcdir}"
+ rm -rf "$1"
+ mkdir "$1"
+ cd "$1"
+}
+
+_build_contrib() {
+ _goto_empty_dir_in_src "${_contrib_build}"
+ for contrib in $@; do
+ cmake -DBUILD_TYPE="${contrib}" "$(_physpath ../${_prefix}/contrib)"
+ done
+}
+
+_build_openms() {
+ _goto_empty_dir_in_src "${_openms_build}"
+ cmake \
+ -DOPENMS_CONTRIB_LIBS="$(_physpath ../${_contrib_build})" \
+ -DHAS_XSERVER=On \
+ -DWITH_GUI=On \
+ -DENABLE_TUTORIALS=Off \
+ -DENABLE_DOCS=Off \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX="$(_physpath ${pkgdir}/usr)" \
+ "$(_physpath ../${_prefix})"
+ make $@
+}
+
build() {
- cd "${srcdir}/"
- rm -rf ${_pkgname}-${pkgver}-build
- mkdir ${_pkgname}-${pkgver}-build
- rm -rf contrib-build
- mkdir contrib-build
- cd contrib-build
- cmake -DBUILD_TYPE=SEQAN $(realpath -P ../${_pkgname}-${pkgver}/contrib)
- cmake -DBUILD_TYPE=LIBSVM $(realpath -P ../${_pkgname}-${pkgver}/contrib)
- cmake -DBUILD_TYPE=COINOR $(realpath -P ../${_pkgname}-${pkgver}/contrib)
- cmake -DBUILD_TYPE=KISSFFT $(realpath -P ../${_pkgname}-${pkgver}/contrib)
- cmake -DBUILD_TYPE=WILDMAGIC $(realpath -P ../${_pkgname}-${pkgver}/contrib)
- cd ../${_pkgname}-${pkgver}-build
- cmake -DCMAKE_BUILD_TYPE=Release -DOPENMS_CONTRIB_LIBS=$(realpath -P ../contrib-build) -DCMAKE_INSTALL_PREFIX=$(realpath -P ${pkgdir}/usr) $(realpath -P ../${_pkgname}-${pkgver})
- make OpenMS TOPP UTILS GUI
+
+ # Variables
+ local _contrib_build="contrib-build"
+
+ # Build the required contribs, which cannot be covered by other Arch Linux packages
+ # Note: We also build SQLITE, since AUR offers sqlite2. If this is installed,
+ # the build process might erroneously link against sqlite2, which will then
+ # break the build
+ _build_contrib SQLITE SEQAN LIBSVM COINOR KISSFFT WILDMAGIC
+
+ # Build OpenMS
+ _build_openms OpenMS TOPP UTILS GUI
}
+
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}-build"
- make DESTDIR=${pkgdir}/usr install
- install -D -m644 ${srcdir}/${_pkgname}-${pkgver}/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -D -m644 ${srcdir}/OpenMS-TOPPView.desktop ${pkgdir}/usr/share/applications/OpenMS-TOPPView.desktop
- install -D -m644 ${srcdir}/OpenMS-TOPPAS.desktop ${pkgdir}/usr/share/applications/OpenMS-TOPPAS.desktop
- install -D -m644 ${srcdir}/OpenMS.sh ${pkgdir}/etc/profile.d/OpenMS.sh
+ cd "${srcdir}/${_openms_build}"
+ make DESTDIR="${pkgdir}/usr" install
+ local INSTALL='install -m644 -D'
+ $INSTALL "${srcdir}/${_prefix}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ $INSTALL "${srcdir}/OpenMS-TOPPView.desktop" "${pkgdir}/usr/share/applications/OpenMS-TOPPView.desktop"
+ $INSTALL "${srcdir}/OpenMS-TOPPAS.desktop" "${pkgdir}/usr/share/applications/OpenMS-TOPPAS.desktop"
+ $INSTALL "${srcdir}/OpenMS.sh" "${pkgdir}/etc/profile.d/OpenMS.sh"
}