summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlukaszimmermann2018-01-19 11:38:07 +0100
committerlukaszimmermann2018-01-19 11:38:07 +0100
commitc75cf6fa2212577b97cdc8a0b22d3e942e99f91a (patch)
tree341b557757cf9153a3edb3c91e83305eb145d9e9
parent74244efe7879519eefe3b771a74b0357a416e8fd (diff)
downloadaur-c75cf6fa2212577b97cdc8a0b22d3e942e99f91a.tar.gz
Update OpenMS to 2.3 release from 2018-01-02
-rw-r--r--.SRCINFO36
-rwxr-xr-xOpenMS-TOPPAS.desktop5
-rwxr-xr-xOpenMS-TOPPView.desktop3
-rwxr-xr-xPKGBUILD66
4 files changed, 58 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 66f758d4c0b5..a0c1d8d4ea9f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,33 @@
pkgbase = openms
pkgdesc = C++ library and tools for LC/MS data management and analyses
- pkgver = 2.0.0
- pkgrel = 2
- url = http://open-ms.sourceforge.net/
+ pkgver = 2.3.0
+ pkgrel = 1
+ url = http://www.openms.de
arch = i686
arch = x86_64
license = BSD
+ makedepends = autoconf
+ makedepends = automake
+ makedepends = binutils
makedepends = cmake
- makedepends = boost
- depends = boost-libs
- depends = libsvm
- depends = glpk
- depends = xerces-c
+ makedepends = fakeroot
+ makedepends = gcc
+ makedepends = make
+ makedepends = patch
+ depends = boost
+ depends = qt4
depends = qtwebkit
+ depends = xerces-c
+ depends = bzip2
depends = eigen
- optdepends = dot2tex: Create package documentation during compilation
- optdepends = texlive-core: Create package documentation during compilation
- optdepends = texlive-latexextra: Create package documentation during compilation
- optdepends = doxygen: Create package documentation during compilation
- source = http://download.sourceforge.net/project/open-ms/OpenMS/OpenMS-2.0/OpenMS-2.0.0_src.tar.gz
+ depends = glpk
+ depends = zlib
+ source = https://download.sourceforge.net/project/open-ms/OpenMS/OpenMS-2.3/OpenMS-2.3.0-src.tar.gz
source = OpenMS-TOPPView.desktop
source = OpenMS-TOPPAS.desktop
- sha256sums = 957bbb28bf484b9e288986c103109298f9aeac8e4d5e68b8b58ac2e365d7ab3d
- sha256sums = 76fab06730720c786a0b874ba6bb8b85adae85b11dde9c68c35a0d3e76d7f049
- sha256sums = ba63c4aa90b1c055141cb0ef5bd199e390912595e7fdb8d30e9bb777f189ca30
+ sha256sums = 6ddc56811e1bcb67f28b8c55781229bbe10cc8250b59e76ba1f2a3b52e142ba5
+ sha256sums = 06819f1899b6122d513e67f2427c0c07bab522f859a79b6c7dd56e7d627d0d23
+ sha256sums = 866f5c99e9516af943e06f3407bad6abbb24167f90e351e4727edb2c5cf058cf
pkgname = openms
diff --git a/OpenMS-TOPPAS.desktop b/OpenMS-TOPPAS.desktop
index 8ebb76cedc99..b04056fd17c2 100755
--- a/OpenMS-TOPPAS.desktop
+++ b/OpenMS-TOPPAS.desktop
@@ -4,7 +4,8 @@ GenericName=
Comment=Software for LC-MS data management and analyses
Exec=TOPPAS
Icon=applications-science
-Terminal=false
Type=Application
+Terminal=false
Categories=Science;
-StartupNotify=false \ No newline at end of file
+StartupNotify=false
+
diff --git a/OpenMS-TOPPView.desktop b/OpenMS-TOPPView.desktop
index 0d2c21c99c65..ff088c7e26e7 100755
--- a/OpenMS-TOPPView.desktop
+++ b/OpenMS-TOPPView.desktop
@@ -7,4 +7,5 @@ Icon=applications-science
Terminal=false
Type=Application
Categories=Science;
-StartupNotify=false \ No newline at end of file
+StartupNotify=false
+
diff --git a/PKGBUILD b/PKGBUILD
index f6163cb576c4..8a90d5b32962 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,41 @@
- # Maintainer: saxonbeta <saxonbeta at gmail dot com>
+# Maintainer: lukaszimmermann <luk.zim91 at gmail dot com>
+# Contributor: saxonbeta <saxonbeta at gmail dot com>
pkgname=openms
_pkgname=OpenMS
-pkgver=2.0.0
-pkgrel=2
+pkgver=2.3.0
+_pkgver=2.3
+pkgrel=1
pkgdesc="C++ library and tools for LC/MS data management and analyses"
arch=('i686' 'x86_64')
-url="http://open-ms.sourceforge.net/"
+url="http://www.openms.de"
license=('BSD')
-depends=('boost-libs' 'libsvm' 'glpk' 'xerces-c' 'qtwebkit' 'eigen')
-makedepends=('cmake' 'boost')
-optdepends=('dot2tex: Create package documentation during compilation'
- 'texlive-core: Create package documentation during compilation'
- 'texlive-latexextra: Create package documentation during compilation'
- 'doxygen: Create package documentation during compilation')
-source=("http://download.sourceforge.net/project/open-ms/${_pkgname}/${_pkgname}-2.0/${_pkgname}-${pkgver}_src.tar.gz"
- 'OpenMS-TOPPView.desktop' 'OpenMS-TOPPAS.desktop')
-sha256sums=('957bbb28bf484b9e288986c103109298f9aeac8e4d5e68b8b58ac2e365d7ab3d'
- '76fab06730720c786a0b874ba6bb8b85adae85b11dde9c68c35a0d3e76d7f049'
- 'ba63c4aa90b1c055141cb0ef5bd199e390912595e7fdb8d30e9bb777f189ca30')
-
-
-
-
+depends=('boost' 'qt4' 'qtwebkit' 'xerces-c' 'bzip2' 'eigen' 'glpk' 'zlib')
+makedepends=('autoconf' 'automake' 'binutils' 'cmake' 'fakeroot' 'gcc' 'make' 'patch')
+source=("https://download.sourceforge.net/project/open-ms/${_pkgname}/${_pkgname}-${_pkgver}/${_pkgname}-${pkgver}-src.tar.gz"
+ OpenMS-TOPPView.desktop OpenMS-TOPPAS.desktop)
+sha256sums=('6ddc56811e1bcb67f28b8c55781229bbe10cc8250b59e76ba1f2a3b52e142ba5'
+ '06819f1899b6122d513e67f2427c0c07bab522f859a79b6c7dd56e7d627d0d23'
+ '866f5c99e9516af943e06f3407bad6abbb24167f90e351e4727edb2c5cf058cf')
build() {
- cd "$srcdir/$_pkgname-$pkgver"
- cd contrib
- cmake -DBUILD_TYPE=WILDMAGIC
- cmake -DBUILD_TYPE=SEQAN
- cd ..
- cmake -DBOOST_USE_STATIC=OFF -DINSTALL_PREFIX=/usr -DCMAKE_FIND_ROOT_PATH=/usr -DCMAKE_INSTALL_PREFIX=/usr
- make
+ cd "${srcdir}/"
+ rm -rf ${_pkgname}-${pkgver}-build
+ mkdir ${_pkgname}-${pkgver}-build
+ rm -rf contrib-build
+ mkdir contrib-build
+ cd contrib-build
+ cmake -DBUILD_TYPE=SEQAN $(realpath -P ../${_pkgname}-${pkgver}/contrib)
+ cmake -DBUILD_TYPE=LIBSVM $(realpath -P ../${_pkgname}-${pkgver}/contrib)
+ cmake -DBUILD_TYPE=COINOR $(realpath -P ../${_pkgname}-${pkgver}/contrib)
+ cmake -DBUILD_TYPE=KISSFFT $(realpath -P ../${_pkgname}-${pkgver}/contrib)
+ cmake -DBUILD_TYPE=WILDMAGIC $(realpath -P ../${_pkgname}-${pkgver}/contrib)
+ cd ../${_pkgname}-${pkgver}-build
+ cmake -DCMAKE_BUILD_TYPE=Release -DOPENMS_CONTRIB_LIBS=$(realpath -P ../contrib-build) -DCMAKE_INSTALL_PREFIX=$(realpath -P ${pkgdir}/usr) $(realpath -P ../${_pkgname}-${pkgver})
+ make OpenMS TOPP UTILS GUI
}
-
package() {
- cd "$srcdir/$_pkgname-$pkgver"
- make DESTDIR="$pkgdir/" install
- install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -D -m644 $srcdir/OpenMS-TOPPView.desktop ${pkgdir}/usr/share/applications/OpenMS-TOPPView.desktop
- install -D -m644 $srcdir/OpenMS-TOPPAS.desktop ${pkgdir}/usr/share/applications/OpenMS-TOPPAS.desktop
-} \ No newline at end of file
+ cd "${srcdir}/${_pkgname}-${pkgver}-build"
+ make DESTDIR=${pkgdir}/usr install
+ install -D -m644 ${srcdir}/${_pkgname}-${pkgver}/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 ${srcdir}/OpenMS-TOPPView.desktop ${pkgdir}/usr/share/applications/OpenMS-TOPPView.desktop
+ install -D -m644 ${srcdir}/OpenMS-TOPPAS.desktop ${pkgdir}/usr/share/applications/OpenMS-TOPPAS.desktop
+}