summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorreztho2015-06-13 23:22:59 +0100
committerreztho2015-06-14 00:17:19 +0100
commitd8db85d5f0cc66e7ec4e27f45a10fcfcb145bdc3 (patch)
tree822f73f2c30cfd715d5976bf592178fcedb2e3cd
downloadaur-d8db85d5f0cc66e7ec4e27f45a10fcfcb145bdc3.tar.gz
Initial commit
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD39
-rw-r--r--openmsx.install13
3 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..89a838b172de
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = openmsx
+ pkgdesc = The MSX emulator that aims for perfection.
+ pkgver = 0.11.0
+ pkgrel = 1
+ url = http://openmsx.sourceforge.net
+ install = openmsx.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = libxml2
+ depends = sdl
+ depends = sdl_image
+ depends = sdl_ttf
+ depends = tcl
+ depends = libpng
+ depends = zlib
+ optdepends = python2
+ optdepends = jack-audio-connection-kit
+ optdepends = glew
+ optdepends = libgl
+ optdepends = catalyst-utils
+ optdepends = nvidia-utils
+ optdepends = nvidia-304xx-utils
+ source = http://downloads.sourceforge.net/openmsx/openmsx-0.11.0.tar.gz
+ md5sums = b6f9c92f3921d9022b89b727c99897f0
+
+pkgname = openmsx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b567499a82f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Contributor: Tom < reztho at archlinux dot us >
+pkgname=openmsx
+pkgver=0.11.0
+pkgrel=1
+pkgdesc="The MSX emulator that aims for perfection."
+arch=('i686' 'x86_64')
+url="http://openmsx.sourceforge.net"
+license=('custom')
+depends=('libxml2' 'sdl' 'sdl_image' 'sdl_ttf' 'tcl' 'libpng' 'zlib')
+optdepends=('python2' 'jack-audio-connection-kit' 'glew' 'libgl' 'catalyst-utils' 'nvidia-utils' 'nvidia-304xx-utils')
+install=${pkgname}.install
+source=("http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ # Changing some default configurations...
+ sed -i 's@SYMLINK_FOR_BINARY:=true@SYMLINK_FOR_BINARY:=false@' build/custom.mk
+ sed -i 's@INSTALL_BASE:=/opt/openMSX@INSTALL_BASE:=/usr/share/openmsx@' build/custom.mk
+ echo 'INSTALL_DOC_DIR:=/usr/share/doc/openmsx' >> build/custom.mk
+ echo 'INSTALL_SHARE_DIR:=/usr/share/openmsx' >> build/custom.mk
+ echo 'INSTALL_BINARY_DIR:=/usr/bin' >> build/custom.mk
+
+ # Compiling
+ ./configure
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+
+ # Licenses
+ mkdir -p "${pkgdir}/usr/share/licenses/openmsx"
+ ln -s /usr/share/licenses/common/GPL2/license.txt "${pkgdir}/usr/share/licenses/openmsx/openmsx.txt"
+ install -m 644 "${pkgdir}/usr/share/doc/openmsx/cbios.txt" "${pkgdir}/usr/share/licenses/openmsx/"
+}
+
+md5sums=('b6f9c92f3921d9022b89b727c99897f0')
diff --git a/openmsx.install b/openmsx.install
new file mode 100644
index 000000000000..ddb879724183
--- /dev/null
+++ b/openmsx.install
@@ -0,0 +1,13 @@
+post_install() {
+ echo "==>> If you want to emulate real MSX systems and not only the free C-BIOS machines,"
+ echo "==>> put the system ROMs in one of the following directories: /usr/share/openmsx/systemroms"
+ echo "==>> or ~/.openMSX/share/systemroms"
+ echo "==>>"
+ echo "==>> If you want openMSX to find MSX software referred to from replays or savestates you get"
+ echo "==>> from your friends, copy that MSX software to /usr/share/openmsx/software or"
+ echo "==>> ~/.openMSX/share/software"
+}
+
+op=$1
+shift
+$op $*