summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWinston Wu2017-08-22 16:28:33 +0000
committerWinston Wu2017-08-22 16:28:33 +0000
commitf925e540b6e61eb5c902fe8bb4ded4960d3b4065 (patch)
treef77f5d2dd811c162159c9d7d12782c03394bbf47
downloadaur-f925e540b6e61eb5c902fe8bb4ded4960d3b4065.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD52
2 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..80f61e3920e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Tue Aug 22 16:28:20 UTC 2017
+pkgbase = openmsx-catapult-git
+ pkgdesc = Front-end for openMSX: the MSX emulator that aims for perfection.
+ pkgver = 925.74a847e
+ pkgrel = 1
+ url = http://openmsx.org
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = python2
+ depends = libxml2
+ depends = wxgtk
+ depends = zlib
+ depends = libjpeg
+ depends = libpng
+ depends = libtiff
+ depends = openmsx
+ provides = openmsx-catapult
+ conflicts = openmsx-catapult
+ source = git://github.com/openMSX/wxcatapult.git
+ md5sums = SKIP
+
+pkgname = openmsx-catapult-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3a9a332fa978
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Contributor: Tom < reztho at archlinux dot us >
+pkgname=openmsx-catapult-git
+pkgver=925.74a847e
+pkgrel=1
+pkgdesc="Front-end for openMSX: the MSX emulator that aims for perfection."
+arch=('i686' 'x86_64')
+url="http://openmsx.org"
+license=('GPL')
+depends=('libxml2' 'wxgtk' 'zlib' 'libjpeg' 'libpng' 'libtiff' "openmsx")
+makedepends=('python2')
+source=("git://github.com/openMSX/wxcatapult.git")
+provides=("openmsx-catapult")
+conflicts=("openmsx-catapult")
+
+pkgver() {
+ cd "${srcdir}/wxcatapult"
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/wxcatapult"
+
+ # Catapult requires python2
+ sed -i 's@=python@=python2@' build/main.mk
+
+ # Changing some default configurations...
+ sed -i 's@SYMLINK_FOR_BINARY:=true@SYMLINK_FOR_BINARY:=false@' build/custom.mk
+ sed -i 's@/opt/openMSX-Catapult@/usr/share/openmsx-catapult@' build/custom.mk
+ sed -i 's@/opt/openMSX/bin/openmsx@/usr/bin/openmsx@' build/custom.mk
+ sed -i 's@/opt/openMSX/share@/usr/share/openmsx@' build/custom.mk
+ echo 'INSTALL_DOC_DIR:=/usr/share/doc/openmsx-catapult' >> build/custom.mk
+ echo 'INSTALL_SHARE_DIR:=/usr/share/openmsx-catapult' >> build/custom.mk
+ echo 'INSTALL_BINARY_DIR:=/usr/bin' >> build/custom.mk
+
+ # Compiling
+ make
+}
+
+package() {
+ cd "${srcdir}/wxcatapult"
+
+ mkdir -p "${pkgdir}/usr/share/applications"
+ make DESTDIR="${pkgdir}" install
+
+ # Fixing the .desktop file
+ sed -i 's@/usr/share/openmsx-catapult/bin/catapult@/usr/bin/catapult@' \
+ "${pkgdir}/usr/share/applications/openMSX-Catapult.desktop"
+ sed -i 's@/usr/share/openmsx-catapult/doc/@/usr/share/doc/openmsx-catapult/@' \
+ "${pkgdir}/usr/share/applications/openMSX-Catapult.desktop"
+}
+
+md5sums=('SKIP')