summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Appelt2017-09-01 18:33:45 +0200
committerDaniel Appelt2017-09-01 18:33:45 +0200
commit795e48309ff79175ac2e95642a25fc95d0e70dd6 (patch)
tree4a9d738947009cd0d5ee380edd689f151a390d66
parent882444806e370505378a10ac75422343c7e3b8da (diff)
downloadaur-795e48309ff79175ac2e95642a25fc95d0e70dd6.tar.gz
Update to version 6.12
-rw-r--r--.SRCINFO21
-rw-r--r--.curlrc1
-rw-r--r--PKGBUILD37
3 files changed, 21 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e1a7c1fcd123..12ee2f71af47 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,22 @@
# Generated by mksrcinfo v8
-# Tue Feb 9 21:39:42 UTC 2016
+# Fri Sep 1 16:32:55 UTC 2017
pkgbase = openmusic
- pkgdesc = A visual programming language designed for music composition. (32 bit)
- pkgver = 6.10.1
- pkgrel = 2
+ pkgdesc = A visual programming language designed for music composition
+ pkgver = 6.12
+ pkgrel = 1
url = http://repmus.ircam.fr/openmusic/linux
install = openmusic.install
- arch = i686
arch = x86_64
license = GPL
+ depends = desktop-file-utils
+ depends = gdk-pixbuf2
+ depends = portmidi
+ depends = libsndfile
+ optdepends = jack: JACK audio support
+ optdepends = libsamplerate: speed up audio-waveform drawing
options = !strip
- source = .curlrc
- source = http://forge.ircam.fr/p/OM/downloads/get/OM_6.10.1-2.tar.bz2
- sha256sums = 21473828e9f743d216caf06dc13ec1dfc78d500e7e58d13414c682653388ea7e
- sha256sums = 94ac8332a609f2ad6ae94ac3f274f66d773b130afc43ca99de54c7ff4cb2e200
+ source = http://forge.ircam.fr/p/OM/downloads/get/OM_6.12.tar.bz2
+ sha256sums = a3b593210805e1c6ce3f47cd137c9f7fb6d93c35edb7f398b0088f247b79db45
pkgname = openmusic
diff --git a/.curlrc b/.curlrc
deleted file mode 100644
index a94e3f5eb4d8..000000000000
--- a/.curlrc
+++ /dev/null
@@ -1 +0,0 @@
---insecure
diff --git a/PKGBUILD b/PKGBUILD
index 87734fbab89f..490b9a770205 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,22 @@
# Maintainer: Daniel Appelt <daniel.appelt@gmail.com>
pkgname=openmusic
-pkgver=6.10.1
-pkgrel=2
-pkgdesc="A visual programming language designed for music composition. (32 bit)"
-arch=('i686' 'x86_64')
+pkgver=6.12
+pkgrel=1
+pkgdesc="A visual programming language designed for music composition"
+arch=('x86_64')
url="http://repmus.ircam.fr/openmusic/linux"
license=('GPL')
-case "$CARCH" in
-i686)
- depends=('desktop-file-utils' 'gdk-pixbuf2' 'jack' 'portmidi' 'libsndfile'
- 'libsdif')
- optdepends=('libsamplerate: speed up audio-waveform drawing')
- ;;
-x86_64)
- depends=('desktop-file-utils' 'lib32-gdk-pixbuf2>=2.31.3-2' 'lib32-jack'
- 'lib32-portmidi' 'lib32-libsndfile' 'lib32-libsdif')
- optdepends=('lib32-libsamplerate: speed up audio-waveform drawing')
- ;;
-esac
+depends=('desktop-file-utils' 'gdk-pixbuf2' 'portmidi' 'libsndfile')
+optdepends=('jack: JACK audio support'
+ 'libsamplerate: speed up audio-waveform drawing')
# Note that the openmusic executable may not be compressed/stripped.
# (http://www.lispworks.com/kb/a15fc2ea99b4f8f5802571fe0057705a.html)
options=(!strip)
install="$pkgname.install"
-# ircam.fr uses a self-signed SSL certificate which may lead to download problems.
-# The following environment variable, and source file .curlrc add option --insecure
-# to curl for the duration of this build process. By default, curl is configured as
-# download agent in makepkg.conf. If the download still does not work, check section
-# DLAGENTS in /etc/makepkgconf and add an option to allow insecure downloads to the
-# respective agent configuration.
-export CURL_HOME="$startdir"
-source=('.curlrc'
- "http://forge.ircam.fr/p/OM/downloads/get/OM_${pkgver}-${pkgrel}.tar.bz2")
-sha256sums=('21473828e9f743d216caf06dc13ec1dfc78d500e7e58d13414c682653388ea7e'
- '94ac8332a609f2ad6ae94ac3f274f66d773b130afc43ca99de54c7ff4cb2e200')
+source=("http://forge.ircam.fr/p/OM/downloads/get/OM_${pkgver}.tar.bz2")
+sha256sums=('a3b593210805e1c6ce3f47cd137c9f7fb6d93c35edb7f398b0088f247b79db45')
package() {
cd "$srcdir/OM_${pkgver}"
make DESTDIR="${pkgdir}" PREFIX=/usr install
}
-