summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2022-05-19 12:06:50 +0200
committerbartus2022-05-19 12:07:47 +0200
commit02ae7770b1c7f121e295b2a16d3c893e8a54a373 (patch)
treed272635d685d0066e5ec7f88a41537efed046726
parent2a9619a766debd02a38ad2a453fa67dfcec53da7 (diff)
downloadaur-02ae7770b1c7.tar.gz
Fix build against cereal>1.3.0
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
-rw-r--r--cereal_131.patch107
3 files changed, 118 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c21bc15c697e..02f3d8ef8a95 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = openmvg-git
pkgdesc = open Multiple View Geometry library. Basis for 3D computer vision and Structure from Motion.
- pkgver = 2.0.r7.g8f61623e
+ pkgver = 2.0.r32.gcbc5618b
pkgrel = 1
url = http://imagine.enpc.fr/~moulonp/openMVG/
arch = i686
@@ -37,13 +37,16 @@ pkgbase = openmvg-git
source = git+https://github.com/elmindreda/glfw.git
source = findflann-v0.1.patch
source = submodule.patch
+ source = cereal_131.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = 13b1f0195b5e97c17eec737e63f4da69c501bb4ced28c4c14517440009139043
sha256sums = 5dcde15464d0b457f0149fff2088f33e59f9c43a2aba9d2351538a0a5fce739d
+ sha256sums = db8b6f2b6b75c33d3559ff7fb0c4e2471c12790ac5443342ba3c940906eed439
b2sums = SKIP
b2sums = SKIP
b2sums = f70e6c4d3368d170d8c182511e1b2ee9aa76ff6495fee6f50fcfbcc432f2c330d4c84868a536df605e0c630b81d024ac0bdd48124d7ad1c4f8ff9114a1850854
b2sums = 688cd6f2ce02448bd75001c509b68f9265496abf0c6b00a46c373e3a6c337f5e24d4d6d3ce8cec3801fd823a076f1de68733edb0ae0283920aea16889c4299e1
+ b2sums = cd94990e9ef8d978df9c7275fa39c469043fa8b818ff9ed55425c01ccbb50a37feb54c3df09803f15fc86d1cdea2bd0559de467e9c9dc73fbff7b8b86f68f2f4
pkgname = openmvg-git
diff --git a/PKGBUILD b/PKGBUILD
index e8c1444cabc4..fd05af766067 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=openmvg-git
_gitname='openMVG'
_fragment="#branch=develop"
-pkgver=2.0.r7.g8f61623e
+pkgver=2.0.r32.gcbc5618b
pkgrel=1
pkgdesc='open Multiple View Geometry library. Basis for 3D computer vision and Structure from Motion.'
arch=('i686' 'x86_64')
@@ -18,15 +18,18 @@ source=("git+https://github.com/${_gitname}/${_gitname}.git${_fragment}"
'git+https://github.com/elmindreda/glfw.git'
'findflann-v0.1.patch'
'submodule.patch'
+ 'cereal_131.patch'
)
sha256sums=('SKIP'
'SKIP'
'13b1f0195b5e97c17eec737e63f4da69c501bb4ced28c4c14517440009139043'
- '5dcde15464d0b457f0149fff2088f33e59f9c43a2aba9d2351538a0a5fce739d')
+ '5dcde15464d0b457f0149fff2088f33e59f9c43a2aba9d2351538a0a5fce739d'
+ 'db8b6f2b6b75c33d3559ff7fb0c4e2471c12790ac5443342ba3c940906eed439')
b2sums=('SKIP'
'SKIP'
'f70e6c4d3368d170d8c182511e1b2ee9aa76ff6495fee6f50fcfbcc432f2c330d4c84868a536df605e0c630b81d024ac0bdd48124d7ad1c4f8ff9114a1850854'
- '688cd6f2ce02448bd75001c509b68f9265496abf0c6b00a46c373e3a6c337f5e24d4d6d3ce8cec3801fd823a076f1de68733edb0ae0283920aea16889c4299e1')
+ '688cd6f2ce02448bd75001c509b68f9265496abf0c6b00a46c373e3a6c337f5e24d4d6d3ce8cec3801fd823a076f1de68733edb0ae0283920aea16889c4299e1'
+ 'cd94990e9ef8d978df9c7275fa39c469043fa8b818ff9ed55425c01ccbb50a37feb54c3df09803f15fc86d1cdea2bd0559de467e9c9dc73fbff7b8b86f68f2f4')
pkgver() {
git -C "${srcdir}/${_gitname}" describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
@@ -36,7 +39,7 @@ prepare() {
cd "${srcdir}/${_gitname}"
git config 'submodule.src/dependencies/glfw.url' "${srcdir}/glfw"
git submodule update --init --remote src/dependencies/glfw
- git apply "${srcdir}"/{findflann-v0.1,submodule}.patch
+ git apply "${srcdir}"/{findflann-v0.1,submodule,cereal_131}.patch
}
build() {
diff --git a/cereal_131.patch b/cereal_131.patch
new file mode 100644
index 000000000000..8c2bd423165b
--- /dev/null
+++ b/cereal_131.patch
@@ -0,0 +1,107 @@
+From 99878b95235445cd02aee1d7669d9a60b91f6fc8 Mon Sep 17 00:00:00 2001
+From: bartus <szczepaniak.bartek+github@gmail.com>
+Date: Thu, 19 May 2022 11:42:53 +0200
+Subject: [PATCH] Fix build againt cereal>1.3.0
+
+As of careal=1.3.1 target requires component
+---
+ src/CMakeLists.txt | 6 ++++++
+ src/openMVG/cameras/CMakeLists.txt | 2 +-
+ src/openMVG/features/CMakeLists.txt | 2 +-
+ src/openMVG/geometry/CMakeLists.txt | 2 +-
+ src/openMVG/matching/CMakeLists.txt | 2 +-
+ src/openMVG/sfm/CMakeLists.txt | 2 +-
+ 6 files changed, 11 insertions(+), 5 deletions(-)
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 37b2aa6e..d799af77 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -248,6 +248,7 @@ ENDMACRO(UNIT_TEST)
+ # ==============================================================================
+ # - external by default
+ # - internal if cereal not found
++# - as of cereal:1.3.1 target requires component
+ # ==============================================================================
+ find_package(cereal QUIET CONFIG)
+ if (NOT cereal_FOUND)
+@@ -260,6 +261,11 @@ if (NOT cereal_FOUND)
+ install(TARGETS cereal EXPORT openMVG-targets)
+ set(OpenMVG_USE_INTERNAL_CEREAL ON)
+ endif()
++if (${cereal_VERSION} VERSION_GREATER 1.3.0)
++ set(cereal_TARGET "cereal::cereal")
++else()
++ set(cereal_TARGET "cereal")
++endif()
+
+ # ==============================================================================
+ # Eigen
+diff --git a/src/openMVG/cameras/CMakeLists.txt b/src/openMVG/cameras/CMakeLists.txt
+index 333ab729..5909e592 100644
+--- a/src/openMVG/cameras/CMakeLists.txt
++++ b/src/openMVG/cameras/CMakeLists.txt
+@@ -4,7 +4,7 @@ set_property(TARGET openMVG_camera APPEND PROPERTY
+ INTERFACE_INCLUDE_DIRECTORIES "$<INSTALL_INTERFACE:include>")
+
+ target_compile_features(openMVG_camera INTERFACE ${CXX11_FEATURES})
+-target_link_libraries(openMVG_camera INTERFACE openMVG_numeric cereal ${OPENMVG_LIBRARY_DEPENDENCIES})
++target_link_libraries(openMVG_camera INTERFACE openMVG_numeric ${cereal_TARGET} ${OPENMVG_LIBRARY_DEPENDENCIES})
+ install(TARGETS openMVG_camera DESTINATION lib EXPORT openMVG-targets)
+
+ UNIT_TEST(openMVG Camera_Pinhole openMVG_camera)
+diff --git a/src/openMVG/features/CMakeLists.txt b/src/openMVG/features/CMakeLists.txt
+index 2e49701d..96b1b30a 100644
+--- a/src/openMVG/features/CMakeLists.txt
++++ b/src/openMVG/features/CMakeLists.txt
+@@ -31,7 +31,7 @@ target_include_directories(openMVG_features
+ )
+ target_link_libraries(openMVG_features
+ PRIVATE openMVG_fast ${STLPLUS_LIBRARY}
+- PUBLIC ${OPENMVG_LIBRARY_DEPENDENCIES} cereal)
++ PUBLIC ${OPENMVG_LIBRARY_DEPENDENCIES} ${cereal_TARGET})
+ if (MSVC)
+ set_target_properties(openMVG_features PROPERTIES COMPILE_FLAGS "/bigobj")
+ target_compile_options(openMVG_features PUBLIC "-D_USE_MATH_DEFINES")
+diff --git a/src/openMVG/geometry/CMakeLists.txt b/src/openMVG/geometry/CMakeLists.txt
+index 0a6a016a..973978d1 100644
+--- a/src/openMVG/geometry/CMakeLists.txt
++++ b/src/openMVG/geometry/CMakeLists.txt
+@@ -21,7 +21,7 @@ set_property(TARGET openMVG_geometry PROPERTY FOLDER OpenMVG/OpenMVG)
+ target_link_libraries(openMVG_geometry
+ PUBLIC
+ openMVG_numeric
+- cereal
++ ${cereal_TARGET}
+ PRIVATE
+ openMVG_linearProgramming
+ )
+diff --git a/src/openMVG/matching/CMakeLists.txt b/src/openMVG/matching/CMakeLists.txt
+index 2e0eafd7..4600550b 100644
+--- a/src/openMVG/matching/CMakeLists.txt
++++ b/src/openMVG/matching/CMakeLists.txt
+@@ -35,7 +35,7 @@ target_link_libraries(openMVG_matching
+ PUBLIC
+ openMVG_features
+ Threads::Threads
+- cereal
++ ${cereal_TARGET}
+ )
+ if (NOT DEFINED OpenMVG_USE_INTERNAL_FLANN)
+ target_link_libraries(openMVG_matching
+diff --git a/src/openMVG/sfm/CMakeLists.txt b/src/openMVG/sfm/CMakeLists.txt
+index b8928083..7aabc136 100644
+--- a/src/openMVG/sfm/CMakeLists.txt
++++ b/src/openMVG/sfm/CMakeLists.txt
+@@ -25,7 +25,7 @@ target_link_libraries(openMVG_sfm
+ openMVG_graph
+ openMVG_matching
+ openMVG_multiview
+- cereal
++ ${cereal_TARGET}
+ ${OPENMVG_LIBRARY_DEPENDENCIES}
+ )
+
+--
+2.35.1
+