summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2021-07-01 12:10:09 +0200
committerbartus2021-07-01 12:10:52 +0200
commit044360953c1dad0325e8b90108f57fe286bfbb5e (patch)
treed967b23332bf9af521e09f59cb2c1400b77eaeac
parent751b16099ed40637d00a64e1262aed427e17d3a9 (diff)
downloadaur-044360953c1dad0325e8b90108f57fe286bfbb5e.tar.gz
Drop cereal osi_cpl submodule
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
-rw-r--r--submodule.patch20
3 files changed, 34 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4655704add50..51787ecfcca7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,6 +10,9 @@ pkgbase = openmvg-git
makedepends = cmake
makedepends = doxygen
makedepends = eigen
+ depends = qt5-base
+ depends = qt5-svg
+ depends = cereal
depends = glfw
depends = lz4
depends = libpng
@@ -32,21 +35,18 @@ pkgbase = openmvg-git
options = !emptydirs
source = git+https://github.com/openMVG/openMVG.git#branch=develop
source = git+https://github.com/elmindreda/glfw.git
- source = git+https://github.com/openMVG-thirdparty/osi_clp.git
- source = git+https://github.com/openMVG-thirdparty/cereal.git
source = findflann-v0.1.patch
source = ld_ceres.patch::https://github.com/openMVG/openMVG/pull/1831.patch
- sha256sums = SKIP
- sha256sums = SKIP
+ source = submodule.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = 13b1f0195b5e97c17eec737e63f4da69c501bb4ced28c4c14517440009139043
sha256sums = 53e5211b55af6f1feabff8962c174227a68e7129f97c4624c05fe1cbca428f43
- b2sums = SKIP
- b2sums = SKIP
+ sha256sums = 5dcde15464d0b457f0149fff2088f33e59f9c43a2aba9d2351538a0a5fce739d
b2sums = SKIP
b2sums = SKIP
b2sums = f70e6c4d3368d170d8c182511e1b2ee9aa76ff6495fee6f50fcfbcc432f2c330d4c84868a536df605e0c630b81d024ac0bdd48124d7ad1c4f8ff9114a1850854
b2sums = 1ce09655750be003ea029be943e8382b0ca9512263bddd28b3536a73e18e071ea4d12de250a75c412649f129b58edbdc6c17302b760173cf338c194ad4b78251
+ b2sums = 688cd6f2ce02448bd75001c509b68f9265496abf0c6b00a46c373e3a6c337f5e24d4d6d3ce8cec3801fd823a076f1de68733edb0ae0283920aea16889c4299e1
pkgname = openmvg-git
diff --git a/PKGBUILD b/PKGBUILD
index b6ef60f8ad2c..ee5e6d79eb9e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,27 +12,24 @@ arch=('i686' 'x86_64')
url='http://imagine.enpc.fr/~moulonp/openMVG/'
license=('MPL')
options=('!emptydirs')
-depends=('glfw' 'lz4' 'libpng' 'libjpeg' 'libtiff' 'libxcursor' 'libxinerama' 'libxrandr' 'libxxf86vm' 'libxi' 'graphviz' 'libgl' 'ceres-solver' 'gflags' 'flann' 'coin-or-coinutils' 'coin-or-clp' 'coin-or-osi' 'coin-or-lemon')
+depends=(qt5-{base,svg} 'cereal' 'glfw' 'lz4' 'libpng' 'libjpeg' 'libtiff' 'libxcursor' 'libxinerama' 'libxrandr' 'libxxf86vm' 'libxi' 'graphviz' 'libgl' 'ceres-solver' 'gflags' 'flann' 'coin-or-coinutils' 'coin-or-clp' 'coin-or-osi' 'coin-or-lemon')
makedepends=('git' 'cmake' 'doxygen' 'eigen')
source=("git+https://github.com/${_gitname}/${_gitname}.git${_fragment}"
'git+https://github.com/elmindreda/glfw.git'
- 'git+https://github.com/openMVG-thirdparty/osi_clp.git'
- 'git+https://github.com/openMVG-thirdparty/cereal.git'
'findflann-v0.1.patch'
'ld_ceres.patch::https://github.com/openMVG/openMVG/pull/1831.patch'
+ 'submodule.patch'
)
sha256sums=('SKIP'
'SKIP'
- 'SKIP'
- 'SKIP'
'13b1f0195b5e97c17eec737e63f4da69c501bb4ced28c4c14517440009139043'
- '53e5211b55af6f1feabff8962c174227a68e7129f97c4624c05fe1cbca428f43')
+ '53e5211b55af6f1feabff8962c174227a68e7129f97c4624c05fe1cbca428f43'
+ '5dcde15464d0b457f0149fff2088f33e59f9c43a2aba9d2351538a0a5fce739d')
b2sums=('SKIP'
'SKIP'
- 'SKIP'
- 'SKIP'
'f70e6c4d3368d170d8c182511e1b2ee9aa76ff6495fee6f50fcfbcc432f2c330d4c84868a536df605e0c630b81d024ac0bdd48124d7ad1c4f8ff9114a1850854'
- '1ce09655750be003ea029be943e8382b0ca9512263bddd28b3536a73e18e071ea4d12de250a75c412649f129b58edbdc6c17302b760173cf338c194ad4b78251')
+ '1ce09655750be003ea029be943e8382b0ca9512263bddd28b3536a73e18e071ea4d12de250a75c412649f129b58edbdc6c17302b760173cf338c194ad4b78251'
+ '688cd6f2ce02448bd75001c509b68f9265496abf0c6b00a46c373e3a6c337f5e24d4d6d3ce8cec3801fd823a076f1de68733edb0ae0283920aea16889c4299e1')
pkgver() {
cd "${srcdir}/${_gitname}"
@@ -42,10 +39,8 @@ pkgver() {
prepare() {
cd "${srcdir}/${_gitname}"
git config 'submodule.src/dependencies/glfw.url' "${srcdir}/glfw"
- git config 'submodule.src/dependencies/osi_clp.url' "${srcdir}/osi_clp"
- git config 'submodule.src/dependencies/cereal.url' "${srcdir}/cereal"
- git submodule update --init --remote
- git apply ${srcdir}/{findflann-v0.1,ld_ceres}.patch
+ git submodule update --init --remote src/dependencies/glfw
+ git apply "${srcdir}"/{findflann-v0.1,ld_ceres,submodule}.patch
}
build() {
diff --git a/submodule.patch b/submodule.patch
new file mode 100644
index 000000000000..47ab9b92bd26
--- /dev/null
+++ b/submodule.patch
@@ -0,0 +1,20 @@
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index b12eb5ad..592084f8 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -90,15 +90,6 @@ if (CMAKE_CXX_COMPILER_ID MATCHES "Clang")
+ register_definitions(-DOPENMVG_STD_UNORDERED_MAP)
+ endif()
+
+-# ==============================================================================
+-# Check that submodule have been initialized and updated
+-# ==============================================================================
+-if (NOT EXISTS ${PROJECT_SOURCE_DIR}/dependencies/cereal/include)
+- message(FATAL_ERROR
+- "\n submodule(s) are missing, please update your repository:\n"
+- " > git submodule update -i\n")
+-endif()
+-
+ # ==============================================================================
+ # Additional cmake find modules
+ # ==============================================================================