summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Brooks2016-05-01 00:26:37 -0400
committerKyle Brooks2016-05-01 00:33:00 -0400
commit36fe62f55e87588d480246b91cf7f8e48ed83ee0 (patch)
tree24d5bf6a0ff383501216be27db4778d72e297a1e
downloadaur-36fe62f55e87588d480246b91cf7f8e48ed83ee0.tar.gz
Initial commit.
-rw-r--r--.SRCINFO38
-rw-r--r--PKGBUILD53
-rw-r--r--libopenMVG_sfm_link_error.patch12
3 files changed, 103 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..91674a949454
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,38 @@
+pkgbase = openmvg-git
+ pkgdesc = open Multiple View Geometry library. Basis for 3D computer vision and Structure from Motion.
+ pkgver = 1.0.r0.g944254c
+ pkgrel = 3
+ url = http://imagine.enpc.fr/~moulonp/openMVG/
+ arch = i686
+ arch = x86_64
+ license = MPL
+ makedepends = git
+ makedepends = cmake
+ makedepends = doxygen
+ depends = libpng
+ depends = libjpeg
+ depends = libtiff
+ depends = libxrandr
+ depends = libxxf86vm
+ depends = libxi
+ depends = graphviz
+ depends = libgl
+ depends = ceres-solver
+ depends = flann
+ depends = coin-or-coinutils
+ depends = coin-or-clp
+ depends = coin-or-osi
+ depends = coin-or-lemon
+ source = git+https://github.com/openMVG/openMVG.git
+ source = git+https://github.com/elmindreda/glfw.git
+ source = git+https://github.com/openMVG-thirdparty/osi_clp.git
+ source = git+https://github.com/openMVG-thirdparty/cereal.git
+ source = libopenMVG_sfm_link_error.patch
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = 8e1dd6742b2ed87b1086829e75d69cee
+
+pkgname = openmvg-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7fa2b257182b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Kyle Brooks <brookskd@gmail.com>
+pkgname=openmvg-git
+pkgver=1.0.r0.g944254c
+pkgrel=3
+pkgdesc='open Multiple View Geometry library. Basis for 3D computer vision and Structure from Motion.'
+arch=('i686' 'x86_64')
+url='http://imagine.enpc.fr/~moulonp/openMVG/'
+license=('MPL')
+depends=('libpng' 'libjpeg' 'libtiff' 'libxrandr' 'libxxf86vm' 'libxi' 'graphviz' 'libgl' 'ceres-solver' 'flann' 'coin-or-coinutils' 'coin-or-clp' 'coin-or-osi' 'coin-or-lemon')
+makedepends=('git' 'cmake' 'doxygen')
+_gitname='openMVG'
+source=("git+https://github.com/openMVG/${_gitname}.git"
+ 'git+https://github.com/elmindreda/glfw.git'
+ 'git+https://github.com/openMVG-thirdparty/osi_clp.git'
+ 'git+https://github.com/openMVG-thirdparty/cereal.git'
+ 'libopenMVG_sfm_link_error.patch'
+ )
+md5sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ '8e1dd6742b2ed87b1086829e75d69cee'
+ )
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${srcdir}/${_gitname}"
+ git submodule init
+ git config 'submodule.src/dependencies/glfw.url' "${srcdir}/glfw"
+ git config 'submodule.src/dependencies/osi_clp.url' "${srcdir}/osi_clp"
+ git config 'submodule.src/dependencies/cereal.url' "${srcdir}/cereal"
+ git submodule update
+ git apply ../libopenMVG_sfm_link_error.patch
+}
+
+build() {
+ cd "${srcdir}"
+ mkdir -p openmvg_build
+ cd openmvg_build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=RELEASE -DOpenMVG_BUILD_SHARED=ON -DOpenMVG_BUILD_EXAMPLES=ON -DOpenMVG_BUILD_DOC=ON -DOpenMVG_BUILD_OPENGL_EXAMPLES=ON -DOpenMVG_USE_OPENMP=ON -DFLANN_INCLUDE_DIR_HINTS=/usr/include -DCOINUTILS_INCLUDE_DIR_HINTS=/usr/include/coin -DCLP_INCLUDE_DIR_HINTS=/usr/include/coin -DOSI_INCLUDE_DIR_HINTS=/usr/include/coin -DLEMON_INCLUDE_DIR_HINTS=/usr/include ../openMVG/src/
+ make
+}
+
+package() {
+ cd "${srcdir}/openmvg_build"
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/libopenMVG_sfm_link_error.patch b/libopenMVG_sfm_link_error.patch
new file mode 100644
index 000000000000..16a3533393f6
--- /dev/null
+++ b/libopenMVG_sfm_link_error.patch
@@ -0,0 +1,12 @@
+diff --git a/src/openMVG/sfm/CMakeLists.txt b/src/openMVG/sfm/CMakeLists.txt
+index 8b02153..e91c80a 100644
+--- a/src/openMVG/sfm/CMakeLists.txt
++++ b/src/openMVG/sfm/CMakeLists.txt
+@@ -25,6 +25,7 @@ target_link_libraries(
+ openMVG_lInftyComputerVision
+ openMVG_system
+ openMVG_matching
++ openMVG_features
+ )
+ set_target_properties(openMVG_sfm PROPERTIES SOVERSION ${OPENMVG_VERSION_MAJOR} VERSION "${OPENMVG_VERSION_MAJOR}.${OPENMVG_VERSION_MINOR}")
+