summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2018-07-15 14:42:18 +0200
committerbartus2018-07-15 14:42:18 +0200
commit8691aa83920adcb0402c0d21172068a9a2c7389c (patch)
treef190abfdd9a8923866ea526d00a546bbfeaa43a2
parent2e7da5112739d5629ad61d7f66ab368d6bc4dba7 (diff)
downloadaur-8691aa83920adcb0402c0d21172068a9a2c7389c.tar.gz
remove upstream included paches
fix stlplus library linking target in VO and SfMViewer
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
-rw-r--r--evalquality.patch12
-rw-r--r--lemon.patch13
-rw-r--r--stlplus.patch25
5 files changed, 34 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 90259ba5bb78..fd5b3192b6fd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = openmvg-git
pkgdesc = open Multiple View Geometry library. Basis for 3D computer vision and Structure from Motion.
- pkgver = 1.3.r91.g4c7367cd
+ pkgver = 1.3.r115.g903b2f44
pkgrel = 1
url = http://imagine.enpc.fr/~moulonp/openMVG/
arch = i686
@@ -31,16 +31,14 @@ pkgbase = openmvg-git
source = git+https://github.com/elmindreda/glfw.git
source = git+https://github.com/openMVG-thirdparty/osi_clp.git
source = git+https://github.com/openMVG-thirdparty/cereal.git
- source = lemon.patch
source = findflann-v0.1.patch
- source = evalquality.patch
+ source = stlplus.patch
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
- md5sums = 11aa728e50e52b10d79dd83dfaa6c1c6
md5sums = f421cb25208a4f95784035d9823abe04
- md5sums = e3ffb7463245b92fdee08045715640ab
+ md5sums = 45325ddb7a710f79e619ba2085697833
pkgname = openmvg-git
diff --git a/PKGBUILD b/PKGBUILD
index 7c968e6edfae..d279d5ed6ef9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=openmvg-git
_gitname='openMVG'
_fragment="#branch=develop"
-pkgver=1.3.r91.g4c7367cd
+pkgver=1.3.r115.g903b2f44
pkgrel=1
pkgdesc='open Multiple View Geometry library. Basis for 3D computer vision and Structure from Motion.'
arch=('i686' 'x86_64')
@@ -16,17 +16,15 @@ source=("git+https://github.com/${_gitname}/${_gitname}.git${_fragment}"
'git+https://github.com/elmindreda/glfw.git'
'git+https://github.com/openMVG-thirdparty/osi_clp.git'
'git+https://github.com/openMVG-thirdparty/cereal.git'
- 'lemon.patch'
'findflann-v0.1.patch'
- 'evalquality.patch'
+ 'stlplus.patch'
)
md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- '11aa728e50e52b10d79dd83dfaa6c1c6'
'f421cb25208a4f95784035d9823abe04'
- 'e3ffb7463245b92fdee08045715640ab')
+ '45325ddb7a710f79e619ba2085697833')
pkgver() {
cd "${srcdir}/${_gitname}"
@@ -40,9 +38,10 @@ prepare() {
git config 'submodule.src/dependencies/osi_clp.url' "${srcdir}/osi_clp"
git config 'submodule.src/dependencies/cereal.url' "${srcdir}/cereal"
git submodule update
- git apply ${srcdir}/lemon.patch
+ msg "flann patch"
git apply ${srcdir}/findflann-v0.1.patch
- git apply ${srcdir}/evalquality.patch
+ msg "fix link target missing stlplus library"
+ git apply ${srcdir}/stlplus.patch
}
build() {
diff --git a/evalquality.patch b/evalquality.patch
deleted file mode 100644
index f958cf1e732e..000000000000
--- a/evalquality.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/src/software/SfM/CMakeLists.txt b/src/software/SfM/CMakeLists.txt
-index cc103147..68b040d4 100644
---- a/src/software/SfM/CMakeLists.txt
-+++ b/src/software/SfM/CMakeLists.txt
-@@ -241,6 +241,7 @@ endif(OpenMVG_USE_OPENCV)
- ###
- add_executable(openMVG_main_evalQuality main_evalQuality.cpp)
- target_link_libraries(openMVG_main_evalQuality
-+ openMVG_image
- openMVG_system
- openMVG_features
- openMVG_sfm
diff --git a/lemon.patch b/lemon.patch
deleted file mode 100644
index 3336e3fef660..000000000000
--- a/lemon.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/software/colorHarmonize/CMakeLists.txt b/src/software/colorHarmonize/CMakeLists.txt
-index ceddd98c..10997693 100644
---- a/src/software/colorHarmonize/CMakeLists.txt
-+++ b/src/software/colorHarmonize/CMakeLists.txt
-@@ -2,7 +2,7 @@
- add_executable(openMVG_main_ColHarmonize main_ColHarmonize.cpp
- colorHarmonizeEngineGlobal.cpp)
- target_link_libraries(openMVG_main_ColHarmonize
-- lemon
-+ emon
- openMVG_features
- openMVG_image
- openMVG_kvld
diff --git a/stlplus.patch b/stlplus.patch
new file mode 100644
index 000000000000..18e071dddd21
--- /dev/null
+++ b/stlplus.patch
@@ -0,0 +1,25 @@
+diff --git a/src/software/VO/CMakeLists.txt b/src/software/VO/CMakeLists.txt
+index ab3c5404..2f0ca771 100644
+--- a/src/software/VO/CMakeLists.txt
++++ b/src/software/VO/CMakeLists.txt
+@@ -39,6 +39,8 @@ if (OpenMVG_BUILD_OPENGL_EXAMPLES)
+ glfw
+ ${GLFW_LIBRARIES}
+ openMVG_sfm
++ ${STLPLUS_LIBRARY}
++ openMVG_image
+ )
+
+ if(OpenMVG_USE_OPENCV)
+diff --git a/src/software/SfMViewer/CMakeLists.txt b/src/software/SfMViewer/CMakeLists.txt
+index 1506e986..4df1a8e6 100644
+--- a/src/software/SfMViewer/CMakeLists.txt
++++ b/src/software/SfMViewer/CMakeLists.txt
+@@ -36,6 +36,7 @@ target_link_libraries(openMVG_main_sfmViewer
+ openMVG_features
+ openMVG_multiview
+ openMVG_sfm
++ ${STLPLUS_LIBRARY}
+ ${OPENGL_gl_LIBRARY}
+ glfw
+ ${GLFW_LIBRARIES})