summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2020-01-05 15:50:56 +0100
committerbartus2020-01-05 15:50:56 +0100
commit886b15aee4a09c8de18499067e4616672b183084 (patch)
tree41d57e9137765477142a74828c21a252bcb23e95
parentd897f176cc29ab1b07d98dbda6c9fc1fb27e542d (diff)
downloadaur-886b15aee4a09c8de18499067e4616672b183084.tar.gz
Fix gcc9.2 issue (https://github.com/openMVG/openMVG/issues/1666)
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD17
-rw-r--r--gcc92.patch12
3 files changed, 30 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2cf55c52a632..b28bcc16b438 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = openmvg-git
pkgdesc = open Multiple View Geometry library. Basis for 3D computer vision and Structure from Motion.
- pkgver = 1.4.r55.g06a7b466
+ pkgver = 1.5.r56.gbe94d6af
pkgrel = 1
url = http://imagine.enpc.fr/~moulonp/openMVG/
arch = i686
@@ -31,11 +31,13 @@ pkgbase = openmvg-git
source = git+https://github.com/openMVG-thirdparty/osi_clp.git
source = git+https://github.com/openMVG-thirdparty/cereal.git
source = findflann-v0.1.patch
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = f421cb25208a4f95784035d9823abe04
+ source = gcc92.patch
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = 13b1f0195b5e97c17eec737e63f4da69c501bb4ced28c4c14517440009139043
+ sha256sums = 212589acc8a657b1096d15da9a96518b91181d9f53a1c5a7735846e964629c8c
pkgname = openmvg-git
diff --git a/PKGBUILD b/PKGBUILD
index 724fd83933c1..806308ecee0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=openmvg-git
_gitname='openMVG'
_fragment="#branch=develop"
-pkgver=1.4.r55.g06a7b466
+pkgver=1.5.r56.gbe94d6af
pkgrel=1
pkgdesc='open Multiple View Geometry library. Basis for 3D computer vision and Structure from Motion.'
arch=('i686' 'x86_64')
@@ -18,13 +18,14 @@ source=("git+https://github.com/${_gitname}/${_gitname}.git${_fragment}"
'git+https://github.com/openMVG-thirdparty/osi_clp.git'
'git+https://github.com/openMVG-thirdparty/cereal.git'
'findflann-v0.1.patch'
+ 'gcc92.patch'
)
-md5sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'f421cb25208a4f95784035d9823abe04'
- )
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ '13b1f0195b5e97c17eec737e63f4da69c501bb4ced28c4c14517440009139043'
+ '212589acc8a657b1096d15da9a96518b91181d9f53a1c5a7735846e964629c8c')
pkgver() {
cd "${srcdir}/${_gitname}"
@@ -40,6 +41,8 @@ prepare() {
git submodule update
msg "flann patch"
git apply ${srcdir}/findflann-v0.1.patch
+ msg "gcc:9.2 patch"
+ git apply ${srcdir}/gcc92.patch
}
build() {
diff --git a/gcc92.patch b/gcc92.patch
new file mode 100644
index 000000000000..6bc64246fe33
--- /dev/null
+++ b/gcc92.patch
@@ -0,0 +1,12 @@
+diff --git a/src/software/VO/Monocular_VO.hpp b/src/software/VO/Monocular_VO.hpp
+index c68d91a6..53448883 100644
+--- a/src/software/VO/Monocular_VO.hpp
++++ b/src/software/VO/Monocular_VO.hpp
+@@ -20,6 +20,7 @@
+ #include "openMVG/sfm/sfm_landmark.hpp"
+
+ #include "software/VO/Abstract_Tracker.hpp"
++#include <iostream>
+
+ namespace openMVG {
+ namespace VO {