summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2018-07-17 09:39:19 +0200
committerbartus2018-07-17 09:39:19 +0200
commitbc0209f9e91fb58b5ac6ec0ce387db101ca21853 (patch)
tree75a06180b5093aed576f218fbb12447c01110356
parent8691aa83920adcb0402c0d21172068a9a2c7389c (diff)
downloadaur-bc0209f9e91fb58b5ac6ec0ce387db101ca21853.tar.gz
remove upstream marged patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
-rw-r--r--stlplus.patch25
3 files changed, 3 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd5b3192b6fd..f2640d905a58 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = openmvg-git
pkgdesc = open Multiple View Geometry library. Basis for 3D computer vision and Structure from Motion.
- pkgver = 1.3.r115.g903b2f44
+ pkgver = 1.3.r118.gd1de7887
pkgrel = 1
url = http://imagine.enpc.fr/~moulonp/openMVG/
arch = i686
@@ -32,13 +32,11 @@ pkgbase = openmvg-git
source = git+https://github.com/openMVG-thirdparty/osi_clp.git
source = git+https://github.com/openMVG-thirdparty/cereal.git
source = findflann-v0.1.patch
- source = stlplus.patch
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = f421cb25208a4f95784035d9823abe04
- md5sums = 45325ddb7a710f79e619ba2085697833
pkgname = openmvg-git
diff --git a/PKGBUILD b/PKGBUILD
index d279d5ed6ef9..9543dd3020c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=openmvg-git
_gitname='openMVG'
_fragment="#branch=develop"
-pkgver=1.3.r115.g903b2f44
+pkgver=1.3.r118.gd1de7887
pkgrel=1
pkgdesc='open Multiple View Geometry library. Basis for 3D computer vision and Structure from Motion.'
arch=('i686' 'x86_64')
@@ -17,14 +17,13 @@ source=("git+https://github.com/${_gitname}/${_gitname}.git${_fragment}"
'git+https://github.com/openMVG-thirdparty/osi_clp.git'
'git+https://github.com/openMVG-thirdparty/cereal.git'
'findflann-v0.1.patch'
- 'stlplus.patch'
)
md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
'f421cb25208a4f95784035d9823abe04'
- '45325ddb7a710f79e619ba2085697833')
+ )
pkgver() {
cd "${srcdir}/${_gitname}"
@@ -40,8 +39,6 @@ prepare() {
git submodule update
msg "flann patch"
git apply ${srcdir}/findflann-v0.1.patch
- msg "fix link target missing stlplus library"
- git apply ${srcdir}/stlplus.patch
}
build() {
diff --git a/stlplus.patch b/stlplus.patch
deleted file mode 100644
index 18e071dddd21..000000000000
--- a/stlplus.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-diff --git a/src/software/VO/CMakeLists.txt b/src/software/VO/CMakeLists.txt
-index ab3c5404..2f0ca771 100644
---- a/src/software/VO/CMakeLists.txt
-+++ b/src/software/VO/CMakeLists.txt
-@@ -39,6 +39,8 @@ if (OpenMVG_BUILD_OPENGL_EXAMPLES)
- glfw
- ${GLFW_LIBRARIES}
- openMVG_sfm
-+ ${STLPLUS_LIBRARY}
-+ openMVG_image
- )
-
- if(OpenMVG_USE_OPENCV)
-diff --git a/src/software/SfMViewer/CMakeLists.txt b/src/software/SfMViewer/CMakeLists.txt
-index 1506e986..4df1a8e6 100644
---- a/src/software/SfMViewer/CMakeLists.txt
-+++ b/src/software/SfMViewer/CMakeLists.txt
-@@ -36,6 +36,7 @@ target_link_libraries(openMVG_main_sfmViewer
- openMVG_features
- openMVG_multiview
- openMVG_sfm
-+ ${STLPLUS_LIBRARY}
- ${OPENGL_gl_LIBRARY}
- glfw
- ${GLFW_LIBRARIES})