summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2018-12-21 20:06:18 +0100
committerbartus2018-12-21 20:06:18 +0100
commit722baa63bf03edae37d9907cbd552902f66a6931 (patch)
tree2b5bef38f8eca8a3b998e8e96d785c7971c9db8e
parent38837e6b79d481372449fe6e64ee4cca09a529a9 (diff)
downloadaur-722baa63bf03edae37d9907cbd552902f66a6931.tar.gz
remove upstream applied patch (cgal)
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
-rw-r--r--cgal.patch44
3 files changed, 8 insertions, 56 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b400dd391d77..49627894be64 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openmvs-git
pkgdesc = open Multi-View Stereo reconstruction library with simple and automatic set of tools
- pkgver = 0.7.r47.g063e5cd
- pkgrel = 2
+ pkgver = 0.7.r65.gd19dae8
+ pkgrel = 1
url = http://cdcseacave.github.io/openMVS
arch = i686
arch = x86_64
@@ -25,10 +25,8 @@ pkgbase = openmvs-git
optdepends = nvidia-utils: GPU optimized mesh reconstruction code
source = openmvs-git::git+https://github.com/cdcseacave/openMVS.git
source = vcglib::git+https://github.com/cdcseacave/VCG.git
- source = cgal.patch
md5sums = SKIP
md5sums = SKIP
- md5sums = 39aa2f1e8cb22bd52a3129539596e495
pkgname = openmvs-git
diff --git a/PKGBUILD b/PKGBUILD
index 36bd64ff2b5a..6661fa22f3f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer : bartus <arch-user-repoᘓbartus.33mail.com>
pkgname=openmvs-git
-pkgver=0.7.r47.g063e5cd
-pkgrel=2
+pkgver=0.7.r65.gd19dae8
+pkgrel=1
pkgdesc="open Multi-View Stereo reconstruction library with simple and automatic set of tools"
arch=('i686' 'x86_64')
url="http://cdcseacave.github.io/openMVS"
@@ -14,11 +14,10 @@ optdepends=('nvidia-utils: GPU optimized mesh reconstruction code'
options=()
source=("${pkgname}::git+https://github.com/cdcseacave/openMVS.git"
"vcglib::git+https://github.com/cdcseacave/VCG.git"
- "cgal.patch"
)
md5sums=('SKIP'
'SKIP'
- '39aa2f1e8cb22bd52a3129539596e495')
+ )
pkgver() {
cd "$pkgname"
@@ -27,10 +26,9 @@ pkgver() {
}
-prepare() {
- cd ${srcdir}/${pkgname}
- git apply -v ${srcdir}/cgal.patch
-}
+#prepare() {
+# cd ${srcdir}/${pkgname}
+#}
build() {
diff --git a/cgal.patch b/cgal.patch
deleted file mode 100644
index 87a28275edb8..000000000000
--- a/cgal.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-diff --git a/build/Modules/FindCGAL.cmake b/build/Modules/FindCGAL.cmake
-index b3895e0..ae45c21 100644
---- a/build/Modules/FindCGAL.cmake
-+++ b/build/Modules/FindCGAL.cmake
-@@ -35,7 +35,7 @@ if(NOT CGAL_DIR)
- ${CGAL_DIR_SEARCH}
-
- # Look in standard UNIX install locations.
-- "/usr" "/usr/local" "/usr/lib" "/usr/lib/x86_64-linux-gnu/cmake"
-+ "/usr" "/usr/local" "/usr/lib" "/usr/lib/cmake" "/usr/lib/x86_64-linux-gnu/cmake"
-
- # Read from the CMakeSetup registry entries. It is likely that
- # CGAL will have been recently built.
-diff --git a/libs/MVS/SceneReconstruct.cpp b/libs/MVS/SceneReconstruct.cpp
-index 49e2f4f..e7959d5 100644
---- a/libs/MVS/SceneReconstruct.cpp
-+++ b/libs/MVS/SceneReconstruct.cpp
-@@ -42,6 +42,10 @@
- #include <CGAL/AABB_triangle_primitive.h>
- #include <CGAL/Polyhedron_3.h>
-
-+#if CGAL_VERSION_NR >= 1041301000
-+ #include <CGAL/Delaunay_triangulation_cell_base_3.h>
-+#endif
-+
- using namespace MVS;
-
-
-@@ -267,7 +271,14 @@ struct cell_info_t {
- };
-
- typedef CGAL::Triangulation_vertex_base_with_info_3<vert_info_t, kernel_t> vertex_base_t;
--typedef CGAL::Triangulation_cell_base_with_info_3<cell_size_t, kernel_t> cell_base_t;
-+
-+#if CGAL_VERSION_NR < 1041301000
-+ typedef CGAL::Triangulation_cell_base_with_info_3<cell_size_t, kernel_t> cell_base_t;
-+#else
-+ typedef CGAL::Delaunay_triangulation_cell_base_3<kernel_t> triangulation_cell_t;
-+ typedef CGAL::Triangulation_cell_base_with_info_3<cell_size_t, kernel_t, triangulation_cell_t> cell_base_t;
-+#endif
-+
- typedef CGAL::Triangulation_data_structure_3<vertex_base_t, cell_base_t> triangulation_data_structure_t;
- typedef CGAL::Delaunay_triangulation_3<kernel_t, triangulation_data_structure_t, CGAL::Compact_location> delaunay_t;
- typedef delaunay_t::Vertex_handle vertex_handle_t;