summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGoodevil952017-09-10 02:36:43 +0300
committerGoodevil952017-09-10 02:36:43 +0300
commitf8aa073790e863a23f6332623c83f9847fe11085 (patch)
tree9f5a4d7bb9d8a928ceb5767053086b2796f5aa8b
downloadaur-f8aa073790e863a23f6332623c83f9847fe11085.tar.gz
Initial import
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD29
-rw-r--r--tes3mp-client.desktop11
-rw-r--r--tes3mp-server-browser.desktop11
-rw-r--r--tes3mp-server.desktop11
5 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..462cb93ab7bc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+# Generated by mksrcinfo v8
+# Sat Sep 9 23:24:01 UTC 2017
+pkgbase = openmw-tes3mp
+ pkgdesc = TES3MP is a project aiming to add multiplayer functionality to OpenMW, a free and open source recreation of the popular Bethesda Softworks game "The Elder Scrolls III: Morrowind".
+ pkgver = 0.6.1
+ pkgrel = 1
+ url = https://github.com/TES3MP/openmw-tes3mp
+ arch = x86_64
+ license = GPL3
+ license = custom
+ depends = openal
+ depends = openscenegraph
+ depends = mygui>=3.2.1
+ depends = bullet
+ depends = qt5-base
+ depends = ffmpeg
+ depends = sdl2
+ depends = unshield
+ depends = libxt
+ provides = openmw-tes3mp
+ conflicts = openmw-tes3mp
+ source = https://github.com/TES3MP/openmw-tes3mp/releases/download/tes3mp-0.6.1/tes3mp-GNU.Linux-x86_64-release-0.6.1-f5e23d5fc6-p5.tar.gz
+ source = https://raw.githubusercontent.com/TES3MP/openmw-tes3mp/master/files/tes3mp/tes3mp_logo.png
+ sha1sums = SKIP
+ sha1sums = SKIP
+
+pkgname = openmw-tes3mp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..544e51b9a446
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Sandy Carter <genaloner@gmail.com>
+# PKGBUILD source: https://github.com/TES3MP/openmw-tes3mp
+
+pkgname=openmw-tes3mp
+pkgver=0.6.1
+pkgrel=1
+pkgdesc="TES3MP is a project aiming to add multiplayer functionality to OpenMW, a free and open source recreation of the popular Bethesda Softworks game \"The Elder Scrolls III: Morrowind\"."
+arch=('x86_64')
+url="https://github.com/TES3MP/openmw-tes3mp"
+license=('GPL3' 'custom')
+
+depends=('openal' 'openscenegraph' 'mygui>=3.2.1' 'bullet' 'qt5-base' 'ffmpeg' 'sdl2' 'unshield' 'libxt')
+conflicts=("${pkgname%-git}")
+provides=("${pkgname%-git}")
+
+source=('https://github.com/TES3MP/openmw-tes3mp/releases/download/tes3mp-0.6.1/tes3mp-GNU.Linux-x86_64-release-0.6.1-f5e23d5fc6-p5.tar.gz'
+ 'https://raw.githubusercontent.com/TES3MP/openmw-tes3mp/master/files/tes3mp/tes3mp_logo.png')
+sha1sums=('SKIP'
+ 'SKIP')
+
+package() {
+ # icon for .desktop file
+ install -Dm644 tes3mp_logo.png "$pkgdir/usr/share/pixmaps/tes3mp.png"
+ install -d $pkgdir/opt/$pkgname
+ cd "${srcdir}"
+ mv TES3MP $pkgdir/opt/$pkgname
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/tes3mp-client.desktop b/tes3mp-client.desktop
new file mode 100644
index 000000000000..d80165dfc64e
--- /dev/null
+++ b/tes3mp-client.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Type=Application
+Name=TES3MP Client
+Name[ru_RU]=Клиент TES3MP
+Comment=Client part of Morrowind multiplayer
+Comment[ru_RU]=Клиентская часть мультиплеера для Morrowind
+Path=/opt/openmw-tes3mp/
+Exec=/opt/openmw-tes3mp/tes3mp-client
+Icon=tes3mp
+Terminal=false
+Categories=Game;
diff --git a/tes3mp-server-browser.desktop b/tes3mp-server-browser.desktop
new file mode 100644
index 000000000000..f544e1fa5296
--- /dev/null
+++ b/tes3mp-server-browser.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Type=Application
+Name=TES3MP Server Browser
+Name[ru_RU]=Браузер серверов TES3MP
+Comment=TES3MP server overview
+Comment[ru_RU]=Обзор серверов TES3MP
+Path=/opt/openmw-tes3mp/
+Exec=/opt/openmw-tes3mp/tes3mp-browser
+Icon=tes3mp
+Terminal=false
+Categories=Game;
diff --git a/tes3mp-server.desktop b/tes3mp-server.desktop
new file mode 100644
index 000000000000..ed890e3b0924
--- /dev/null
+++ b/tes3mp-server.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Type=Application
+Name=TES3MP Server
+Name[ru_RU]=Сервер TES3MP
+Comment=Server part of Morrowind multiplayer
+Comment[ru_RU]=Серверная часть мультиплеера для Morrowind
+Path=/opt/openmw-tes3mp/
+Exec=/opt/openmw-tes3mp/tes3mp-server
+Icon=tes3mp
+Terminal=false
+Categories=Game;