summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHristos N. Triantafillou2022-12-02 21:12:16 -0600
committerHristos N. Triantafillou2022-12-02 21:12:16 -0600
commit115df5f74c1072217217bbc4485e1c91466b696f (patch)
tree2e4a64591fb66c20a8edc06e792a5eecd5da8dbc
parenta5f11bf4c919956c05c2fc1558c9e4f050dc80e0 (diff)
downloadaur-115df5f74c1072217217bbc4485e1c91466b696f.tar.gz
Update to 1.7
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 69a182bdb289..811471705e32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Hristos N. Triantafillou <me@hristos.co>
pkgname=openmw-validator
-pkgver=1.5
+pkgver=1.7
pkgrel=1
pkgdesc='Validate your OpenMW configuration file by checking it for various errors, also give various useful stats about data file usage.'
arch=('x86_64')
@@ -11,7 +11,7 @@ license=('GPL3')
depends=('glibc')
makedepends=('go')
source=("$pkgname-$pkgver.tar.gz::$url/archive/${pkgver}.tar.gz")
-sha512sums=('3e0c4fd18b5946f2b9ef023b5fde13b3cbf8e18baa13be86e2b549dd32225c1ed75674c8dece2c92eda90ece940bb854c8bee6003a2485c9f97b629eb8d64302')
+sha512sums=('333e83a3de9047d7fc6c4220c9c2361691d153dae8ba89736a6e9b5d59e5f864312d33d84554325e4d5c463e12f0e5ca31141cbf459e1d284cdd4394b34e23a1')
build() {
export CGO_CPPFLAGS="${CPPFLAGS}"
@@ -20,7 +20,7 @@ build() {
export CGO_LDFLAGS="${LDFLAGS}"
cd "$pkgname-$pkgver"
- go build -buildmode=pie -trimpath -ldflags="-linkmode=external -s -w -X 'git.sr.ht/~hristoast/openmw-validator/config.Version=$$(git describe --tags)'" -mod=readonly -modcacherw -o openmw-validator ./cmd/openmw-validator
+ go build -buildvcs=false -buildmode=pie -trimpath -ldflags="-linkmode=external -s -w -X 'git.sr.ht/~hristoast/openmw-validator/config.Version=$$(git describe --tags)'" -mod=readonly -modcacherw -o openmw-validator ./cmd/openmw-validator
}
package() {