summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Shalygin2016-04-17 17:25:01 +0600
committerKonstantin Shalygin2016-04-17 17:25:01 +0600
commitb2064fd0708e2fe96a595fc6f517f74202ec5caf (patch)
tree7fcda16be8f661bd7f926326c654f61258aae263
downloadaur-b2064fd0708e2fe96a595fc6f517f74202ec5caf.tar.gz
Initial import from AUR3
-rw-r--r--.SRCINFO20
-rw-r--r--MIT-LICENSE.txt19
-rw-r--r--PKGBUILD29
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..07d776d055e7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sun Apr 17 11:24:48 UTC 2016
+pkgbase = opennhrp
+ pkgdesc = An opensource NHRP implementation
+ pkgver = 0.14
+ pkgrel = 1
+ url = http://sourceforge.net/projects/opennhrp/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = linux>=3.7.4-1
+ depends = bash
+ depends = c-ares
+ source = http://downloads.sourceforge.net/project/opennhrp/opennhrp/opennhrp-0.14.tar.bz2
+ source = MIT-LICENSE.txt
+ md5sums = 62e8f16dd3bdf0600e43fcb37aa40462
+ md5sums = fcde66d6d3a34d2a5c48fcef0b0be04c
+
+pkgname = opennhrp
+
diff --git a/MIT-LICENSE.txt b/MIT-LICENSE.txt
new file mode 100644
index 000000000000..27931833e97d
--- /dev/null
+++ b/MIT-LICENSE.txt
@@ -0,0 +1,19 @@
+Copyright (c) 2007-2012 Timo Teräs
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e3e9a5d6440b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Shawn Fisher <fishbot@gmail.com>
+
+pkgname=opennhrp
+pkgver=0.14
+pkgrel=1
+pkgdesc="An opensource NHRP implementation"
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/opennhrp/"
+license=('custom')
+depends=('linux>=3.7.4-1' 'bash' 'c-ares')
+source=("http://downloads.sourceforge.net/project/opennhrp/opennhrp/$pkgname-$pkgver.tar.bz2"
+ 'MIT-LICENSE.txt')
+md5sums=('62e8f16dd3bdf0600e43fcb37aa40462'
+ 'fcde66d6d3a34d2a5c48fcef0b0be04c')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+ install -Dm644 "$srcdir/MIT-LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/MIT-LICENSE.txt"
+}
+
+# vim:set ts=2 sw=2 et: