summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2017-02-28 21:03:12 -0300
committerDaniel Bermond2017-02-28 21:03:12 -0300
commitdfadcc3fa97664106196b7fc14164f24a4bc7576 (patch)
tree5183a4d2247768d61f1c29adf763f5b1ccca6df8
parentbe35346318aee8b1544b83553e669760a9945ac6 (diff)
downloadaur-dfadcc3fa97664106196b7fc14164f24a4bc7576.tar.gz
Updated description, added more patches and fixed includes permissions
-rw-r--r--.SRCINFO16
-rw-r--r--0003-Change-path-of-config-files-to-etc-openni-modified-for-1.5.7.10.patch182
-rw-r--r--0006-Use-system-wide-libjpeg.patch38
-rw-r--r--0007-Use-system-wide-tinyxml.patch42
-rw-r--r--0010-Including-call-to-libusb_detach_kernel_driver-to-det.patch67
-rw-r--r--PKGBUILD38
6 files changed, 374 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03eaaee9af88..98150db2c01e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Feb 28 03:46:22 UTC 2017
+# Tue Feb 28 23:57:01 UTC 2017
pkgbase = openni
- pkgdesc = An interface for physical devices and for middleware components
+ pkgdesc = Framework for sensor-based 'Natural Interaction'
pkgver = 1.5.7.10
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/OpenNI/OpenNI/
install = openni.install
arch = i686
@@ -14,10 +14,20 @@ pkgbase = openni
depends = glu
depends = libusb
depends = java-environment
+ depends = libjpeg-turbo
+ depends = tinyxml
source = OpenNI-Stable-1.5.7.10.tar.gz::https://github.com/OpenNI/OpenNI/archive/Stable-1.5.7.10.tar.gz
+ source = 0003-Change-path-of-config-files-to-etc-openni-modified-for-1.5.7.10.patch
+ source = 0006-Use-system-wide-libjpeg.patch
+ source = 0007-Use-system-wide-tinyxml.patch
+ source = 0010-Including-call-to-libusb_detach_kernel_driver-to-det.patch
source = 0016-Rename-equivalent-to-fix-compilation-on-gcc6.patch
source = libopenni.pc
sha256sums = 34b0bbf68633bb213dcb15408f979d5384bdceb04e151fa519e107a12e225852
+ sha256sums = d967d715bc530eac42246182680d6a02e8f4c4251d38bd2aeabc38b9aabe6ebd
+ sha256sums = 7690bc720b3f1a06333b6ba6ca2e44f8c1b964fa31a5c1e25c112d1a2a46ae59
+ sha256sums = cf45346cd7c1a6d564dc4512c2b24852fc797c9ade57d7819446e214a88f3275
+ sha256sums = 3f60387926942f2cad4bb775738148ac5a9fa765f8873e035d8357c8d4e34ef2
sha256sums = 69cbbde667d2ad18bfb3e9933bda05d0cae36d575a4082912bbc42b7c754cd8c
sha256sums = 90b67ed122eb33df96d9935421d79b620f87e791d8773e00c1406ebafd01a364
diff --git a/0003-Change-path-of-config-files-to-etc-openni-modified-for-1.5.7.10.patch b/0003-Change-path-of-config-files-to-etc-openni-modified-for-1.5.7.10.patch
new file mode 100644
index 000000000000..bd2a60a06e9a
--- /dev/null
+++ b/0003-Change-path-of-config-files-to-etc-openni-modified-for-1.5.7.10.patch
@@ -0,0 +1,182 @@
+From: Jochen Sprickerhof <jochen@sprickerhof.de>
+Date: Wed, 4 Jul 2012 17:40:33 +0200
+Subject: Change path of config files to /etc/openni
+
+---
+ Samples/NiAudioSample/NiAudioSample.cpp | 2 +-
+ Samples/NiCRead/NiCRead.c | 2 +-
+ Samples/NiHandTracker/main.cpp | 4 ++--
+ Samples/NiRecordRaw/NiRecordRaw.cpp | 2 +-
+ Samples/NiRecordSynthetic/NiRecordSynthetic.cpp | 2 +-
+ Samples/NiSimpleRead/NiSimpleRead.cpp | 2 +-
+ Samples/NiSimpleSkeleton/NiSimpleSkeleton.cpp | 2 +-
+ Samples/NiSimpleViewer/NiSimpleViewer.cpp | 2 +-
+ Samples/NiSkeletonBenchmark/NiSkeletonBenchmark.cpp | 2 +-
+ Samples/NiUserSelection/UserTracker.cpp | 2 +-
+ Samples/NiUserTracker/main.cpp | 2 +-
+ Samples/NiViewer/NiViewer.cpp | 2 +-
+ 12 files changed, 13 insertions(+), 13 deletions(-)
+
+diff --git a/Samples/NiAudioSample/NiAudioSample.cpp b/Samples/NiAudioSample/NiAudioSample.cpp
+index a7acdf3..b57463b 100644
+--- a/Samples/NiAudioSample/NiAudioSample.cpp
++++ b/Samples/NiAudioSample/NiAudioSample.cpp
+@@ -33,7 +33,7 @@
+ //---------------------------------------------------------------------------
+ // Defines
+ //---------------------------------------------------------------------------
+-#define SAMPLE_XML_PATH "../../../../Data/SamplesConfig.xml"
++#define SAMPLE_XML_PATH "/etc/openni/SamplesConfig.xml"
+
+ #define NUMBER_OF_AUDIO_BUFFERS 100
+
+diff --git a/Samples/NiCRead/NiCRead.c b/Samples/NiCRead/NiCRead.c
+index 8fe3584..bba0ab6 100644
+--- a/Samples/NiCRead/NiCRead.c
++++ b/Samples/NiCRead/NiCRead.c
+@@ -27,7 +27,7 @@
+ //---------------------------------------------------------------------------
+ // Defines
+ //---------------------------------------------------------------------------
+-#define SAMPLE_XML_PATH "../../../../Data/SamplesConfig.xml"
++#define SAMPLE_XML_PATH "/etc/openni/SamplesConfig.xml"
+ #define SAMPLE_XML_PATH_LOCAL "SamplesConfig.xml"
+
+ //---------------------------------------------------------------------------
+diff --git a/Samples/NiHandTracker/main.cpp b/Samples/NiHandTracker/main.cpp
+index d5ca19e..de2f769 100644
+--- a/Samples/NiHandTracker/main.cpp
++++ b/Samples/NiHandTracker/main.cpp
+@@ -28,7 +28,7 @@
+ //---------------------------------------------------------------------------
+ // Defines
+ //---------------------------------------------------------------------------
+-#define SAMPLE_XML_PATH "../../../../Data/SamplesConfig.xml"
++#define SAMPLE_XML_PATH "/etc/openni/SamplesConfig.xml"
+
+
+ //---------------------------------------------------------------------------
+@@ -75,4 +75,4 @@ int main(int argc, char* argv[])
+ }
+
+ return 0;
+-}
+\ No newline at end of file
++}
+diff --git a/Samples/NiRecordRaw/NiRecordRaw.cpp b/Samples/NiRecordRaw/NiRecordRaw.cpp
+index ec7b61b..d11d8c7 100644
+--- a/Samples/NiRecordRaw/NiRecordRaw.cpp
++++ b/Samples/NiRecordRaw/NiRecordRaw.cpp
+@@ -30,7 +30,7 @@
+ //---------------------------------------------------------------------------
+ // Defines
+ //---------------------------------------------------------------------------
+-#define SAMPLE_XML_PATH "../../../../Data/SamplesConfig.xml"
++#define SAMPLE_XML_PATH "/etc/openni/SamplesConfig.xml"
+ #define RECORDING_FILE_NAME "recordingWithRaw.oni"
+ #define RAW_NODE_NAME "Raw1"
+
+diff --git a/Samples/NiRecordSynthetic/NiRecordSynthetic.cpp b/Samples/NiRecordSynthetic/NiRecordSynthetic.cpp
+index 93579d3..fa910b3 100644
+--- a/Samples/NiRecordSynthetic/NiRecordSynthetic.cpp
++++ b/Samples/NiRecordSynthetic/NiRecordSynthetic.cpp
+@@ -30,7 +30,7 @@
+ //---------------------------------------------------------------------------
+ // Defines
+ //---------------------------------------------------------------------------
+-#define SAMPLE_XML_PATH "../../../../Data/SamplesConfig.xml"
++#define SAMPLE_XML_PATH "/etc/openni/SamplesConfig.xml"
+
+ //---------------------------------------------------------------------------
+ // Macros
+diff --git a/Samples/NiSimpleRead/NiSimpleRead.cpp b/Samples/NiSimpleRead/NiSimpleRead.cpp
+index 37aed52..745b8f4 100644
+--- a/Samples/NiSimpleRead/NiSimpleRead.cpp
++++ b/Samples/NiSimpleRead/NiSimpleRead.cpp
+@@ -30,7 +30,7 @@
+ //---------------------------------------------------------------------------
+ // Defines
+ //---------------------------------------------------------------------------
+-#define SAMPLE_XML_PATH "../../../../Data/SamplesConfig.xml"
++#define SAMPLE_XML_PATH "/etc/openni/SamplesConfig.xml"
+ #define SAMPLE_XML_PATH_LOCAL "SamplesConfig.xml"
+
+ //---------------------------------------------------------------------------
+diff --git a/Samples/NiSimpleSkeleton/NiSimpleSkeleton.cpp b/Samples/NiSimpleSkeleton/NiSimpleSkeleton.cpp
+index 443058a..f2093c7 100644
+--- a/Samples/NiSimpleSkeleton/NiSimpleSkeleton.cpp
++++ b/Samples/NiSimpleSkeleton/NiSimpleSkeleton.cpp
+@@ -27,7 +27,7 @@
+ //---------------------------------------------------------------------------
+ // Defines
+ //---------------------------------------------------------------------------
+-#define SAMPLE_XML_PATH "../../../../Data/SamplesConfig.xml"
++#define SAMPLE_XML_PATH "/etc/openni/SamplesConfig.xml"
+ #define SAMPLE_XML_PATH_LOCAL "SamplesConfig.xml"
+
+ //---------------------------------------------------------------------------
+diff --git a/Samples/NiSimpleViewer/NiSimpleViewer.cpp b/Samples/NiSimpleViewer/NiSimpleViewer.cpp
+index dffb1c7..8f58195 100644
+--- a/Samples/NiSimpleViewer/NiSimpleViewer.cpp
++++ b/Samples/NiSimpleViewer/NiSimpleViewer.cpp
+@@ -36,7 +36,7 @@ using namespace xn;
+ //---------------------------------------------------------------------------
+ // Defines
+ //---------------------------------------------------------------------------
+-#define SAMPLE_XML_PATH "../../../../Data/SamplesConfig.xml"
++#define SAMPLE_XML_PATH "/etc/openni/SamplesConfig.xml"
+
+ #define GL_WIN_SIZE_X 1280
+ #define GL_WIN_SIZE_Y 1024
+diff --git a/Samples/NiSkeletonBenchmark/NiSkeletonBenchmark.cpp b/Samples/NiSkeletonBenchmark/NiSkeletonBenchmark.cpp
+index 9159875..66a8cc2 100644
+--- a/Samples/NiSkeletonBenchmark/NiSkeletonBenchmark.cpp
++++ b/Samples/NiSkeletonBenchmark/NiSkeletonBenchmark.cpp
+@@ -29,7 +29,7 @@
+ //---------------------------------------------------------------------------
+ // Defines
+ //---------------------------------------------------------------------------
+-#define SAMPLE_XML_PATH "../../Config/SamplesConfig.xml"
++#define SAMPLE_XML_PATH "/etc/openni/SamplesConfig.xml"
+ #define SAMPLE_XML_PATH_LOCAL "SamplesConfig.xml"
+ //printf tweaks
+ #define BRIGHT 1
+diff --git a/Samples/NiUserSelection/UserTracker.cpp b/Samples/NiUserSelection/UserTracker.cpp
+index 41983d0..e29d4b5 100644
+--- a/Samples/NiUserSelection/UserTracker.cpp
++++ b/Samples/NiUserSelection/UserTracker.cpp
+@@ -28,7 +28,7 @@
+ // the filename for saving/loading calibration.
+ #define XN_CALIBRATION_FILE_NAME "UserCalibration.bin"
+
+-#define SAMPLE_XML_PATH "../../../../Data/SamplesConfig.xml"
++#define SAMPLE_XML_PATH "/etc/openni/SamplesConfig.xml"
+
+
+ float *UserTracker::s_pDepthHist=NULL;
+diff --git a/Samples/NiUserTracker/main.cpp b/Samples/NiUserTracker/main.cpp
+index ea1c4e2..2da08b3 100644
+--- a/Samples/NiUserTracker/main.cpp
++++ b/Samples/NiUserTracker/main.cpp
+@@ -315,7 +315,7 @@ void glInit (int * pargc, char ** argv)
+ }
+ #endif // USE_GLES
+
+-#define SAMPLE_XML_PATH "../../../../Data/SamplesConfig.xml"
++#define SAMPLE_XML_PATH "/etc/openni/SamplesConfig.xml"
+
+ #define CHECK_RC(nRetVal, what) \
+ if (nRetVal != XN_STATUS_OK) \
+diff --git a/Samples/NiViewer/NiViewer.cpp b/Samples/NiViewer/NiViewer.cpp
+index 9e9d8f4..72f5dfb 100644
+--- a/Samples/NiViewer/NiViewer.cpp
++++ b/Samples/NiViewer/NiViewer.cpp
+@@ -86,7 +86,7 @@ using namespace glh;
+ // --------------------------------
+ // Defines
+ // --------------------------------
+-#define SAMPLE_XML_PATH "../../../../Data/SamplesConfig.xml"
++#define SAMPLE_XML_PATH "/etc/openni/SamplesConfig.xml"
+
+ // --------------------------------
+ // Types
diff --git a/0006-Use-system-wide-libjpeg.patch b/0006-Use-system-wide-libjpeg.patch
new file mode 100644
index 000000000000..d2f4bd4223f9
--- /dev/null
+++ b/0006-Use-system-wide-libjpeg.patch
@@ -0,0 +1,38 @@
+From: Jochen Sprickerhof <jochen@sprickerhof.de>
+Date: Fri, 6 Jul 2012 09:52:58 +0200
+Subject: Use system wide libjpeg
+
+---
+ Platform/Linux/Build/Modules/nimCodecs/Makefile | 13 +++++++++----
+ 1 file changed, 9 insertions(+), 4 deletions(-)
+
+diff --git a/Platform/Linux/Build/Modules/nimCodecs/Makefile b/Platform/Linux/Build/Modules/nimCodecs/Makefile
+index 1089d96..9d69531 100644
+--- a/Platform/Linux/Build/Modules/nimCodecs/Makefile
++++ b/Platform/Linux/Build/Modules/nimCodecs/Makefile
+@@ -2,16 +2,21 @@ BIN_DIR = ../../../Bin
+
+ INC_DIRS = \
+ ../../../../../Include \
+- ../../../../../Source \
+- ../../../../../Externals/LibJPEG
++ ../../../../../Source
+
+ SRC_FILES = \
+- ../../../../../Source/Modules/nimCodecs/*.cpp \
+- ../../../../../Externals/LibJPEG/*.c
++ ../../../../../Source/Modules/nimCodecs/*.cpp
+
+ LIB_NAME = nimCodecs
+ USED_LIBS = OpenNI
+
++ifeq ($(shell ld -ljpeg -o /dev/null 1>&2 2> /dev/null; echo $$?), 0)
++ USED_LIBS += jpeg
++else
++ INC_DIRS += ../../../../../Source/External/LibJPEG
++ SRC_FILES += ../../../../../Source/External/LibJPEG/*.c
++endif
++
+ include ../../Common/CommonCppMakefile
+
+
diff --git a/0007-Use-system-wide-tinyxml.patch b/0007-Use-system-wide-tinyxml.patch
new file mode 100644
index 000000000000..8fee137ae369
--- /dev/null
+++ b/0007-Use-system-wide-tinyxml.patch
@@ -0,0 +1,42 @@
+From: Jochen Sprickerhof <jochen@sprickerhof.de>
+Date: Fri, 6 Jul 2012 10:01:46 +0200
+Subject: Use system wide tinyxml
+
+---
+ Platform/Linux/Build/OpenNI/Makefile | 13 +++++++++----
+ 1 file changed, 9 insertions(+), 4 deletions(-)
+
+diff --git a/Platform/Linux/Build/OpenNI/Makefile b/Platform/Linux/Build/OpenNI/Makefile
+index c4645f5..8c0a74d 100644
+--- a/Platform/Linux/Build/OpenNI/Makefile
++++ b/Platform/Linux/Build/OpenNI/Makefile
+@@ -4,13 +4,11 @@ BIN_DIR = ../../Bin
+
+ INC_DIRS = \
+ ../../../../Include \
+- ../../../../Source \
+- ../../../../Externals/TinyXml
++ ../../../../Source
+
+ SRC_FILES = \
+ ../../../../Source/OpenNI/*.cpp \
+- ../../../../Source/OpenNI/Linux/*.cpp \
+- ../../../../Externals/TinyXml/*.cpp
++ ../../../../Source/OpenNI/Linux/*.cpp
+
+ ifeq ("$(OSTYPE)","Darwin")
+ INC_DIRS += /opt/local/include
+@@ -25,6 +23,13 @@ ifneq ("$(OSTYPE)","Darwin")
+ endif
+ DEFINES = XN_EXPORTS
+
++ifeq ($(shell ld -ltinyxml -o /dev/null 1>&2 2> /dev/null; echo $$?), 0)
++ USED_LIBS += tinyxml
++else
++ INC_DIRS += ../../../../Source/External/TinyXml
++ SRC_FILES += ../../../../Source/External/TinyXml/*.cpp
++endif
++
+ include ../Common/CommonCppMakefile
+
+
diff --git a/0010-Including-call-to-libusb_detach_kernel_driver-to-det.patch b/0010-Including-call-to-libusb_detach_kernel_driver-to-det.patch
new file mode 100644
index 000000000000..8e8f4a20fe5d
--- /dev/null
+++ b/0010-Including-call-to-libusb_detach_kernel_driver-to-det.patch
@@ -0,0 +1,67 @@
+From: elpaquete <jsaavedra.uy@gmail.com>
+Date: Mon, 7 Jan 2013 17:44:06 +0100
+Subject: =?UTF-8?q?Including=20call=20to=20libusb=5Fdetach=5Fkernel=5Fdriver?=
+ =?UTF-8?q?=20to=20detach=20other=20programs=20from=20the=20interface.=20Pre?=
+ =?UTF-8?q?vents=20errors=20in=20libusb=5Fclaim=5Finterface=20if=20it=20is=20?=
+ =?UTF-8?q?claimed=20by=20another=20program=20or=20driver.=20Corrects=20some?=
+ =?UTF-8?q?=20"Open=20failed:=20Failed=20to=20set=20USB=20interface!"=20erro?=
+ =?UTF-8?q?rs.=0AMore=20complete=20and=20detailed=20logging=20in=20openImpl=20?=
+ =?UTF-8?q?errors.?=
+
+---
+ Source/OpenNI/Linux/XnUSBLinux.cpp | 38 ++++++++++++++++++++++++++++++++++++
+ 1 file changed, 38 insertions(+)
+
+diff --git a/Source/OpenNI/Linux/XnUSBLinux.cpp b/Source/OpenNI/Linux/XnUSBLinux.cpp
+index c8529f8..44259e5 100644
+--- a/Source/OpenNI/Linux/XnUSBLinux.cpp
++++ b/Source/OpenNI/Linux/XnUSBLinux.cpp
+@@ -398,10 +398,48 @@ XN_C_API XnStatus xnUSBOpenDeviceImpl(libusb_device* pDevice, XN_USB_DEV_HANDLE*
+ return (XN_STATUS_USB_SET_CONFIG_FAILED);
+ }
+ */
++
++ // Asking the kernel politely to detach every other driver form this device.
++ // If other drivers or programs are attached to the interface, it cannot be claimed.
++ xnLogVerbose(XN_MASK_USB, "Detaching other kernel drivers.");
++ rc = libusb_detach_kernel_driver(handle, 0);
++ if (rc == 0)
++ {
++ xnLogWarning (XN_MASK_USB, "Detach success. Drivers detached.");
++ }
++ else if (rc == LIBUSB_ERROR_NOT_FOUND)
++ {
++ xnLogWarning (XN_MASK_USB, "Detach success. No drivers were attached.");
++ }
++ else if (rc == LIBUSB_ERROR_INVALID_PARAM)
++ {
++ XN_LOG_ERROR_RETURN (XN_STATUS_USB_SET_CONFIG_FAILED, XN_MASK_USB, "Detach kernel driver error. The specified interface does not exist.");
++ }
++ else if (rc == LIBUSB_ERROR_NO_DEVICE)
++ {
++ XN_LOG_ERROR_RETURN (XN_STATUS_USB_SET_CONFIG_FAILED, XN_MASK_USB, "Detach kernel driver error. Device is disconnectd.");
++ }
++ else
++ {
++ XN_LOG_ERROR_RETURN (XN_STATUS_USB_SET_CONFIG_FAILED, XN_MASK_USB, "Detach kernel driver error. Unknown error.");
++ }
++
++ xnLogVerbose(XN_MASK_USB, "Claiming the interface.");
+ // claim the interface (you cannot open any end point before claiming the interface)
+ rc = libusb_claim_interface(handle, 0);
+ if (rc != 0)
+ {
++ if (rc == LIBUSB_ERROR_NOT_FOUND)
++ xnLogError (XN_MASK_USB, "Interface claim failed: The specified interface does not exist.");
++ else if (rc == LIBUSB_ERROR_BUSY)
++ xnLogError (XN_MASK_USB, "Interface claim failed: Another program or driver has claimed the interface.");
++ else if (rc == LIBUSB_ERROR_NO_DEVICE)
++ xnLogError (XN_MASK_USB, "Interface claim failed: Device disconnected.");
++ else if (rc == LIBUSB_ERROR_OTHER)
++ xnLogError(XN_MASK_USB, "Interface claim failed: Other error.");
++ else
++ xnLogError(XN_MASK_USB, "Interface claim failed: Unknown error.");
++
+ libusb_close(handle);
+ return (XN_STATUS_USB_SET_INTERFACE_FAILED);
+ }
diff --git a/PKGBUILD b/PKGBUILD
index 04d8bf7bb502..a788c0c1d0c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,25 +6,51 @@
pkgname=openni
pkgver=1.5.7.10
-pkgrel=3
-pkgdesc="An interface for physical devices and for middleware components"
+pkgrel=4
+pkgdesc="Framework for sensor-based 'Natural Interaction'"
arch=('i686' 'x86_64')
url="https://github.com/OpenNI/OpenNI/"
license=('APACHE')
-depends=('freeglut' 'glu' 'libusb' 'java-environment')
+depends=('freeglut' 'glu' 'libusb' 'java-environment' 'libjpeg-turbo' 'tinyxml')
makedepends=('dos2unix')
install="${pkgname}.install"
_srcprefix="OpenNI-Stable"
source=("${_srcprefix}-${pkgver}.tar.gz"::"https://github.com/OpenNI/OpenNI/archive/Stable-${pkgver}.tar.gz"
+ '0003-Change-path-of-config-files-to-etc-openni-modified-for-1.5.7.10.patch'
+ '0006-Use-system-wide-libjpeg.patch'
+ '0007-Use-system-wide-tinyxml.patch'
+ '0010-Including-call-to-libusb_detach_kernel_driver-to-det.patch'
'0016-Rename-equivalent-to-fix-compilation-on-gcc6.patch'
'libopenni.pc')
sha256sums=('34b0bbf68633bb213dcb15408f979d5384bdceb04e151fa519e107a12e225852'
+ 'd967d715bc530eac42246182680d6a02e8f4c4251d38bd2aeabc38b9aabe6ebd'
+ '7690bc720b3f1a06333b6ba6ca2e44f8c1b964fa31a5c1e25c112d1a2a46ae59'
+ 'cf45346cd7c1a6d564dc4512c2b24852fc797c9ade57d7819446e214a88f3275'
+ '3f60387926942f2cad4bb775738148ac5a9fa765f8873e035d8357c8d4e34ef2'
'69cbbde667d2ad18bfb3e9933bda05d0cae36d575a4082912bbc42b7c754cd8c'
'90b67ed122eb33df96d9935421d79b620f87e791d8773e00c1406ebafd01a364')
prepare() {
cd "${srcdir}/${_srcprefix}-${pkgver}"
- dos2unix Samples/NiViewer/glh/glh_linear.h
+
+ # needed for patch 0003
+ dos2unix Samples/NiAudioSample/NiAudioSample.cpp
+ dos2unix Samples/NiCRead/NiCRead.c
+ dos2unix Samples/NiSimpleRead/NiSimpleRead.cpp
+ dos2unix Samples/NiSimpleSkeleton/NiSimpleSkeleton.cpp
+ dos2unix Samples/NiSimpleViewer/NiSimpleViewer.cpp
+ unix2dos Samples/NiSkeletonBenchmark/NiSkeletonBenchmark.cpp
+ dos2unix Samples/NiUserSelection/UserTracker.cpp
+ dos2unix Samples/NiUserTracker/main.cpp
+ dos2unix Samples/NiViewer/NiViewer.cpp
+
+ dos2unix Source/OpenNI/Linux/XnUSBLinux.cpp # needed for patch 0010
+ dos2unix Samples/NiViewer/glh/glh_linear.h # needed for patch 0016
+
+ patch -Np1 -i "${srcdir}/0003-Change-path-of-config-files-to-etc-openni-modified-for-1.5.7.10.patch"
+ patch -Np1 -i "${srcdir}/0006-Use-system-wide-libjpeg.patch"
+ patch -Np1 -i "${srcdir}/0007-Use-system-wide-tinyxml.patch"
+ patch -Np1 -i "${srcdir}/0010-Including-call-to-libusb_detach_kernel_driver-to-det.patch"
patch -Np1 -i "${srcdir}/0016-Rename-equivalent-to-fix-compilation-on-gcc6.patch"
}
@@ -56,8 +82,8 @@ package() {
# includes
cd "${srcdir}/${_srcprefix}-${pkgver}/Include"
install -D -m644 *.h "${pkgdir}/usr/include/ni"
- install -D -m755 Linux-Arm/* "${pkgdir}/usr/include/ni/Linux-Arm"
- install -D -m755 Linux-x86/* "${pkgdir}/usr/include/ni/Linux-x86"
+ install -D -m644 Linux-Arm/* "${pkgdir}/usr/include/ni/Linux-Arm"
+ install -D -m644 Linux-x86/* "${pkgdir}/usr/include/ni/Linux-x86"
# config
cd "${srcdir}/${_srcprefix}-${pkgver}/Data"