summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Kohlstedde2018-11-03 13:48:23 +0100
committerChristian Kohlstedde2018-11-03 13:48:23 +0100
commit0081c58da8dcb12ba4a4e43b53943840a2d4904a (patch)
tree8d1ca758ecda92612eca8a82582680157c7e6780
downloadaur-0081c58da8dcb12ba4a4e43b53943840a2d4904a.tar.gz
Package openob
-rw-r--r--.SRCINFO23
-rw-r--r--LICENSE13
-rw-r--r--PKGBUILD47
3 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5c6e78f1c77d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = openob
+ pkgdesc = A GStreamer based app a configurable RTP audio link system
+ pkgver = 4.0.2
+ pkgrel = 1
+ url = https://github.com/JamesHarrison/openob
+ arch = x86_64
+ license = BSD
+ makedepends = python-setuptools
+ depends = python
+ depends = python-redis
+ depends = python-gobject
+ depends = gst-plugins-base
+ depends = gst-plugins-good
+ depends = gst-plugins-bad
+ depends = gst-python
+ depends = gobject-introspection
+ source = https://files.pythonhosted.org/packages/source/O/OpenOB/OpenOB-4.0.2.tar.gz
+ source = LICENSE
+ sha256sums = 650609cfd87e54371f5141b5aa6dc4079cbd9386c22de420488509325841bb37
+ sha256sums = 36cf4ab7947bb6c146c13457bfda770a5ea208d176c3dd3c7820857c559cd523
+
+pkgname = openob
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..0cd20e2e5296
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,13 @@
+OpenOB was developed by James Harrison, with chunks of example code used from Alexandre Bourget and various other GStreamer documentation sites such as the PyGST manual.
+
+Copyright (c) 2018, James Harrison
+
+License is 3-clause BSD:
+
+Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
+
+* Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
+* Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
+* Neither the name of the OpenOB project nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL JAMES HARRISON OR OTHER OPENOB CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..40caa998e0ae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Christian Kohlstedde <christian@kohlsted.de>
+
+_name=OpenOB
+pkgname=openob
+pkgver=4.0.2
+pkgrel=1
+pkgdesc="A GStreamer based app a configurable RTP audio link system"
+arch=('x86_64')
+url="https://github.com/JamesHarrison/openob"
+license=('BSD')
+depends=(
+ 'python'
+ 'python-redis'
+ 'python-gobject'
+ 'gst-plugins-base'
+ 'gst-plugins-good'
+ 'gst-plugins-bad'
+ 'gst-python'
+ 'gobject-introspection'
+)
+makedepends=('python-setuptools')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz"
+ "LICENSE")
+noextract=()
+sha256sums=('650609cfd87e54371f5141b5aa6dc4079cbd9386c22de420488509325841bb37'
+ '36cf4ab7947bb6c146c13457bfda770a5ea208d176c3dd3c7820857c559cd523')
+
+build() {
+ cd "${_name}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${_name}-${pkgver}"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+
+ install -Dm644 $srcdir/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}