summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-06 22:04:50 +0100
committerBartłomiej Piotrowski2018-01-06 22:04:50 +0100
commit7b34277e7b2a22f47daab76e0955defbfd667e17 (patch)
treecb8ec1ce2587131c117d035a4ebb037e4d450b54
downloadaur-7b34277e7b2a22f47daab76e0955defbfd667e17.tar.gz
Import from official repositories
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD42
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f22a61504b02
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = openobex
+ pkgdesc = Implementation of the OBject EXchange (OBEX) protocol
+ pkgver = 1.7.2
+ pkgrel = 3
+ url = http://dev.zuckschwerdt.org/openobex/
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ makedepends = cmake
+ makedepends = libxslt
+ makedepends = doxygen
+ makedepends = java-environment
+ depends = libusbx
+ depends = bluez-libs
+ options = staticlibs
+ options = !makeflags
+ source = http://downloads.sourceforge.net/openobex/openobex-1.7.2-Source.tar.gz
+ md5sums = f6e0b6cb7dcfd731460a7e9a91429a3a
+
+pkgname = openobex
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..68d65b558867
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
+# Maintainer:
+# Contributor: Geoffroy Carrier <geoffroy@archlinux.org>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: damir <damir@archlinux.org>
+
+pkgname=openobex
+pkgver=1.7.2
+pkgrel=3
+pkgdesc="Implementation of the OBject EXchange (OBEX) protocol"
+url="http://dev.zuckschwerdt.org/openobex/"
+arch=('x86_64')
+license=('GPL' 'LGPL')
+depends=('libusbx' 'bluez-libs')
+makedepends=('cmake' 'libxslt' 'doxygen' 'java-environment')
+options=('staticlibs' '!makeflags')
+source=(http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}-Source.tar.gz)
+md5sums=('f6e0b6cb7dcfd731460a7e9a91429a3a')
+
+prepare() {
+ sed -i 's|MODE="660", GROUP="plugdev"|TAG+="uaccess"|' ${pkgname}-${pkgver}-Source/udev/openobex.rules.in
+}
+
+build() {
+ mkdir build
+ cd build
+ cmake ../${pkgname}-${pkgver}-Source \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_SKIP_RPATH=ON \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib \
+ -DCMAKE_INSTALL_SBINDIR=/usr/bin \
+ -DCMAKE_INSTALL_UDEVRULESDIR=/usr/lib/udev/rules.d
+ make all openobex-apps
+}
+
+package() {
+ cd build
+ make DESTDIR="${pkgdir}" install
+ cp ../${pkgname}-${pkgver}-Source/apps/lib/*.h "${pkgdir}/usr/include/openobex/"
+ install -m644 apps/lib/libopenobex-apps-common.a "${pkgdir}/usr/lib/libopenobex-apps-common.a"
+}