summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKurt McAlpine2019-03-07 11:20:34 +1300
committerKurt McAlpine2019-03-07 11:20:34 +1300
commit07f760ccc0e03f9810e0b3af3e87178264e87ef6 (patch)
tree4bba365d362ff30cb6c8db4cb7daa6e2b052d4a0
downloadaur-07f760ccc0e03f9810e0b3af3e87178264e87ef6.tar.gz
Create package for espressif openocd-esp32
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD65
2 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0475a6eb703f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = openocd-esp32
+ pkgdesc = Fork of OpenOCD that has ESP32 support
+ pkgver = .00778.g256cc646
+ pkgrel = 1
+ url = https://github.com/espressif/openocd-esp32
+ arch = i686
+ arch = x86_64
+ arch = arm
+ license = GPL
+ makedepends = git
+ makedepends = automake>=1.11
+ makedepends = autoconf
+ makedepends = libtool
+ makedepends = tcl
+ depends = libftdi
+ depends = libftdi-compat
+ depends = libusb
+ depends = libusb-compat
+ depends = hidapi
+ options = !strip
+ source = openocd-esp32::git+https://github.com/espressif/openocd-esp32.git
+ md5sums = SKIP
+ sha1sums = SKIP
+
+pkgname = openocd-esp32
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc2ca31e06cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# Maintainer: Kurt McAlpine <kurt at linux dot com>
+# Contributor: Michael Zimmermann <sigmaepsilon92@gmail.com>
+# Contributor: Emil Renner Berthing <aur@esmil.dk>
+# Contributor: yhfudev <yhfudev ta gmail dot com>
+# Contributor: veox <veox ta wemakethings dot net>
+# Contributor: Nick Østergaard <oe.nick at gmail dot com>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Contributor: Matthias Bauch <matthias.bauch@gmail.com>
+# Contributor: Laszlo Papp <djszapi2 at gmail com>
+# Contributor: Samuel Tardieu <sam@rfc1149.net>
+
+pkgname=openocd-esp32
+pkgver=.00778.g256cc646
+pkgrel=1
+pkgdesc='Fork of OpenOCD that has ESP32 support'
+arch=('i686' 'x86_64' 'arm')
+url='https://github.com/espressif/openocd-esp32'
+license=('GPL')
+depends=('libftdi' 'libftdi-compat' 'libusb' 'libusb-compat' 'hidapi' )
+makedepends=('git' 'automake>=1.11' 'autoconf' 'libtool' 'tcl')
+options=(!strip)
+
+source=(
+ "$pkgname::git+https://github.com/espressif/openocd-esp32.git"
+ )
+md5sums=(
+ 'SKIP'
+ )
+sha1sums=(
+ 'SKIP'
+ )
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ local ver="$(cat configure.ac | grep AC_INIT | cut -d'[' -f3 | cut -d']' -f1)"
+ local rev="$(./guess-rev.sh)"
+ echo "${rev//-/.}"
+}
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ git submodule init
+ git submodule update
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+
+ ./bootstrap
+ ./configure \
+ --prefix=/usr \
+ --program-prefix=${pkgname%openocd} \
+ --disable-werror \
+ --with-gnu-ld
+
+ make pkgdatadir="/usr/share/$pkgname"
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+
+ make pkgdatadir="/usr/share/$pkgname" DESTDIR="$pkgdir" install
+
+ rm -r "$pkgdir/usr/share/info"
+}