summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBienChen2021-04-01 16:41:39 +0800
committerBienChen2021-04-01 16:41:39 +0800
commite0a0bb58e8761644b003f5aa8f54427ec4c3602c (patch)
tree7819c3988c11a85bd2c7b17bde0dedf1cb422443
downloadaur-e0a0bb58e8761644b003f5aa8f54427ec4c3602c.tar.gz
Initial commit.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD20
-rw-r--r--openocd-nuclei-bin.install7
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5d01cc861bbe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = openocd-nuclei-bin
+ pkgdesc = OpenOCD with RISC-V support from Nuclei System Technology (official build).
+ pkgver = 0.10.0
+ pkgrel = 15
+ url = https://nucleisys.com/download.php
+ install = openocd-nuclei-bin.install
+ arch = x86_64
+ license = GPL
+ provides = openocd
+ source = https://nucleisys.com/upload/files/toochain/openocd/nuclei-openocd-0.10.0-15-linux-x64.tgz
+ sha256sums = 636e48ffba7ab4b63f28f36db2549c09fb04cd2f876e450b8c3e39af4e5b983f
+
+pkgname = openocd-nuclei-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d30accd2ba60
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: BienChen <binchan at gmx dot com>
+
+pkgname=openocd-nuclei-bin
+_pkgname=Nuclei-Toolchain
+pkgver=0.10.0
+pkgrel=15
+pkgdesc='OpenOCD with RISC-V support from Nuclei System Technology (official build).'
+arch=('x86_64')
+url='https://nucleisys.com/download.php'
+license=('GPL')
+provides=('openocd')
+install="${pkgname}.install"
+source=("https://nucleisys.com/upload/files/toochain/openocd/nuclei-openocd-${pkgver}-${pkgrel}-linux-x64.tgz")
+sha256sums=('636e48ffba7ab4b63f28f36db2549c09fb04cd2f876e450b8c3e39af4e5b983f')
+
+package() {
+ mkdir -p "${pkgdir}/opt/${_pkgname}"
+ mv "${srcdir}/Nuclei/openocd/${pkgver}-${pkgrel}" "${srcdir}/openocd"
+ mv "${srcdir}/openocd" "${pkgdir}/opt/${_pkgname}/"
+}
diff --git a/openocd-nuclei-bin.install b/openocd-nuclei-bin.install
new file mode 100644
index 000000000000..6be88bd6ea4d
--- /dev/null
+++ b/openocd-nuclei-bin.install
@@ -0,0 +1,7 @@
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+post_install() {
+ echo "add ${bold}export NUCLEI_TOOL_ROOT=/opt/Nuclei-Toolchain${all_off}"
+ echo "and ${bold}export PATH=\$NUCLEI_TOOL_ROOT/gcc/bin:\$NUCLEI_TOOL_ROOT/openocd/bin:\$PATH${all_off}"
+ echo "to ${bold}~/.bashrc${all_off} and ${bold}source ~/.bashrc${all_off} before compile any project."
+}