summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryhfudev2015-06-13 13:05:50 -0400
committeryhfudev2015-06-13 13:05:50 -0400
commita43188ff3d131611725f9b2b3d89f25f13c07b3f (patch)
tree6c2873ed753a03ce34af5fc1de156d80bac399b9
parent2ba09416929f9e0e4e0e6210abac3b0b4dc4d3b7 (diff)
downloadaur-a43188ff3d131611725f9b2b3d89f25f13c07b3f.tar.gz
update for latest git version
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD62
-rw-r--r--openocd-0.9.0-exit-clean.patch59
3 files changed, 47 insertions, 87 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df605118cb38..1e893d1ebc98 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = openocd-git
pkgdesc = Debugging, in-system programming and boundary-scan testing for embedded target devices (git version)
- pkgver = 6734.09ca5af
+ pkgver = 70a14db
pkgrel = 1
- url = http://openocd.sourceforge.net/
+ url = http://openocd.org
install = openocd-git.install
arch = i686
arch = x86_64
@@ -17,18 +17,13 @@ pkgbase = openocd-git
depends = libftdi-compat
depends = libusb
depends = libusb-compat
- optdepends = libftdi: support devices using this FTDI implementation
- optdepends = libftd2xx: support devices using this FTDI implementation
- optdepends = hidapi: support CMSIS-DAP compliant devices
+ depends = hidapi
provides = openocd
conflicts = openocd
options = !strip
- source = openocd::git://git.code.sf.net/p/openocd/code
- source = openocd-0.9.0-exit-clean.patch
+ source = openocd-git::git://git.code.sf.net/p/openocd/code
md5sums = SKIP
- md5sums = 72f43470849c08d298a8de6b4598ba3b
sha1sums = SKIP
- sha1sums = 5456bd27e1bdb466a3df12f163efb8b6128429b9
pkgname = openocd-git
diff --git a/PKGBUILD b/PKGBUILD
index 878ac33d1745..69c0239a7c7c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,17 +7,14 @@
# Contributor: Samuel Tardieu <sam@rfc1149.net>
pkgname=openocd-git
-_gitname=openocd
-pkgver=6734.09ca5af
+_gitname=openocd-git
+pkgver=70a14db
pkgrel=1
pkgdesc="Debugging, in-system programming and boundary-scan testing for embedded target devices (git version)"
arch=('i686' 'x86_64' 'arm')
-url="http://openocd.sourceforge.net/"
+url="http://openocd.org"
license=('GPL')
-depends=('libftdi' 'libftdi-compat' 'libusb' 'libusb-compat')
-optdepends=('libftdi: support devices using this FTDI implementation'
- 'libftd2xx: support devices using this FTDI implementation'
- 'hidapi: support CMSIS-DAP compliant devices')
+depends=('libftdi' 'libftdi-compat' 'libusb' 'libusb-compat' 'hidapi' )
makedepends=('git' 'automake>=1.11' 'autoconf' 'libtool' 'tcl')
options=(!strip)
install=openocd-git.install
@@ -26,24 +23,52 @@ conflicts=('openocd')
source=(
"${_gitname}::git://git.code.sf.net/p/openocd/code"
- "openocd-0.9.0-exit-clean.patch"
+ #"openocd-0.9.0-exit-clean.patch"
)
md5sums=(
'SKIP'
- '72f43470849c08d298a8de6b4598ba3b'
)
sha1sums=(
'SKIP'
- '5456bd27e1bdb466a3df12f163efb8b6128429b9'
)
# Specify desired features and device support here. A list can be
# obtained by running ./configure in the source directory.
_features=(
- sysfsgpio amtjtagaccel arm-jtag-ew at91rm9200 buspirate ep93xx ftdi gw16012 jlink
- oocd_trace opendous osbdm parport presto_libftdi remote-bitbang rlink stlink ti-icdi
- ulink usbprog vsllink
- arm-jtag-ew dummy
+ aice
+ amtjtagaccel
+ armjtagew
+ at91rm9200
+ bcm2835gpio
+ buspirate
+ cmsis-dap
+ dummy
+ ep93xx
+ ftdi
+ gw16012
+ ioutil
+ jlink
+ jtag_vpi
+ legacy-ft2232_libftdi
+ oocd_trace
+ opendous
+ openjtag_ftdi
+ osbdm
+ parport
+ presto_libftdi
+ remote-bitbang
+ rlink
+ stlink
+ sysfsgpio
+ ti-icdi
+ ulink
+ usb-blaster-2
+ usb_blaster_libftdi
+ usbprog
+ vsllink
+ #parport-giveio
+ #zy1000
+ #zy1000-master
)
pkgver_git() {
@@ -67,7 +92,7 @@ pkgver() {
prepare() {
cd "$srcdir/${_gitname}"
- patch -p1 <$srcdir/openocd-0.9.0-exit-clean.patch
+ #patch -p1 <$srcdir/openocd-0.9.0-exit-clean.patch
}
build() {
@@ -78,16 +103,15 @@ build() {
--enable-maintainer-mode \
--disable-werror \
${_features[@]/#/--enable-} \
- --enable-legacy-ft2232_libftdi \
- --enable-usb_blaster_libftdi \
$(NULL)
+ #make clean
make
}
package() {
cd "$srcdir/${_gitname}"
make DESTDIR=${pkgdir} install
- #rm -rf ${srcdir}/$_gitname-build
- #rm -rf $pkgdir/usr/share/info/dir
+ rm -rf ${srcdir}/$_gitname-build
+ rm -rf $pkgdir/usr/share/info/dir
}
diff --git a/openocd-0.9.0-exit-clean.patch b/openocd-0.9.0-exit-clean.patch
deleted file mode 100644
index 4babc355a651..000000000000
--- a/openocd-0.9.0-exit-clean.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-diff --git a/src/helper/command.c b/src/helper/command.c
-index c29f113..d01c35e 100644
---- a/src/helper/command.c
-+++ b/src/helper/command.c
-@@ -118,10 +118,17 @@ static void command_log_capture_finish(struct log_capture_state *state)
- static int command_retval_set(Jim_Interp *interp, int retval)
- {
- int *return_retval = Jim_GetAssocData(interp, "retval");
-- if (return_retval != NULL)
-- *return_retval = retval;
-
-- return (retval == ERROR_OK) ? JIM_OK : JIM_ERR;
-+ if (retval == ERROR_COMMAND_CLOSE_CONNECTION)
-+ {
-+ if (return_retval != NULL)
-+ *return_retval = 0;
-+ return JIM_EXIT;
-+ } else {
-+ if (return_retval != NULL)
-+ *return_retval = retval;
-+ return (retval == ERROR_OK) ? JIM_OK : JIM_ERR;
-+ }
- }
-
- extern struct command_context *global_cmd_ctx;
-@@ -671,8 +678,7 @@ int command_run_line(struct command_context *context, char *line)
- }
- return retval;
- } else if (retcode == JIM_EXIT) {
-- /* ignore.
-- * exit(Jim_GetExitCode(interp)); */
-+ return ERROR_OK_EXIT;
- } else {
- const char *result;
- int reslen;
-diff --git a/src/helper/log.h b/src/helper/log.h
-index 7f9f32c..8a15b41 100644
---- a/src/helper/log.h
-+++ b/src/helper/log.h
-@@ -140,5 +140,6 @@ extern int debug_level;
- #define ERROR_FAIL (-4)
- #define ERROR_WAIT (-5)
-
-+#define ERROR_OK_EXIT (-6)
-
- #endif /* LOG_H */
-diff --git a/src/openocd.c b/src/openocd.c
-index b0dd21a..847c137 100644
---- a/src/openocd.c
-+++ b/src/openocd.c
-@@ -283,6 +283,8 @@ static int openocd_thread(int argc, char *argv[], struct command_context *cmd_ct
- return ERROR_FAIL;
-
- ret = parse_config_file(cmd_ctx);
-+ if (ret == ERROR_OK_EXIT)
-+ return ERROR_OK;
- if (ret != ERROR_OK)
- return ERROR_FAIL;
-