summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortaotieren2021-07-27 14:43:48 +0800
committertaotieren2021-07-27 14:43:48 +0800
commitf34ecbc20f3ad321c827a44d06ea8577d274d313 (patch)
tree5bc98f68a870df649a1e225c435f9c8e1579f96b
downloadaur-f34ecbc20f3ad321c827a44d06ea8577d274d313.tar.gz
Update v20.08.00.00
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD31
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0443c2e4a133
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = openocdcfg-generator
+ pkgdesc = This is a python tool based on pydevicetree (GitHub/PyPI) which generates OpenOCD Configuration Files for Freedom Metal applications.
+ pkgver = 20.08.00.00
+ pkgrel = 1
+ url = https://github.com/sifive/openocdcfg-generator
+ arch = any
+ license = Apache
+ depends = python
+ depends = openocd
+ depends = python-jinja-time
+ depends = python-markupsafe
+ depends = python-pylint
+ depends = python-pydevicetree
+ options = !strip
+ source = openocdcfg-generator-20.08.00.00.tar.gz::https://download.fastgit.org/sifive/openocdcfg-generator/archive/refs/tags/v20.08.00.00.tar.gz
+ sha256sums = a348e9688502b88ede43c8a40b0d8a29d52620482361b2c7c0d4106b3d91a50c
+
+pkgname = openocdcfg-generator
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..37bb465dc2db
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*
+*.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b378be555f40
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: taotieren <admin@taotieren.com>
+
+pkgname=openocdcfg-generator
+pkgver=20.08.00.00
+pkgrel=1
+epoch=
+pkgdesc="This is a python tool based on pydevicetree (GitHub/PyPI) which generates OpenOCD Configuration Files for Freedom Metal applications."
+arch=('any')
+url="https://github.com/sifive/openocdcfg-generator"
+license=('Apache')
+groups=()
+depends=('python' 'openocd' 'python-jinja-time' 'python-markupsafe' 'python-pylint' 'python-pydevicetree')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=('!strip')
+install=
+changelog=
+source=("${pkgname}-${pkgver}.tar.gz::https://download.fastgit.org/sifive/openocdcfg-generator/archive/refs/tags/v${pkgver}.tar.gz")
+noextract=()
+sha256sums=('a348e9688502b88ede43c8a40b0d8a29d52620482361b2c7c0d4106b3d91a50c')
+#validpgpkeys=()
+
+package() {
+ install -Dm0755 "${srcdir}/${pkgname}-${pkgver}/generate_openocdcfg.py" "${pkgdir}/usr/bin/${pkgname}"
+
+}