summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Parnell2015-06-15 21:24:23 -0500
committerMatt Parnell2015-06-15 21:24:23 -0500
commitdd5cc4c210361700a6dd3b1967fddcf59a571a13 (patch)
tree95f24d68653f7acd45dce863294c7c0bebbc3c2a
downloadaur-dd5cc4c210361700a6dd3b1967fddcf59a571a13.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rwxr-xr-xPKGBUILD39
-rw-r--r--openoffice.patch20
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aadc8b9cbf03
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = openoffice-uglyfix-freetype2
+ pkgdesc = Original Uglyfix, which compiles freetype2 .so files and puts them in the libreoffice directory to fix font ugliness
+ pkgver = 2.5.5
+ pkgrel = 1
+ url = http://freetype.sourceforge.net
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = zlib
+ depends = libreoffice
+ options = !libtool
+ source = http://downloads.sourceforge.net/sourceforge/freetype/freetype-2.5.5.tar.bz2
+ source = openoffice.patch
+ md5sums = 2a7a314927011d5030903179cf183be0
+ md5sums = 14d44b030ab8de3e865f095930018766
+
+pkgname = openoffice-uglyfix-freetype2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..caf9729ab2d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Contributor: ilikenwf/Matt Parnell <parwok@gmail.com>
+# Maintainer: ilikenwf/Matt Parnell <parwok@gmail.com>
+
+pkgname=openoffice-uglyfix-freetype2
+pkgver=2.5.5
+pkgrel=1
+pkgdesc="Original Uglyfix, which compiles freetype2 .so files and puts them in the libreoffice directory to fix font ugliness"
+arch=(i686 x86_64)
+license=('GPL')
+url="http://freetype.sourceforge.net"
+depends=('zlib' 'libreoffice')
+options=('!libtool')
+source=(http://downloads.sourceforge.net/sourceforge/freetype/freetype-${pkgver}.tar.bz2
+ openoffice.patch)
+md5sums=('2a7a314927011d5030903179cf183be0'
+ '14d44b030ab8de3e865f095930018766')
+
+prepare()
+{
+ cd ${srcdir}/freetype-${pkgver}
+ patch -Np0 -i ${srcdir}/openoffice.patch || return 1
+}
+
+build()
+{
+ cd ${srcdir}/freetype-${pkgver}
+ ./configure --prefix=/usr --with-bytecode_interpreter --with-subpixel_rendering --disable-static || return 1
+ make || return 1
+}
+
+package()
+{
+ cd ${srcdir}/freetype-${pkgver}
+ make DESTDIR=${startdir}/pkg install || return 1
+ mkdir -p ${pkgdir}/usr/lib/libreoffice/basis-link/program
+ install -c ${startdir}/pkg/usr/lib/libfreetype.so* ${pkgdir}/usr/lib/libreoffice/basis-link/program/
+ rm -rf ${pkgdir}/usr/{bin,include,share}
+ rm -rf ${pkgdir}/usr/lib/{pkgconfig,libfreetype.so,libfreetype.so.6,libfreetype.so*}
+}
diff --git a/openoffice.patch b/openoffice.patch
new file mode 100644
index 000000000000..6ec502864f0f
--- /dev/null
+++ b/openoffice.patch
@@ -0,0 +1,20 @@
+--- include/freetype.orig 2013-12-21 22:58:05.639880352 -0600
++++ include/freetype.h 2013-12-21 22:57:36.886881072 -0600
+@@ -2592,7 +2592,7 @@
+ #define FT_LOAD_RENDER ( 1L << 2 )
+ #define FT_LOAD_NO_BITMAP ( 1L << 3 )
+ #define FT_LOAD_VERTICAL_LAYOUT ( 1L << 4 )
+-#define FT_LOAD_FORCE_AUTOHINT ( 1L << 5 )
++#define FT_LOAD_NO_AUTOHINT ( 1L << 5 )
+ #define FT_LOAD_CROP_BITMAP ( 1L << 6 )
+ #define FT_LOAD_PEDANTIC ( 1L << 7 )
+ #define FT_LOAD_IGNORE_GLOBAL_ADVANCE_WIDTH ( 1L << 9 )
+@@ -2600,7 +2600,7 @@
+ #define FT_LOAD_IGNORE_TRANSFORM ( 1L << 11 )
+ #define FT_LOAD_MONOCHROME ( 1L << 12 )
+ #define FT_LOAD_LINEAR_DESIGN ( 1L << 13 )
+-#define FT_LOAD_NO_AUTOHINT ( 1L << 15 )
++#define FT_LOAD_FORCE_AUTOHINT ( 1L << 15 )
+ /* Bits 16..19 are used by `FT_LOAD_TARGET_' */
+ #define FT_LOAD_COLOR ( 1L << 20 )
+