summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-02-28 15:47:42 +0200
committerDimitris Kiziridis2020-02-28 15:47:42 +0200
commite6ee475d7889fbb1676ee5663219d5ead4d6655d (patch)
tree521ac68958c3713cc0d4c4f928a6aeffe5fe5099
parent278a768010489a651684bf5dc322c36cb746a038 (diff)
downloadaur-e6ee475d7889fbb1676ee5663219d5ead4d6655d.tar.gz
Update to 1.5.1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD87
2 files changed, 40 insertions, 59 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64a5a44088fd..97658eb90a05 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = openpose
- pkgdesc = OpenPose represents the first real-time multi-person system to jointly detect human body, hand, and facial keypoints (in total 135 keypoints) on single images.
- pkgver = 1.3.0
+ pkgdesc = OpenPose: Real-time multi-person keypoint detection library for body, face, hands, and foot estimation
+ pkgver = 1.5.1
pkgrel = 1
url = https://github.com/CMU-Perceptual-Computing-Lab/openpose
arch = any
@@ -15,12 +15,8 @@ pkgbase = openpose
depends = glu
depends = lilv
depends = boost
- source = https://github.com/CMU-Perceptual-Computing-Lab/openpose/archive/v1.3.0.tar.gz
- source = GLU.patch
- source = models.patch
- sha256sums = 5ef834e603dc207c249f49ba672c8bd1895e5a2ffc0ff5548037402a80398bd0
- sha256sums = d2e3ad3dd350e494d1e90d595f6b0d4daa76ed9744f7730c22b1803390f1f021
- sha256sums = 6dfa55f1876778950ed04cbf98f032c4b4129c56c396209837403398e9815f31
+ source = https://github.com/CMU-Perceptual-Computing-Lab/openpose/archive/v1.5.1.tar.gz
+ md5sums = ac27f8102c1e8c2e5b51532a46c10181
pkgname = openpose
diff --git a/PKGBUILD b/PKGBUILD
index e04968ae8845..027936dc3554 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,20 @@
-# Maintainer: Franck Lucien Duriez <franck.lucien.duriez@gmail.com>
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+# Contributor: Franck Lucien Duriez <franck.lucien.duriez@gmail.com>
-pkgname="openpose"
-pkgver="1.3.0"
-pkgrel="1"
-pkgdesc="OpenPose represents the first real-time multi-person system to jointly detect human body, hand, and facial keypoints (in total 135 keypoints) on single images."
-arch=("any")
-url="https://github.com/CMU-Perceptual-Computing-Lab/openpose"
+pkgname=openpose
+pkgver=1.5.1
+pkgrel=1
+pkgdesc='OpenPose: Real-time multi-person keypoint detection library for body, face, hands, and foot estimation'
+arch=('any')
+url='https://github.com/CMU-Perceptual-Computing-Lab/openpose'
license=("ACADEMIC OR NON-PROFIT ORGANIZATION NONCOMMERCIAL RESEARCH USE ONLY")
-depends=("caffe" "intel-mkl" "libgl" "glu" "lilv" "boost")
-makedepends=("cmake" "doxygen" "graphviz" "wget")
-source=(
- "https://github.com/CMU-Perceptual-Computing-Lab/openpose/archive/v${pkgver}.tar.gz"
- "GLU.patch"
- "models.patch"
-)
-sha256sums=(
- "5ef834e603dc207c249f49ba672c8bd1895e5a2ffc0ff5548037402a80398bd0"
- "d2e3ad3dd350e494d1e90d595f6b0d4daa76ed9744f7730c22b1803390f1f021"
- "6dfa55f1876778950ed04cbf98f032c4b4129c56c396209837403398e9815f31"
-)
-
-prepare() {
- cd "$pkgname-$pkgver"
- patch -p1 -i "${srcdir}/GLU.patch"
- patch -p1 -i "${srcdir}/models.patch"
-}
+depends=('caffe' 'intel-mkl' 'libgl' 'glu' 'lilv' 'boost')
+makedepends=('cmake' 'doxygen' 'graphviz' 'wget')
+source=("${url}/archive/v${pkgver}.tar.gz")
+md5sums=('ac27f8102c1e8c2e5b51532a46c10181')
build() {
- cd "$pkgname-$pkgver"
+ cd "${pkgname}-${pkgver}"
mkdir -p build
cd build
cmake \
@@ -43,46 +30,44 @@ build() {
-DDOWNLOAD_HAND_MODEL:BOOL=ON \
-DGPU_MODE:STRING=CPU_ONLY \
-DWITH_3D_RENDERER:BOOL=ON \
- -DCMAKE_CXX_FLAGS:STRING="-I/opt/intel/compilers_and_libraries_2018.3.222/linux/mkl/include" \
- -DCMAKE_C_FLAGS:STRING="-I/opt/intel/compilers_and_libraries_2018.3.222/linux/mkl/include" \
+ -DCMAKE_CXX_FLAGS:STRING="-I/opt/intel/mkl/include" \
+ -DCMAKE_C_FLAGS:STRING="-I/opt/intel/mkl/include" \
-DCaffe_INCLUDE_DIRS:PATH="/usr/include" \
-DCaffe_LIBS:PATH="/usr/lib/libcaffe.so" \
- -DCMAKE_INSTALL_PREFIX:PATH="$pkgdir/usr" \
+ -DCMAKE_INSTALL_PREFIX:PATH="${pkgdir}/usr" \
..
make
}
package() {
- cd "$pkgname-$pkgver/build"
-
- # Install libraries.
+ # Install libraries
+ cd "${pkgname}-${pkgver}/build"
make install
- # Install the examples.
- _destdir="$pkgdir/usr/share/OpenPose/examples"
- mkdir -p "$_destdir"
+ # Install the examples
+ _destdir="${pkgdir}/usr/share/OpenPose/examples"
+ mkdir -p "${_destdir}"
find "./examples" -type f -executable \
-not -path './examples/tests/*' \
-not -path './examples/openpose/*' \
- -exec install -D -m755 '{}' "$_destdir" ';'
+ -exec install -D -m755 '{}' "${_destdir}" ';'
- # Install main executable.
- _destdir="$pkgdir/usr/bin"
- mkdir -p "$_destdir"
+ # Install main executable
+ _destdir="${pkgdir}/usr/bin"
+ mkdir -p "${_destdir}"
install -D -m755 \
"./examples/openpose/openpose.bin" \
- "$_destdir/openpose"
-
+ "${_destdir}/openpose"
cd ..
- # Install documentation.
- _destdir="$pkgdir/usr/share/doc/OpenPose"
- mkdir -p "$(dirname "$_destdir")"
- cp -r "./doc/doxygen/html" "$_destdir"
- find "$_destdir" -type f -exec chmod 644 '{}' ';'
+ # Install documentation
+ _destdir="${pkgdir}/usr/share/doc/OpenPose"
+ mkdir -p "$(dirname "${_destdir}")"
+ cp -r "./doc/doxygen/html" "${_destdir}"
+ find "${_destdir}" -type f -exec chmod 644 '{}' ';'
- # Install the models.
- _destdir="$pkgdir/usr/lib/OpenPose"
- cp -r "models" "$_destdir"
- find "$_destdir" -type f -exec chmod 644 '{}' ';'
-}
+ # Install the models
+ _destdir="${pkgdir}/usr/lib/OpenPose"
+ cp -r "models" "${_destdir}"
+ find "${_destdir}" -type f -exec chmod 644 '{}' ';'
+} \ No newline at end of file